Giant Bomb News

97 Comments

A StarCraft II Bug Or Two You Might Want To Know About

Because we care.

The StarCraft II: Wings of Liberty downloader and I don't get along. Because I can't connect to the direct download server, I'm stuck in a peer-to-peer logjam. In an estimated 13 hours or so, I'll be able to experience Blizzard's RTS, which from all the accounts I've read thus far, is a stellar offering. Yet, it's one that isn't without its small share issues. This downloader springs to my mind, but Blizzard has identified more pressing faults on the game's official website.

Perhaps the most important one you should know about at this point is a dandy that can send your computer into a nuclear meltdown. "Certain screens make your hardware work pretty hard," the known issues portion of the site reads, "screens that are light on detail [like a menu screen] may make your system overheat if cooling is overall insufficient." It's a result of the game "drawing the screen quickly." The workaround is to cap the game's frame rate by digging and adjusting file values. 
 

I don't know who this guy is, but I like his beard. I bet we're going to be the bestest of best friends whenever I start playing. 

Windows owners of the game are also reporting crashes when running the game in compatibility mode. But Mac owners are feeling the pain, too. In a message board thread, it's pointed out that there are crashes associated with NVIDIA drivers for owners with OSX 10.6 and that plugging in a USB headset makes the frame rate take a dive--another handy fix, I'd say, for anyone with menu screen meltdown issues.

Have you spotted any issues? I would chime in, but I've got a few more hours of downloading before I get a chance to whiff Jim Raynor's space cigarette smoke or put the hurt on some Zerg.
97 Comments
  • 97 results
  • 1
  • 2
Posted by BradNicholson

The StarCraft II: Wings of Liberty downloader and I don't get along. Because I can't connect to the direct download server, I'm stuck in a peer-to-peer logjam. In an estimated 13 hours or so, I'll be able to experience Blizzard's RTS, which from all the accounts I've read thus far, is a stellar offering. Yet, it's one that isn't without its small share issues. This downloader springs to my mind, but Blizzard has identified more pressing faults on the game's official website.

Perhaps the most important one you should know about at this point is a dandy that can send your computer into a nuclear meltdown. "Certain screens make your hardware work pretty hard," the known issues portion of the site reads, "screens that are light on detail [like a menu screen] may make your system overheat if cooling is overall insufficient." It's a result of the game "drawing the screen quickly." The workaround is to cap the game's frame rate by digging and adjusting file values. 
 

I don't know who this guy is, but I like his beard. I bet we're going to be the bestest of best friends whenever I start playing. 

Windows owners of the game are also reporting crashes when running the game in compatibility mode. But Mac owners are feeling the pain, too. In a message board thread, it's pointed out that there are crashes associated with NVIDIA drivers for owners with OSX 10.6 and that plugging in a USB headset makes the frame rate take a dive--another handy fix, I'd say, for anyone with menu screen meltdown issues.

Have you spotted any issues? I would chime in, but I've got a few more hours of downloading before I get a chance to whiff Jim Raynor's space cigarette smoke or put the hurt on some Zerg.
Posted by RE_Player1

Good to know. I'm a mac owner and I was going to plug in a headset. Thanks Brad. 

Posted by KarlHungus

I have experienced some inconsistent frame rates at times, but other than that I have had no other issues.

Edited by Falx

I've had a really annoying problem that when i save my campaign and quit out and go back to it later the saves havent worked and ive had to repeat 1 or 2 missions again, it only happens when i quit the campaign mode and it goes to the main screen but says it has lost connection to battlenet.

Posted by Rockdalf

I've just gotten a brand new rig, so I should be cool, but I'll monitor my temps while I game the next few times just to be sure it's not going to blow up on me mid game.  Hope it downloads soon.

Posted by EightBitShik

Brad, my roommate had the same problem and it turned out he was uploading way more then it was downloading he was able to do something to make it so that he was downloading more of the information. As far as other problems it seems quite a few people can't get the in game voice chat to work but it works with things like wow and vent just fine.

Edited by Crono

The game's client has been out for over a week before the game's launch, Brad.  It was even posted as news here.  You should have downloaded it before the rush :p
 
Unless you mean for the update?

Posted by GBLatros

Good to know, thanks!

Posted by Falx

Erm, ive just got another problem while trying to post a message in the bug forum "You need a StarCraft II character (created in-game) to post on the forums." and i do have a starcraft 2 character, ive been playing it for almost 2 days.

Posted by MordeaniisChaos

You need to set some stuff up to allow Blizzards downloader to work properly. This isn't to do with SC2 in general, the Blizz Downloader is notoriously finicky. But generally, once you get it going, you should be fine.

Posted by Franstone

My only issue has been the latest mission I've tried to complete has taken me 3 or 4 attempts and I can't seem to beat it yet...
Posted by V_Ben

Yeah, I'm a Mac guy with an Nvidia card, and the game is bricking it for me. Lovely :/

Posted by pap

No problems for me so far.  Actually, I'm just amazed that my little lappy can handle it.  No concerns about frame rate at all - although I've not faced a super-rush yet :)

Posted by Jayzilla

not a blizz gamer but glad to hear everyone is having fun sans the issues i am reading about here.

Posted by Jacob816

I've had some graphical hitches on my 2.5 year old MBP, running OX 10.6. I was able to play the beta at 1440 x 900, with most options set to medium, and things ran pretty smooth. Now the same settings are causing noticeable framerate and slowdown issues, to the point where I had to scale down the resolution and drop a lot of the settings to low. Isn't a finished product supposed to run better then the beta, not worse. Le sigh...

Posted by GreatDane

Im on a Macbok pro unibody: c2d 2,4 ghz, 2gb ram, 9600gt 256 mb.  osx 10.6.
 
And the game runs like shit, cant run medium!  
 
Gotta put all things to minium, and it looks like crap.

Posted by Driadon

No issues here. My big ass laptop eats this game for lunch, which is a relief seeing as when I played the beta on my desktop I got some very inconsistent frame rates

Posted by Myomoto

How the hell does a game that has been in development for so long ship with issues such as "might melt your computer, sorry!". What the eff'?

Posted by 234r2we232

Does this affect the N64 version?

Posted by MSUSteve

I did have SC2 freeze on me last night when examining menu options.  Perhaps it was due to this overheating issue.  I updated my video card drivers and didn't have a problem after that.

Posted by StupidGamer

My first night was full of issues. I have the CE, and I had a failed install on the first attempt, several crashes after finally getting installed on the second attempt, and a corrupted install that forced me to use the Blizzard repair tool. After the 3rd game crash I was only through the second mission in single player and I gave up for the night. 
 
I'm running Windows XP, all settings at Ultra (by recommedation).

Posted by NoXious

I goddamn hate the Haven mission. Had to stop trying after 5 attempts because I just cba with it at the moment. God that mission gets on my nerves. I want those achievements! Finished the mission without getting two of the three achievements :-(
I'll just swap to another mission that I probably can manage till I have the resources to ace that mission.

Posted by letsgohome
@sofacitysweetheart: HAHAHAHHAHAHAAH!
Posted by DjRich

A headset dropping the framerate. What?

Edited by Darko

Protip: if you're trying to use the blizzard downloader and it won't work, download the pirated version from your filesharing service of choice. Don't install any cracks for it, just install it and register as you would your version from Blizzard. Should work.
 
Having said that... I've had no issues.

Posted by Rhombus_Of_Terror

Running the game on an eighteen month old PC build. I can run it at ultra apart from having the texture set to high. The game is beautiful to watch. I just wish the Battlenet loading on start-up could be a little smoother, though that could be down to the router I'm using.

Posted by SSully

 
I run everything with a mix of ultra/high and i turned off reflections but i do get some janky frame rates every now and again. Its only during the cut scenes though, which is a bit odd. Its fine during game play, smooth as butter. I just think its funny that its for the cut scenes because i can get crysis to run at 60 FPS but i get the jitter with star craft cut scenes. 

Online
Posted by Teirdome

There's a part of me that's chuckling after hearing all of the mac issues.  The only friend who had problems last night was the one super proud of his apple logo.

Posted by DoctorWelch

I'v had a few weird connection issues with battle.net where it just logs me out randomly for no reason. It happened once in the middle of a match. It never happens with any other online game I am playing, and I play WoW, so idk what it is.

Posted by HydraHam

Don't you have the disc? why on earth would you use the installer if you have the disc? i bought the CE yesturday, popped in the disc, did the small patch that took maybe 30-40 seconds and was ready to go
 
the only problem i came across was audio problems, huge stuttering problems which got fixed by turning off the echo effect.

Posted by FuzzYLemoN

Guess I got lucky. Mine installed and patched like butter. I was playing with 30 minutes of getting home. Haven't had any issues since then either.

Posted by Gav47

Can anyone tell me is there a V-Sync option?

Posted by Kumo

Brad, the issue is that your upload is choking the download, a common problem with Blizzard's downloader. There's an option in the downloader to disable peer-to-peer downloading, so do that and it will download directly from HTTP servers.

Posted by MachoFantastico

Haven't had any serious issues performance wise, the only issue I've noticed is balancing which still seems a little off. 

Posted by Darko
@Gav47:  Yes. It's in the graphic options
Posted by VisariLoyalist

well, the only reason why people scrutinize blizzard games so much is because people love them so much. I don't think these issues are any worse than issues that most games have at launch especially games which involve such complicated programming with tons of piles of patches to balance the game.

Posted by Boyling

For some reason, the mission archives screen looks super wonky for me, and I do have some framerate issues right at the beginning of most missions. That's about it.

Posted by Deathpooky

When I made my digital purchase the website threw a ton of errors at me, failed, and then charged my credit card 12 times.  I'm guessing billing will solve that, but until then it's a little uncomfortable having $600 in holds on my account.

Posted by TwoLines

It's a PC game, it has bugs.
It's Blizzard, the game'll be patched.

Online
Posted by kratier

i really wish there was someone legitimately discussing the issues about various units not being in multiplayer,
 
and people keep talking about MELEE multiplayer? what is that exactly?
 
And why hasn't blizzard talked about pricing of the next 2 games.

Posted by hsj

I was playing multi and notice my SCVs started idling after they had mined a bit... just sat there, had 4-5 of them doing nothing.  Clearly showed in the economy graph after the game.

Posted by Ben_H

The little bit I've played it on my new 2.4 Ghz C2D MacBook with the 320M has been a great experience thus far.  It runs quite smooth on a mixture of medium and high. 
 
It's much better on my Desktop though but playing on my MBP will be good for at the lake where there's no internet.

Posted by hsj

Also, my Windows 7 mouse cursors are messed up at the moment, I believe that happened when was switching video modes from fullscreen windowed to just fullscreened.

Posted by Gav47
@Darko said:
" @Gav47:  Yes. It's in the graphic options "
So shouldn't that fix the overheating problem?
Posted by plasmafrag

I've been having some loading time issues and choppy framerate when a mission starts on a rig that should be able to handle it.

Edited by Brackynews

How come people didn't just try the demo first to see how it runs on their machine?
 
Oh. Right.

Posted by blacklab

I don't understand why this game would be so technically greedy.  It looks like a bunch of tonka toys fighting.

Posted by Uberjannie
@Ben_H:  The game requires internet just to start, does it not? I even thought you had to stay connected at all times even to play single player.
Posted by Lydian_Sel

That's a real disappointment to hear considering the way most Blizzard games handle on your standard system. Kinda makes me glad I didn't rush out & grab a copy.

Posted by Meowshi
@TomA said:
"

Mr Nicholson your a dumbass, that's Mengsk. And the rest of the people upset or shocked by the download servers sucking ass are dumbasses too. If you knew anything about Blizzard games, you should know that they are terrible for download and patch problems, like this one.

"
I hope you're banned.
  • 97 results
  • 1
  • 2