No Physx. Whos to blame GFWL or Nvidia?

#1 Posted by Funzzo (835 posts) -

I just got the GOTY edition off of steam and installed it. I set my settings and turned physx on. I then started the game but right when you pick your difficulty it crashes. So I did some research and found out that this is a well know problem with this game. So I called GFWL tech support and they told me that since GFWL is part of the game that its not their fault. So I called Nvidia tech support and talked to a guy I could barley understand(very thick indian accent) and he told me I should just install XP on my computer also. Nope not gunna do that. He also told me that physx is not fully compatible with win 7 and game like BM:AA. WTF batman came out in 09 I thought. Why the fuck make a game not compatible. Such bullshit. O and both people I talked to had no idea what game I was talking about. They both said "I'm not a gamer". I know it's not a huge issue but come on people we cant put up with kind of shit or companies will just keep getting worse when it comes to product quality and customer service.
#2 Posted by WilliamRLBaker (4777 posts) -

huh...what does being a gamer have to do with customer service?

#3 Posted by Geno (6477 posts) -

I played the non-GOTY version with PhysX just fine. Doesn't the GOTY version just add some extra challenge maps or something? I don't see how that would interfere with PhysX. 

#4 Posted by Funzzo (835 posts) -
@Geno said:
"I played the non-GOTY version with PhysX just fine. Doesn't the GOTY version just add some extra challenge maps or something? I don't see how that would interfere with PhysX.  "


What OS are you using?
#5 Posted by Geno (6477 posts) -
@Funzzo: Windows 7 64-bit HP.
#6 Posted by ATrevelan (606 posts) -

That's a really weird problem. I'm also using Win 7 64 HP and I've got physx working totally fine on the original edition. GOTY shouldn't change anything except a few new challenge maps.

#7 Posted by Funzzo (835 posts) -
@Geno said:
" @Funzzo: Windows 7 64-bit HP. "
@ATrevelan said:
" That's a really weird problem. I'm also using Win 7 64 HP and I've got physx working totally fine on the original edition. GOTY shouldn't change anything except a few new challenge maps. "
Did you guys install to the default C: location?
#8 Posted by ectoplasma (974 posts) -

Maybe u should ax them if they have a different gfx card first.

#9 Posted by warxsnake (2648 posts) -

physx worked fine for me for all games that support it, all my games are steam purchases that are not on the system drive. GTX260

#10 Posted by ATrevelan (606 posts) -
@Funzzo: I did not. I've got a dedicated games partition.
#11 Posted by Geno (6477 posts) -
@Funzzo: Steam for me. 
#12 Posted by Baillie (4079 posts) -
@Funzzo: I don't know why you're blaming tech support. Nvidia and GFWL are clearly the wrong people to attack. Also - Windows 7 64-bit - I used that and physx worked fine.
#13 Posted by HitmanAgent47 (8576 posts) -

I also have the game on steam, an earlier edition, phyX is enabled and it works for me. I don't have the game of the year edition though. I'm using vista 32 bit.

#14 Posted by Metal_Mills (2989 posts) -

May I ask what graphics card you have? If it isn't a really good card, preferably a duel GPU then I wouldn't bother.

#15 Posted by Funzzo (835 posts) -
@Metal_Mills: 
Im using a gtx295 nvidia.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.