My Arkham City PC disc refuses to work

#1 Posted by Sprucegrove (10 posts) -

A strange thing happened. Got my copy of Arkham City for PC yesterday, installed it, played it, loved it. However, today when I started up my computer, the disc is unreadable. My PC can't even find the disc itself. This problem is with disc 1, disc 2 works perfectly fine but that won't really help me since I tried to solve the problem by uninstallning the game. Big Mistake. Has anyone else had this problem or did I just get a broken disc? I've done some research on Google about the problem but I can't find a solution.

#2 Posted by MayorFeedback (674 posts) -

Return it for a new copy.

#3 Posted by jetsetwillie (857 posts) -

turn the disk over check for greasy finger prints or any filthy stains you might of left on it.

#4 Posted by Sprucegrove (10 posts) -

Yeah, that was my first idea as well. The strange thing is that it seems to work on my roommate's computer, and all other discs I put in my computer works as well. I'm just curious to see if it's a common problem with the PC version.

#5 Edited by RIDEBIRD (1232 posts) -

Activate the code in Steam and download the game. It's Steamworks afaik. If you can't download it, try burning a copy of it or something.

#6 Posted by Sprucegrove (10 posts) -

@Ertard said:

Activate the code in Steam and download the game. It's Steamworks afaik.

I tried it and it didn't work. Valve doesn't seem to support it as a third-party release on Steam according to their official list. That would've solved my problem pretty quick, though. :(

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.