Minerva's Den PC problems - Or how I hate Games for Windows Live

#1 Posted by ds8k (414 posts) -

After listening to the Bombcasters gush over Minerva's Den I decided I wanted to check it out. I own the Steam version of BioShock 2 and already knew that it was only available through the Games for Windows Live Marketplace. I started up the program on my computer, only to be greeted by a page telling me to go to their website.

I go there, log in, buy the game and then restart the Marketplace program. This is where the trouble starts.

After downloading the DLC, Marketplace tells me that it can't be installed. I click retry, but nothing changes. I delete the files, thinking maybe they became corrupted at some point during the download, and wait for it to download again.

Cannot be installed.

Flabbergasted at this point, I head to the internet. I find that a lot of people are having this same problem. After a few minutes of sleuthing I come upon a most mind-boggling solution:

Start the download then change your computer's time to June 2011.

A major "wat" indeed, but at this point I was desperate to try anything. Did exactly what was said and voila! I can now play the video game that I spent money on. It's pathetic that such a thing needs to be done, but that's GfWL for you. Why companies can't accept that Steam handles all of this much better is beyond me. These sorts of work-arounds should not need to exist at this point.

#2 Posted by MrSensible (17 posts) -

Oh hey, someone had the same problem.

I tried the time-change workaround but it just causes the download to fail at 23.7% every time because the BITS service times out.

#3 Posted by Ben_H (3430 posts) -

I think I'm finally starting to understand just why people hate GFWL.  I never used to have issues but I am now. Your issue sounds super annoying and a lot like the many I've been dealing with. This evening I was setting up Dirt 2, which also has GFWL, and apparently it updates through that system instead of through Steam like it logically would. The update downloads were super slow (at the same time I was getting 40 megabit speeds from Steam so it wasn't on my end), and it forced me to relogin 3 separate times even though I had it set to remember my email and password, and it forced me to put in the key even though that key is already registered to my GFWL account (I was reinstalling after formatting my desktop). And then it kept loading my "settings" from my profile (which were not my settings, and for some reason kept forcing it into 1024x768 windowed mode) so I had to force it to fullscreen even though in the settings it was set to supposedly be fullscreen already. It took almost 20 minutes in total to get the game working. In the end I was so annoyed I ended up just quitting that game and playing Diablo II.

#4 Posted by ds8k (414 posts) -

@StarmanDeluxe: Mine failed in the middle as well but luckily it started back up after clicking retry.

#5 Posted by MrSensible (17 posts) -

@ds8k: Thanks for the tip. I restarted the download and it finished, but I'm getting the same 8007000D error because of corrupt data. GFWL is downloading the Minerva's Den install package as five separate .CAB files, and the 2nd and 4th files are corrupt when I try to extract them manually.

Could anyone who actually pulled these files down send me a PM? Normally I wouldn't grovel but I'm at my wits' end with this damned service.

#6 Posted by BaconGames (3574 posts) -

I too was hoping to jump on for 5 bucks no less but now I can afford to wait to see what fixes people come up with in the future.

#7 Posted by Shookems (474 posts) -

I still haven't ever been able to play bioshock 2 because game for windows live will not fucking update it.

#8 Posted by mordukai (7185 posts) -

@Shookems said:

I still haven't ever been able to play bioshock 2 because game for windows live will not fucking update it.

Don't worry. You're not missing much.

#9 Posted by Shookems (474 posts) -

@mordukai: That doesn't change the fact that I paid for a game and got nothing out of it.

#10 Posted by mordukai (7185 posts) -

@Shookems: No it doesn't. I haven't had any dealing with GFWL, and I don't intend to any time in the future, but I have to know why you can't play it? I mean I know it won't update it but you really can't start up the game if it's not updated?

#11 Posted by Shookems (474 posts) -

@mordukai: Basically GWFL wouldn't update the game. I'd open it up, I'd get the pop up to update. Game would close and try to update, then when it reopened I would still be running 1.0 and the process would start over again.

Tried manual patching, tried reinstalling the game, tried verifying game cache, everything.

#12 Posted by oueddy (59 posts) -

Wasted 2 hours trying to get this to work to no avail, I can't seem to install any DLC with GFWL anymore and this issue is nowhere else on the net. I'll leave it here for google.

They all fail installing with the same very obscure issue -

2012-11-18T00:58:13 Error Installing Failed to install license. {Exception: {Type: System.Runtime.InteropServices.COMException} {Message: Not enough storage is available to process this command. (Exception from HRESULT: 0x80070008)} {Source: mscorlib} {Stack Trace: at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo) at Microsoft.GamesForWindows.XLiveServices.ContentManagement.PackageManager.InstallLicenseInternal(PackageInstallerContext context)} {Target Site: Void ThrowExceptionForHRInternal(Int32, IntPtr)}}

Its nice that the GFWL support page has been removed so we can't query anything.

#13 Posted by michaelfossbakk (236 posts) -

Is Minerva's Den really only available on the PC via GFWL? That kind of blows. I heard it was a great piece of DLC, but really? GFWL only? I'm considering buying BioShock 1 and 2 for $5 total on Amazon (with Steam activation) right now. I guess if I really want to play Minerva's Den, I'll have to jump through some hoops.

#14 Posted by Beforet (2933 posts) -

And suddenly, I'm thankful I got Bioshock 2 on PS3.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.