Bioshock Infinite PC version thread

  • 139 results
  • 1
  • 2
  • 3
#51 Posted by xdaknightx69 (448 posts) -

is the FOV a problem for anyone else?

i maxed out the slider but when ingame my eyes start to hurt after a while, had the same problem in previous bioshock games. i think the default FOV is 75?

#52 Posted by xSeanZx (188 posts) -

@zenmastah said:

Damn, even at 1920x1200 im maxing my 2GB card..knew i shouldve gone with the 4GB versions.

If anyone is getting drops to 30 from 60 btw, enable vsync and tripple buffering via D3DOverrider and disable the ingame vsync.

Thanks alot dude lol im not joking is in game vsync broke because i did as you said but with nvidia settings and i swear i got huge fps increase i went from 30-60 on gtx 580 to 60fps ultra no drops what so ever even in skyline or large battles.

What and where did you do this exactly?

I have a Matrix GTX 580 and on Ultra the game bogs down pretty hard.... even on high it seems like it does.

I updated my drivers already as well

#53 Edited by SithToast (165 posts) -

I'm just sad that the game crashes on me when I try to play it for more than 5 minutes. Apparently a bunch of dudes are having the same issue.

#54 Edited by Intro (1205 posts) -

EVGA GTX 660 running on normal and high settings fine. Looks pretty good to me.

Also, that scene right after you're about to throw the baseball is great.

#55 Posted by mostman (248 posts) -

@intro: I have a 660 as well - you have your settings on high? I had mine set to Very High, but I was getting drops down to 30 pretty often. I'm trying to get it to be 60 all the time.

#56 Posted by Zurv (439 posts) -

running fine maxed with 2560x1600 on 3 titans... as it should for the cost

Online
#57 Posted by BeachThunder (11689 posts) -

is the FOV a problem for anyone else?

i maxed out the slider but when ingame my eyes start to hurt after a while, had the same problem in previous bioshock games. i think the default FOV is 75?

Have a look over here.

#58 Posted by OfficeGamer (1087 posts) -

@xdaknightx69 said:

is the FOV a problem for anyone else?

i maxed out the slider but when ingame my eyes start to hurt after a while, had the same problem in previous bioshock games. i think the default FOV is 75?

Have a look over here.

Very nice

#59 Posted by xdaknightx69 (448 posts) -

@xdaknightx69 said:

is the FOV a problem for anyone else?

i maxed out the slider but when ingame my eyes start to hurt after a while, had the same problem in previous bioshock games. i think the default FOV is 75?

Have a look over here.

thanks!

#60 Edited by crimson26 (49 posts) -

@xseanzx said:

@crimson26 said:

@zenmastah said:

Damn, even at 1920x1200 im maxing my 2GB card..knew i shouldve gone with the 4GB versions.

If anyone is getting drops to 30 from 60 btw, enable vsync and tripple buffering via D3DOverrider and disable the ingame vsync.

Thanks alot dude lol im not joking is in game vsync broke because i did as you said but with nvidia settings and i swear i got huge fps increase i went from 30-60 on gtx 580 to 60fps ultra no drops what so ever even in skyline or large battles.

What and where did you do this exactly?

I have a Matrix GTX 580 and on Ultra the game bogs down pretty hard.... even on high it seems like it does.

I updated my drivers already as well

Disable frame rate lock in game

Open nvidia setting in task bar

Go to manage 3d settings

In Global settings scroll down to bottom two settings should be triple buffering and vertical sync at bottom.

Set both to on and apply.

Play the game

Note this will apply these settings to all your games so make sure you to disable it if you dont want it for all your pc games it will force it for all them otherwise. Just hit restore when you dont want it any more.

#61 Edited by 00 (113 posts) -

Standard V-Sync will lock the framerate to your refresh rate (usually 60Hz) or a multiple of it, if it can't hit that target. (30fps, 20fps, 15fps...) The jump between 30 and 60 is very jarring to me.

Nvidia cards have the option of adaptive v-sync in the drivers which will enable v-sync when the framerate is at or above your refresh rate, but disables it when it drops below that, allowing the game to tear, but maybe only drop down to 50fps rather than being forced to drop to 30fps. (I hate tearing, but prefer this to dropping down to 30fps as long as it is not constantly below 60)

Alternatively you can use D3DOverrider to try and force Triple Buffering, which will allow the game to drop to any framerate below your refresh rate without tearing, but it does introduce an extra frame of lag, and it's still going to stutter when it does this as it's out of sync with your refresh rate.

The driver control panel setting for triple buffering only applies to OpenGL, it does not work with Direct3D games. (BioShock, along with most games these days, is a Direct3D game)

You also have the option to enable v-sync set at half the refresh rate to cap the game to (typically) 30fps if you want a more consistent experience, but I personally can't stand anything less than 60.

Performance in the game has been absolutely terrible for me with my GTX570. Unless I turn textures down to low, I get constant stuttering/framerate drops. I think something is broken with the texture caching or there's a memory leak or something, because at anything above low my VRAM usage goes up to 100% after a minute or two of playing, and then it starts stuttering really badly when I move between rooms or turn around quickly - it feels like playing an old game back when hardware was slow enough that streaming data off the HDD caused it to hiccup, but I'm playing the game off a very fast SSD so it can't be that. (people have even tried running it off a RAM Disk and it still happens)

I'm thinking that I might put the game on hold until it's patched to fix this, or someone finds a fix (the "PoolSize" tweak did nothing for me) because I really can't stand to play games at anything less than a solid 60fps, and I'm not enjoying it much so far. (just feels exactly like BioShock 1 & 2 with a new coat of paint)

#62 Edited by BeachThunder (11689 posts) -

Sigh, someone really needs to figure out a way to remove the HUD; the health bar even remains in non-combat areas =(

#63 Edited by Colourful_Hippie (4330 posts) -

Damn, even at 1920x1200 im maxing my 2GB card..knew i shouldve gone with the 4GB versions.

If anyone is getting drops to 30 from 60 btw, enable vsync and triple buffering via D3DOverrider and disable the ingame vsync.

Where do you download d3doverrider? The game still drops and jumps between 30 and 60 when enabling vsync through nvidia control panel.

#64 Edited by xSeanZx (188 posts) -

@zenmastah said:

Damn, even at 1920x1200 im maxing my 2GB card..knew i shouldve gone with the 4GB versions.

If anyone is getting drops to 30 from 60 btw, enable vsync and triple buffering via D3DOverrider and disable the ingame vsync.

Where do you download d3doverrider? The game still drops and jumps between 30 and 60 when enabling vsync through nvidia control panel.

Yeah I experienced this too..... Im shocked that my 580 cant run this game perfectly fine on high or very high

#65 Posted by Colourful_Hippie (4330 posts) -

@xseanzx said:

@colourful_hippie said:

@zenmastah said:

Damn, even at 1920x1200 im maxing my 2GB card..knew i shouldve gone with the 4GB versions.

If anyone is getting drops to 30 from 60 btw, enable vsync and triple buffering via D3DOverrider and disable the ingame vsync.

Where do you download d3doverrider? The game still drops and jumps between 30 and 60 when enabling vsync through nvidia control panel.

Yeah I experienced this too..... Im shocked that my 580 cant run this game perfectly fine on high or very high

It's a problem with the in game vsync, not your hardware. When the game dips a bit below 60 it defaults to 30 which makes it jarring.

#66 Posted by RedRavN (397 posts) -

One other thing you can do to get around the v-sync issue is to disable it in game but use a frame limiter. I use MSI afterburner to cap my framerate at 58fps. This way you can get smooth game play and no screen tearing.

#67 Edited by I_Stay_Puft (3005 posts) -

was reading specs on the pc version but does this game seriously need 30 gb install? Think the last pc game needing that much space was probably Max Payne 3.

#68 Posted by BeachThunder (11689 posts) -

was reading specs on the pc version but does this game seriously need 30 gb install? Think the last pc game needing that much space was probably Max Payne 3.

where did you get 30 from? The game takes up ~17 on my computer...

#69 Posted by I_Stay_Puft (3005 posts) -

@i_stay_puft said:

was reading specs on the pc version but does this game seriously need 30 gb install? Think the last pc game needing that much space was probably Max Payne 3.

where did you get 30 from? The game takes up ~17 on my computer...

Got it from the recommended setting on the Bioshock Inf. wiki page. Minimum was 20 gb and recommended was 30 gb. I'm assuming either patches or dlc in the coming future.

#70 Posted by Colourful_Hippie (4330 posts) -

@redravn:How do you limit the frames in Afterburner?

#71 Edited by ectoplasma (961 posts) -

@zenmastah: Wow I'm gonna check this out. The game runs smooth on 7870 xt + 3,6ghz Phenom II 955 on Ultra specs (I put the Shadows on the second highest level is all) but I get drops to 30 fps when loading new data in some cases. Apparently everyone gets this. I'm trying your workaround.

#72 Edited by kishinfoulux (2253 posts) -

@xseanzx said:

@colourful_hippie said:

@zenmastah said:

Damn, even at 1920x1200 im maxing my 2GB card..knew i shouldve gone with the 4GB versions.

If anyone is getting drops to 30 from 60 btw, enable vsync and triple buffering via D3DOverrider and disable the ingame vsync.

Where do you download d3doverrider? The game still drops and jumps between 30 and 60 when enabling vsync through nvidia control panel.

Yeah I experienced this too..... Im shocked that my 580 cant run this game perfectly fine on high or very high

The drops from 60 to 30 usually last like a few seconds so it doesn't really bother me too much. Generally in enclosed spaces I've noticed. Also running with a 580. Other then that running on Very High and generally stays at 60.

#73 Posted by sodapop7 (204 posts) -

Game freezes for me as soon as I get to the Columbia statue. Tried on all different settings. Hope they get this figured out soon because its pretty frustrating playing the same 5 minutes over and over.

#74 Posted by 00 (113 posts) -

@colourful_hippie said:

It's a problem with the in game vsync, not your hardware. When the game dips a bit below 60 it defaults to 30 which makes it jarring.

That's not a problem with the game - that's just how v-sync works.

The problem is that even on hardware that should be capable of running at a locked 60fps, something is causing the game to drop huge amounts of frames. I'm convinced it's a caching/memory management issue now, because I've just played another hour of the game, and every time it happens my GPU usage drops from around 70% or so (where it normally lies) to below 40% when it's stuttering badly. So it's definitely not GPU load causing the framerate problems - it's something else going wrong in the engine.

@redravn said:

One other thing you can do to get around the v-sync issue is to disable it in game but use a frame limiter. I use MSI afterburner to cap my framerate at 58fps. This way you can get smooth game play and no screen tearing.

You do have screen tearing - you either don't notice it because it's right at the top/bottom of the frame because you're lucky with how 58fps syncs to your monitor, or it's hidden by overscan if your display is using it.

It's not possible to run without v-sync at all and not have tearing. (triple buffering is an extension of v-sync's double buffering)

You don't need to run MSI Afterburner for that either, the Nvidia drivers have a framerate limiter built in, which you can access via Nvidia inspector. (it just changes the setting, rather than running in the background)

But doing this shouldn't give you smoother gameplay - the game is either running synced to your refresh rate (smooth) or it isn't. (stutters)

All it will do is stop the game rapidly switching between 60/30fps which can be jarring. This is better accomplished either with Nvidia's adaptive vsync (only tears when below 60fps, rather than constantly) or by forcing triple buffering. (never tears, but has an extra frame of latency)

The only way to eliminate stutter is to have the game never drop below 60fps.

#75 Posted by zenmastah (874 posts) -

@colourful_hippie:

Try this, i enabled triple buffering and vsync with it and disabled it in game, i also capped my framerate to 60 with MSI Afterburner. Pretty solid 60 so far, it only dips when its loading something new or when my VRAM is full..and i dont get why its full so quickly btw, seems like theres something going on with the engine maybe.

I also tried the Poolsize increase thingy with the XEngine .ini file and that helped quite a bit.

#76 Posted by Vitor (2809 posts) -

@redravn:How do you limit the frames in Afterburner?

Bring up the minimised program in the toolbar - should look like a jet with a 60 above it.

Click on the plus symbol at the bottom and add the bioshock infinite .exe. Then set application detection level to high, click on the picture of the tool above and enter the FPS limit in the last box.

#77 Posted by Colourful_Hippie (4330 posts) -

@vitor:I must be blind, I don't see the plus symbol.

#78 Edited by 00 (113 posts) -
@zenmastah said:

Try this, i enabled triple buffering and vsync with it and disabled it in game, i also capped my framerate to 60 with MSI Afterburner. Pretty solid 60 so far, it only dips when its loading something new or when my VRAM is full..and i dont get why its full so quickly btw, seems like theres something going on with the engine maybe.

You shouldn't have to cap the framerate if you have v-sync enabled - if you do, it can actually lead to increased stuttering.

However, I've just come across this, and from a brief amount of testing, it seems to have actually fixed the stuttering:

Set bUseBackgroundLevelStreaming=false in

\Users\###\Documents\My Games\BioShock Infinite\XGame\Config\XEngine.ini

#79 Edited by zenmastah (874 posts) -

@00:

Capping the framerate fixed my stuttering in Sleeping Dogs, so..

Going to try that streaming fix next, thanks.

**edit

holy hell, that streaming fix eliminated all of the stuttering, its so goddam smooth now.

#80 Edited by ectoplasma (961 posts) -

@00: That your GPU usage drops might as well just be because you reached a hypertransfer or CPU limit. Like in Tomb Raider I had solid 60 fps as long as I was in smaller areas but on 2 of the large maps my fps dropped to 20 and my GPU load also dropped to 40% but it was because it was CPU limited (and that without even a single cores reaching over 90% load).

#81 Posted by Colourful_Hippie (4330 posts) -

@00:

Capping the framerate fixed my stuttering in Sleeping Dogs, so..

Going to try that streaming fix next, thanks.

**edit

holy hell, that streaming fix eliminated all of the stuttering, its so goddam smooth now.

Same here, thanks!

#82 Edited by RVonE (4603 posts) -

@colourful_hippie said:

@zenmastah said:

@00:

Capping the framerate fixed my stuttering in Sleeping Dogs, so..

Going to try that streaming fix next, thanks.

**edit

holy hell, that streaming fix eliminated all of the stuttering, its so goddam smooth now.

Same here, thanks!

Disabling background streaming, does that also have a downside? Like reduced level of detail or whatever?

EDIT: according to some users on GAF setting background streaming to disabled makes the game glitch in certain cases where specific interactions have to be loaded in.

#83 Edited by mostman (248 posts) -

Oh. Damn. Maybe that's why my raffle is all sorts of screwed up. Let me turn that thing back on and see if the raffle gets fixed.

#84 Posted by RVonE (4603 posts) -

@mostman said:

Oh. Damn. Maybe that's why my raffle is all sorts of screwed up. Let me turn that thing back on and see if the raffle gets fixed.

I hope that works out for you. One user reports that resetting that bit does allow the game to load in the required elements but it still fails to initiate the actual interaction.

#85 Posted by Vitor (2809 posts) -

@00 said:
@zenmastah said:

Try this, i enabled triple buffering and vsync with it and disabled it in game, i also capped my framerate to 60 with MSI Afterburner. Pretty solid 60 so far, it only dips when its loading something new or when my VRAM is full..and i dont get why its full so quickly btw, seems like theres something going on with the engine maybe.

You shouldn't have to cap the framerate if you have v-sync enabled - if you do, it can actually lead to increased stuttering.

However, I've just come across this, and from a brief amount of testing, it seems to have actually fixed the stuttering:

Set bUseBackgroundLevelStreaming=false in

\Users\###\Documents\My Games\BioShock Infinite\XGame\Config\XEngine.ini

I cannot recommend enough that people DO NOT do this.

I did, and while it fixed the streaming (hitches still happened but it was much less frequently), some levels now refuse to load.

If you do this, you may get stuck on an infinite (no pun intended) loading screen when trying to re-enter certain areas.

#86 Edited by RVonE (4603 posts) -

This seems like a viable way to reduce the amount of stuttering caused by the game streaming in content.

EDIT: the above link now shows a different fix than I intended. Please don't change background streaming to false.

#87 Edited by TooWalrus (13135 posts) -

I'm... not quite sure I can explain why my screen folder is full of a billion pictures of Elizabeth.

#88 Posted by Vitor (2809 posts) -

@rvone said:

This seems like a viable way to reduce the amount of stuttering caused by the game streaming in content.

Don't do this - it screws up the engine and causes infinite load screens when re-entering areas.

#89 Posted by mostman (248 posts) -

@rvone said:

@mostman said:

Oh. Damn. Maybe that's why my raffle is all sorts of screwed up. Let me turn that thing back on and see if the raffle gets fixed.

I hope that works out for you. One user reports that resetting that bit does allow the game to load in the required elements but it still fails to initiate the actual interaction.

No dice. So - I've disabled steam cloud and nuked my saved game. Starting over. Hopefully this will fix it.

#90 Edited by SpudBug (633 posts) -

Was having a great time with this on my 670 and i7 2700k.

About two hours in when you start riding the skylines or whatever, the game turns into this very odd, stuttery slideshow - MSI Afterburner says i'm running at 51-60 fps but the game looks like 10 fps. WTF?

And I am using d3doverrider and in-game vsync off. I used that for a lot of games so I know the feeling of jumping down to 30fps when it can't maintain 60 (crysis 3 was bad at this) and this is much worse.

Its' like the game is running at a high framerate, but what it's displaying is lagging behind. It must be some kind of memory leak issue. There's no way this game is more demanding than Crysis 3 at near max or Tomb Raider at near max on a 670.

#91 Edited by thetenthdoctor (291 posts) -

The shit we go through for a little more resolution and frame rate, eh?

I'm playing on a GTX470, everything on Ultra and locked @ 30fps via RivaTuner. Stutters occasionally when loading new areas, but looks and plays way better than a console game. I'm staying far away from any .ini tweaking.

#92 Edited by RVonE (4603 posts) -

@vitor said:

@rvone said:

This seems like a viable way to reduce the amount of stuttering caused by the game streaming in content.

Don't do this - it screws up the engine and causes infinite load screens when re-entering areas.

I see the page changed. The fix I was referring to wasn't setting background streaming to false--in my previous posts in this thread I already pointed out that that leads to disaster.

#93 Posted by Karkarov (2980 posts) -

Game looks great on pc, seriously. Anyone who thinks the textures weren't up to snuff was never going to be satisfied no matter what they looked like. Make sure to download the newest non beta drivers for whatever graphics card you have, both companies just released new ones for this game.

For the record I am playing it maxed out with as wide a field of view as possible at 1080. I use a 670 gtx, a 2600k i7, and 16 gig ram. I am running over 70 fps most of the time with a dip to low 60 high 50's here and there. When fraps is running I still get mid 30's.

#94 Edited by SpudBug (633 posts) -

I don't know if it will come back after playing for a certain amount of time, but the following fix seems to have helped a LOT. It's very, very smooth now.

- Open BaseEngine.ini (Bioshock Infinite/Engine/Config)

- Increase [MemoryPools] values to 512 or 1024. ( I used 1024)

- Set MaxSmoothFrameRate to 59 FPS.

along with using Nvidia Control Panel to set Triple Buffering and Adaptive Vsync the game was working much much better than before. I'm on a GTX 670.

#95 Posted by RVonE (4603 posts) -

@karkarov said:

Game looks great on pc, seriously. Anyone who thinks the textures weren't up to snuff was never going to be satisfied no matter what they looked like. Make sure to download the newest non beta drivers for whatever graphics card you have, both companies just released new ones for this game.

For the record I am playing it maxed out with as wide a field of view as possible at 1080. I use a 670 gtx, a 2600k i7, and 16 gig ram. I am running over 70 fps most of the time with a dip to low 60 high 50's here and there. When fraps is running I still get mid 30's.

How far along in the game are you? You say you have it maxed out, does that include ultra shadows and the highest setting for AO?

The early part of the game runs really well, but you should be seeing significant slow-down a little ways into the game with those settings.

#96 Posted by LiquidPrince (15842 posts) -

So apparently its running very well on teh PC, also nVidia and AMD have released drivers so be sure to upgrade your GPUs.

And apparently there wont be additional HD textures after all, what you download from Steam is what you get.

Not gona lie, kinda bummed.

Which new drivers are you talking about? I'm running 13.3 beta 3. Newer then that?

#97 Posted by LiquidPrince (15842 posts) -

@zurv said:

running fine maxed with 2560x1600 on 3 titans... as it should for the cost

Hey I didn't know you were a Giantbomb member. I watch your stuff on Youtube all the time. Always leave comments too. Your setup is too crazy.

Anyways, for people having issues with the game, it may be the fact that you have the POST PROCESSING setting set to ALTERNATE. It's some sort of DX11 setting that changes the way depth of field effects are rendered. Doesn't look any different to me, so I set it to normal which the game touts as the WAY IT WAS ORIGINALLY MEANT TO BE SEEN or something along those lines. Anyways, with my 7970 at 1080P Ultra settings all around, I'm getting a solid 60FPS.

#98 Edited by zenmastah (874 posts) -

@vitor:

Goddam it, it was so smooth while it lasted......

#99 Edited by Caustic_Fox (112 posts) -

Just curious - Is this just game as demanding as Battlefield 3? BF3 is the limit of what my shitty GTX 260 can handle.

#100 Posted by AiurFlux (901 posts) -

I'm having framerate dumps to below 30 with two 570's in SLI so I'm kind of relieved to see that it's not me but rather it might be a memory leak. I can wait... I guess. Or maybe I'll try it on my wife's computer instead since she has a 7970 and maybe it's just an nVidia issue kind of like Tomb Raider.

Either way it's a beautiful game and what I played of it was quite good. Might even try 1999 Mode and see how that goes.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.