Can't connect to the Blur Servers (PS3)

#1 Posted by D_W (1127 posts) -

Anyone else having this issue? I have no problem playing other games online but this one never connects to the servers.
#2 Posted by D_W (1127 posts) -

So from what I've read on other forums a lot of people are having this issue and it doesn't seem like there is any intention to resolve it. I guess I wasted 60 bucks on this game. Might as well return it.
#3 Posted by get2sammyb (6412 posts) -

Working absolutely fine for me. I'm in the UK. All features - Twitter, Facebook and online multiplayer are working great. Not had any drop-outs either.
 
Hold out for a patch.

#4 Posted by Rhombus_Of_Terror (2089 posts) -

it's probably early start server issues which they iron out over time. the Beta wouldn't have done much other than given people early access to the game so that won't count.

#5 Edited by CLemATic (32 posts) -

im having the same issue. i hope they fix it else i am returning and getting Mod Nation instead.
Edit: i figured out how to fix it. i changed some settings in my router that weren't allowing my ps3 to play blur online.

#6 Posted by Xeiphyer (5596 posts) -
@IntramanDW said:
" So from what I've read on other forums a lot of people are having this issue and it doesn't seem like there is any intention to resolve it. I guess I wasted 60 bucks on this game. Might as well return it. "
I'm having the same problem, seems they are still retarded about it. 
 
@CLemATic: What did you change specifically to make Blur work? I have tried putting my PS3 into DMZ mode which should have made it work but it didnt... >_>"
#7 Posted by BigAT (70 posts) -

I'm having the exact same problems and it's extremely frustrating.   
 
I've never had problems connecting to any other game on my PS3.  I even tried port forwarding and DMZing my PS3, it didn't work at all. 
 
It does seem like a lot of people are having this problem, and there doesn't seem to be any solution available.  Does anyone have any ideas?

#8 Posted by Rhombus_Of_Terror (2089 posts) -
@BigAT: a patch for European and Australian copies of the game was issued in the last 2 weeks and fixed a lot of the online problems all apart from matchmaking or actually finding games that are ready to start,  where by you find yourself in a lobby that is still racing and you have to wait for them to finish.
 
Also they still haven't fixed the number of people playing online, i am only able to see that there are at least 1000 people playing online when i race, which is a terrifyingly small number for such a game. I assume the game sold a lot more than a 1000 units, or that the servers only do a local search of players, which results in the waiting game for a race. So that needs fixing.
#9 Posted by RobbieMac (534 posts) -
@RhombusOfTerror: No that seems about right on the xbox there are only about 1000-2000 people on at the times I get on.  Sometimes even in the hundreds.
#10 Posted by garnsr (97 posts) -

I just picked it up on PS3 today, and it always says it can't find the servers.  t hasn't connected once.  I tried changing the port forwarding and DMZ stuff on the router, but it still doesn't work.  All the posts I've seen on Google are from a couple weeks ago, too, I don't know if it's gotten better for some people or they just aren't posting.

#11 Posted by Xater (25 posts) -

Got the game today and can't connect to the servers at all. The demo worked fine...

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.