Huge PC audio issues in Borderlands

#1 Posted by StaticInSnow (37 posts) -

Bought this in the steam sale last week, it loads up fine and runs well...but there are really bizzare audio issues.  If headphones are plugged in, sound comes out of the internal speakers anyway.  Then when I exit Borderlands sound from other applications still comes from the speakers and the laptop doesn't recognise the headphones, so it has to be restarted. As my laptop uses the headphones jack also for external speakers, then there's no way to play this without using the crappy tinny internal laptop speakers I have.
 
Really fucking dissapointed, been searching for a while for a fix to this but to no avail.  The lack of options in the audio menu is infuriating. I'd heard the pc version was a bit gimped, but this takes the piss.

#2 Posted by mosespippy (4430 posts) -

That's what you get for buying an inferior version of the game, even knowing that it was inferior.

#3 Edited by Geno (6477 posts) -

Do you have your latest audio drivers? Check your laptop manufacturer's website for that, having some sort of identification ready (your laptop should have some sort of ID or service code). Should also be possible to get from Windows Update. 
 
Also, a remote fix but it has worked before on some bizarre problems. Try going to your sound properties and adjusting your speakers and headphones to use 44.1Khz sound. 

#4 Posted by StaticInSnow (37 posts) -
@mosespippy:  

 It was in the sale, and I'd not heard of any issues like this, nor have I encountered them in any game ever.  Forgive me for wanting to play the game and just look past some minor flaws.
 
Your input is appreciated though. It really helps. A lot. 
#5 Edited by MrKlorox (11209 posts) -

What about other Unreal 3 engine games? Do those work fine? Vista or Win7? Try checking or unchecking the "Allow applications to take exclusive control of this device" box in the device properties box in the windows sound settings thing.
 
Do your internal speakers and headphones show up as different devices in the windows sound settings?

#6 Posted by HellBrendy (994 posts) -
@StaticInSnow:  Don't worry, the PC version holds nothing back from the consoleversion. Only "problem" is the menu, where the use of a controller rather than a keyboard is obvious. After they fixed the online settings as well, Borderlands is a top of the class game! Hope you get the problem fixed soon. 
#7 Posted by Navissor (1 posts) -

@StaticInSnow: Hey mate, i had the same issue for the first time today after months of having borderlands...but i think i fixed it. What i did was i went into the control panel/hardware and sound/sound and i went into the properties of the main communication device. In my case it was Speakers and Dual Headphones, it would most likely be the same thing for you if you're on a laptop. As Geno said, i switched my sound quality down to 44.1Khz. I then just right clicked on the Speakers and Dual Headphones in the Sound box, and "set as default communication device" 
 
I hope this helps 
 
Navi
#8 Posted by KerrBurr1996 (1 posts) -

I believe I have fixed the problem. I exited out of the game and went to borderlands and started watching the gameplay video, the gameplay video had no noise and there was a little icon on the video that showed a speaker that had a slash indicating it was off, so I clicked it and got sound on the video then I started the game and BOOM sound! Hope it works for you :)

#9 Posted by jimmieiversen (1 posts) -

Many audio related issues can also appear because of you audio quality settings. etc. in Realtek be sure to set your audio quality to 48.000Hz when playing. This fixed my problem :)

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.