How do I enable DX11 features?

#1 Posted by NTM (7319 posts) -

I downloaded that and the High res pack, but I can't seem to get the DX11 feature to enable. I have DirectX 11, so what's going on?

#2 Posted by NTM (7319 posts) -

GAHHHH!

#3 Edited by Marz (5648 posts) -
#4 Posted by NTM (7319 posts) -
@Marz: Yes I did, and then installed it, it didn't do anything (as shown in the game). It only shows that I installed the high res textures. 
#5 Posted by JusticeJanitor (145 posts) -

This might be a dumb question but does your GPU support DX11? After installing the three patches it should prompt you if you want to turn on DX11 features has soon has you boot up the game.

#6 Posted by NTM (7319 posts) -
@justicejanitor: Yeah, I checked. It runs DX11. I use steam, do I still need to install the v1.9 update individually? I only installed the DX 11 ultra upgrade and the High res texture pack.
#7 Posted by JusticeJanitor (145 posts) -

I've read somewhere that you Steam should install 1.9 automatically.  It needs to be installed before the DX11 patch or else it won't work. Other then that, Not to sure what's going on.

#8 Posted by NTM (7319 posts) -
@justicejanitor: Yeah, that's what I've read too. Alright, thanks anyways.
#9 Posted by Hef (1110 posts) -

@NTM: Once you finished downloading the update to steam, it just gives you the advanced graphics category in-game. Then you can click on the links right in Crysis 2 that send you to the download page for dx11 and high res textures. It's cool because you're actually downloading an application as well because it will automatically update the files inside your steam folders, even though it has nothing really to do with steam. I though I was going to have to play around in my steamapps folder but it just installs it automatically. I don't know why they couldn't just be included in the steam patch.

#10 Posted by NTM (7319 posts) -

Maybe someone can explain to me what this means -- Error: On Startup, Line 91: attempt to index global 'tbVersionInfo' (a nil value). I get this when I try to install the DX11 patch, but when I click OK the installation proceeds as if that meant nothing, but I have the feeling that's what makes it so I'm not being able to play it in DX11, then again, it also popped up when I installed the other high res patch as well, but that one works just fine.

#11 Posted by Captain_Felafel (1561 posts) -

@NTM said:

Maybe someone can explain to me what this means -- Error: On Startup, Line 91: attempt to index global 'tbVersionInfo' (a nil value). I get this when I try to install the DX11 patch, but when I click OK the installation proceeds as if that meant nothing, but I have the feeling that's what makes it so I'm not being able to play it in DX11, then again, it also popped up when I installed the other high res patch as well, but that one works just fine.

No that isn't your problem. While installing the DX11/High-res texture pack files I also got the same error, which then was proceeded by a successful installation of both packs. I can successfully run the game in DX11 and have the high-res textures enabled.

What GPU are you currently using?

#12 Posted by Heltom92 (707 posts) -

There is an in game menu used for enabling the new features.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.