Final Boss Battle Bug (360)

#1 Edited by caramelatonin (5 posts) -

This might crop up elsewhere for others.

Every single time I die and the game tries to load the previous checkpoint, the screen goes black and locks up the xbox. I even tried restarting the level - same result. As I can't pull up the dash either, I'm forced to manually power off the xbox each time, which I'm not really keen on, as I'm afraid something will break eventually. Any solutions? :/

EDIT: Cleared the cache and went to the mission select menu. Previously it skipped the whole elevator to the lower deck sequence and went straight to the walker and the warship. That might have been the cause.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.