Oh fuck, I have encountered a game breaking glitch (Spoilers?)

#1 Posted by lclay (383 posts) -

So I am the second world and have to defeat the arena champion to meet the Lord of Bones, I am collecting the third Animus Stone and there is a room with a rotating throne. It's a simple puzzle, you grab a bomb, stand on the throne and throw the bomb at the switch which turns the throne. Stupidly, the first time I did this I thought I had to throw the bomb while not standing on the throne and dash towards the throne before it turns. I did this and the game glitched out on me. It thought I was in the throne and now the switch is depressed, I am still on the wrong side and the throne is facing the wrong way. If I pull the switch out the throne is closed to me and the bombs only work when the switch is out so I can no longer solve this puzzle.

Has anyone ever encountered this glitch before? Does anyone know if there is a way to fix it? I tried the thing where you delete the newer autosave but I stupidly tried fast travelling first so now my older save is just when I travelled back to the broken puzzle.

I am 8 hours or so into this game and REALLY enjoying it. There is no way I can start again now so if I can't fix it that basically means this game is over for me until enough time has passed for me to forget all the dungeons and puzzles, which will be a long time.

FYI, playing 360 version.

#2 Posted by Heltom92 (706 posts) -

So you can't use the switch at all? Should still be usable even though it's depressed.

Other than that the only thing I can think of is quitting out and then loading back in, but you've probably already tried that.

#3 Edited by lclay (383 posts) -

No I can use it but the throne is now facing the wrong way. I'm supposed to be standing by the throne when I use the bomb on the switch. But now, when the switch is pulled out the back of the throne is facing me so I can't get through.

I am unbelievably angry. Why can't they just let me have multiple fucking save files?!

edit: and yeah I've tried quitting and reloading, I've tried fast travelling there and back and I've even gone all the way back to the Forge Lands via the tree of life and back but that didn't work either. THe only thing I haven't tried is fast travelling out of the dungeon and then instead of fast travelling back just walking from the main entrance back to the puzzle room. I am fairly certain this wont work.

#4 Posted by AuthenticM (3700 posts) -

I did the exact same thing as you did, except my game did not glitch. However, the camera did something really weird and for a second I thought the game had glitched, but it didn't. I don't know what to tell you.

#5 Edited by lclay (383 posts) -

Well I guess I'll just have to START ALL OVER AGAIN :(((((((((

I'll go put all my points into magic instead of physical, I'm sure that'll make it difference enough for me to enjoy playing like 5 or 6 dungeons again...

Fuck you THQ. Test your games better and give me multiple saves.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.