Dead Island loading to black screen

#1 Posted by Donos (1194 posts) -

Hey folks, just posting this up in case anyone (like me) got real frustrated when starting up the game and getting stuck in blackscreen for 5+ minutes, and at google's failure to find useful answers. It turns out the pre-menu logos dislike multiple monitors, and just disconnecting any secondary monitors until reaching main menu solved the problem for me. Hopefully next time someone searches this problem, they'll find this and save some time.

#2 Edited by MrKlorox (11209 posts) -

Absolutely zero problems with my multimon rig. What you need to do is go to ...\Users\<USERNAME>\Documents\DeadIsland\out\Settings and open VIDEO.SCR in a text editor. Now mess around with the Monitor line and see if you can get it working.
 
Like I said, mine works fine at the default 0 setting, but maybe you need to try -1 or 1. Disconnecting a monitor is NOT an acceptable solution.

#3 Edited by Donos (1194 posts) -

@MrKlorox: *shrug* matter of perference. For me, messing around in text file settings without an exact change is not an acceptable solution, but I'm perfectly happy to press a button when I start the game.

#4 Posted by MrKlorox (11209 posts) -
@Donos: You can disconnect your monitor by pressing a button? That sounds like some future technology shit right there. Most people would have to yank a cable.
 
Pretty certain everybody else would rather change a single digit number in a text file once than climb behind their computer twice, every time they want to play this game.
#5 Edited by Donos (1194 posts) -

@MrKlorox: By the vaguaries of 3 year old TVs just powering the thing off for a couple seconds works for me, what matters is only having one screen detect on startup. If other people's setups are less convenient that's fine, I'm just offering a simple solution. I should point out that file format isn't standard windows, so anyone looking for the lasting fix should go find the appropriate program to open a .scr

Edit: huh apparently it should open in notepad, where the heck is my option?

Double edit: There it goes, man this computer is weird.

#6 Posted by TinyGrasshopper (224 posts) -

A quick google also shows a solution on the dead island forums that worked for me

Go to: C:\Program Files\Steam\steamapps\common\dead island

Right click on "DeadIslandGame.exe" and select properties.

Under "Compatibility," check "Disable desktop composition."

#7 Posted by Kato (156 posts) -

@TinyGrasshopper Thank you do much, that fixed it for me. Great solution!

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.