A sad European Diablo 3 player :-(

  • 59 results
  • 1
  • 2
#1 Posted by BatMat (14 posts) -

Okay...so I decided to try and play some Diablo 3 again today after yesterday's Error 37 debacle and an patch that created a login-loop the day before that.

I had to download a new patch before I could press 'play'.

I had high hopes this time, but in the back of my head a voice was saying: "Here we go again."

And lo and behold: as soon as I log in, I get a message stating that a new patch needs to be installed and it kicks me out of the game. And then it loops...

I'm not one to post my grievances on internet fora, but this is getting ridiculous.

I think a guy on one of the Diablo 3 fora who stated it felt like he lent the game instead of owning it hit the nail on the head for me.

Online
#2 Posted by doobie (605 posts) -

what nail?

#3 Posted by kindgineer (2771 posts) -

Sorry for your grief, duder. Shit happens.

#4 Posted by supamon (1333 posts) -

Well dude, you were really just unlucky. Blizzard took the servers down for an hour maintenance/update and the servers are up for Americas. You'll have to wait for the patch to be released in your region.

#5 Posted by gamefreak9 (2372 posts) -

I have the same problem... ridiculous...

#6 Edited by Chicken_Pants (19 posts) -

I'm on Europe too and I agree that it has sucked for the last week or so. For the last three nights I haven't been able to play consistently or at all in some cases (apart from the understandable maintenance windows). Just now I was disconnected when I was just about to finish the Zoltan Kulle quest....

I feel like I don't even own the game at times too. It's really spoiling my enjoyment.

#7 Posted by Dagbiker (6978 posts) -

It really sucks when people piss on you in the forums because you want to play your game.

#8 Posted by BatMat (14 posts) -

@Dagbiker: When I post on forums I expect, nay, demand to be pissed upon!

I'm ready to receive thine golden drops now, so please let them flow with abundance.

Online
#9 Posted by Dagbiker (6978 posts) -

@BatMat said:

@Dagbiker: When I post on forums I expect, nay, demand to be pissed upon!

I'm ready to receive thine golden drops now, so please let them flow with abundance.

As long as your happy.

#10 Posted by BatMat (14 posts) -

Wait, what did I just post?

Online
#11 Posted by Binman88 (3689 posts) -

Yeah, Blizzard fucked up by prompting users to download the US version of the installer when they purchased the game, despite buying it from a EU IP, with an EU credit card, from and EU address. If you're desperate to play tonight BatMat, you can download the EU (enGB) installer and fudge it to turn your game into the correct region install, but it's a bit bothersome and you have to continue launching the game by first launching the enGB installer after doing this (launching by the regular one switches it back to the US version for some reason).

If you do want to do this, grab the enGB installer (google for it, don't have a link sorry!), then go to your current Diablo III install folder. What you want to do is delete all the files related to the US install. It doesn't really matter what you delete (the installer will replace them anyway), so I just deleted everything EXCEPT the Data_D3 folder (which contains the bulk of the installation; delete this and you'll have to install again). When all you're left with is that Data_D3 folder, open it up. Navigate through to Data_D3 > PC > MPQs and delete any files beginning with "enUS". Open the "cache" folder and do the same. I actually just deleted all the folders in MPQs because they're quite small, and won't take long to download again. Once you've done all that, open up the enGB installer, and choose your current install directory. The installer should get to work and install about 50 MB or so, and then allow you to launch the game as the correct EU version (without the US patch). Like I said, if you try to launch using the normal shortcut or .exe's in the Diablo III folder, it might try to launch the US version again, undoing your work. Load up the enGB installer whenever you want to play.

I would really advise though to just uninstall the game entirely, reboot and clean install with the enGB installer to avoid hassle in the future. But if you're looking to play before they patch the EU servers tonight at 1am, then the above is probably your best bet.

#12 Posted by BatMat (14 posts) -

@Binman88: Thanks for the tip, doing that right now.

Online
#13 Posted by Binman88 (3689 posts) -

@BatMat: No problem, hope it works out. Though what you need to download will only be small, the speed was pretty abysmal for me (something like 30 - 50 kb/s), so it might take a little while.

#14 Posted by BatMat (14 posts) -

@Binman88: Well, it worked, I can log in now...up until the point where it says `Retrieving Hero List´.

I checked the forums on eu.battle.net and apparently it´s a known error everyone is experiencing on the EU servers right now. Blizzard is working on it...

*sigh*

Online
#15 Posted by Ravenlight (8040 posts) -

@BatMat said:

When I post on forums I expect, nay, demand to be pissed upon!

I'm ready to receive thine golden drops now, so please let them flow with abundance.

Maybe we should see if the mods will change the thread from the D3 forum to the Jarate forum.

#16 Posted by TentPole (1858 posts) -

This is kinda beyond ridiculous at this point.

@Dagbiker said:

It really sucks when people piss on you in the forums because you want to play your game.

Who has pissed on him? No one is being even mildly rude.

#17 Posted by BatMat (14 posts) -

@TentPole: Well, I´m very easily offended, and ck1nd did say ´shit´ in his post!

Online
#18 Posted by Lumley (961 posts) -

I'm from the UK and bought the game yesterday, I've had quite a few error 37's and error 73's.

#19 Posted by Binman88 (3689 posts) -

@BatMat said:

@Binman88: Well, it worked, I can log in now...up until the point where it says `Retrieving Hero List´.

I checked the forums on eu.battle.net and apparently it´s a known error everyone is experiencing on the EU servers right now. Blizzard is working on it...

*sigh*

Damn. Yep, just tried it myself and can't get in either. Guess I'll take that as my cue to do a clean reinstall of the game. Really hope they iron out these issues soon because it is getting beyond ridiculous, like TentPole said above.

#20 Posted by destruktive (1069 posts) -

same here. I'm in an endless "Please patch game - game is up to date" loop here :\

#21 Posted by Village_Guy (2637 posts) -

European here, no problem for me, so it don't seem to inherently related to being in Europe.

#22 Edited by mandude (2669 posts) -

I haven't had any problems, thankfully, but every now and then my player (or an enemy) will zip around the room as though I had a bad connection to myself. Not sure what that's about, but I can only pray it doesn't get worse.

This is unwelcome in my single player game.

#23 Posted by ZimboDK (848 posts) -

That sucks, man. I got the game today. Well, I downloaded the enGB client yesterday, and bought the game this morning. I played for a while and then got booted (error 37). After about 40 minutes I could log in again. Haven't experienced any issues since, I'm looking forward to see how it runs over the weekend, since the only thing I'll be doing is playing it.

#24 Posted by Ares42 (2731 posts) -

Well, even if your client were fine you wouldn't be able to play anyways =/ it's getting beyond ridicolous. Two and a half weeks since launch and there's barely been a day without any issues at all.

#25 Posted by emergency (1193 posts) -

@Village_Guy said:

European here, no problem for me, so it don't seem to inherently related to being in Europe.

It is. The european servers are being awful. I guess you don't play all day like I do. Like third time I've been booted today alone and then it's a 30min process to get back in/fix the servers.

#26 Posted by Binman88 (3689 posts) -

@ZimboDK said:

That sucks, man. I got the game today. Well, I downloaded the enGB client yesterday, and bought the game this morning. I played for a while and then got booted (error 37). After about 40 minutes I could log in again. Haven't experienced any issues since, I'm looking forward to see how it runs over the weekend, since the only thing I'll be doing is playing it.

Yeah, one thing I will say is that when I'm not having login issues, my ping has been markedly improved since the last patch; closer to 50ms rather than ranging between 100 and 330.

#27 Posted by eroticfishcake (7786 posts) -

Are the EU servers working for anyone right now? I'm getting Error 1 all of sudden and I can't seem to log back in. Apparently it can't form my party. Whatever that means.

#28 Posted by Ares42 (2731 posts) -

@eroticfishcake: Nope, they broke down... again...

#29 Edited by stinky (1549 posts) -

this is exactly what it sounded like to me, but i thought nah, he must have downloaded the correct version.

with patches the different regions can get out of sync causing log in problems. i recommend the same, be sure you have the correct install running from the start.

*hopefully that doesn't wipe your characters.

@Binman88 said:

Yeah, Blizzard fucked up by prompting users to download the US version of the installer when they purchased the game, despite buying it from a EU IP, with an EU credit card, from and EU address. If you're desperate to play tonight BatMat, you can download the EU (enGB) installer and fudge it to turn your game into the correct region install, but it's a bit bothersome and you have to continue launching the game by first launching the enGB installer after doing this (launching by the regular one switches it back to the US version for some reason).

#30 Posted by eroticfishcake (7786 posts) -

@Ares42 said:

@eroticfishcake: Nope, they broke down... again...

Yeah I just noticed.The whole thing is shuttered. This is actually the first major problem I've personally had since I got the game on launch. The performance for me is pretty good for the most part apart from odd lag spike and disconnections when I pause it for a long while Of course I still think the always online is a terrible idea.

Well, in somewhat related news, Diablo 3 is being sold in China under an interesting name.

#31 Edited by Cincaid (2958 posts) -

I was one of the EU suckers who (by accident) downloaded the US client when I bought the game. Later I thought "meh, what's the difference?" since the game worked fine for me. After having patch errors these past two days I uninstalled and am now downloading the EU client in hope it won't screw me up in the future like this.

And yes, it's fucking hilarious to download 8GB at 300kb/s. For the second time.

#32 Posted by Mr_Skeleton (5147 posts) -

I can understand a rough launch but having a game barely playable after two weeks is inexcusable.

#33 Posted by pweidman (2342 posts) -

Went through the whole stall at load hero the other day, and the server maintenance warning thing. Worked fine yesterday though, and this morning(US).

I've, up to now, been willing to give Blizz the benefit of the doubt. I know they're working on it, but damn, it's been one thing after the other. If anyone should have been able to efficiently deal with an admittedly huge launch, you think it would be them. Things have got to get better soon.

#34 Posted by emergency (1193 posts) -

When everyone whined about always online, I didn't mind. I knew their would be some issues for the first few days, but everything would settle out and it wouldn't affect me. Two weeks later and every day several times a day they boot me off. It's a bit disgusting, absolutely no one else other than maybe valve could "get away with this". I'm really disappointed in Blizzard. I feel like I gave them the benefit of the doubt and too much credit. When people would whine, I would fervently defend them. After a few weeks of this absolute crap, I feel like readying my pitchfork as well. Shocking service, especially considering the fact it was an expensive for a PC game.

#35 Posted by OmegaPirate (5522 posts) -

http://eu.battle.net/d3/en/forum/topic/4551555680?page=4#74

:(

Due to the issues we have been experiencing we are now bringing down the service and will start the maintenance after a short restart. The service will be offline for approximately 1 to 2 hours to complete the maintenance.

#36 Posted by Majkiboy (994 posts) -

Yea hopefully this patch fixes... something.... :P

#37 Posted by eroticfishcake (7786 posts) -

@Majkiboy said:

Yea hopefully this patch fixes... something.... :P

Could be this patch to buff Legendary items and so fourth. Either way those tweaks are coming in the near future.

#38 Edited by Majkiboy (994 posts) -

@eroticfishcake said:

@Majkiboy said:

Yea hopefully this patch fixes... something.... :P

Could be this patch to buff Legendary items and so fourth. Either way those tweaks are coming in the near future.

That actually sounds promising :) Although the thing I want the most (well .. second to servers actually working) is being able to run while you have the large map up!

#39 Posted by eroticfishcake (7786 posts) -

@Majkiboy: Yeah like classic Diablo games. Popping the map in and out isn't the most optimal way to play sometimes. But yeah while I'm enjoying D3 a lot if could do with a LOT of improvements like the one you pointed out. Having said that, I think Legendary items should take some priority. I hate to imagine the feeling of finding a Legendary only to discover the stats are absolute bollocks (which have been the case for a lot of people.)

#40 Edited by Majkiboy (994 posts) -

Although! I fail to see the reasoning behind these changes.

There needs to be money sinks in a game like this where one of the goals is pretty much... farming. I guess this will make people buy more expensive stuff in the AH?

Or maybe it is because they want people NOT to buy everything from the AH...

  • Blacksmith gold and page costs will be reduced.
  • Jeweller gem costs will be reduced, gems up to flawless square level can be crafted with two gems instead of three.

Sorry for kinda OT

So, OT:

"We have a patch coming within the next week (patch 1.0.2) that has been in development since the game’s launch and is mainly aimed at addressing service issues."

Anyway, time for EU people to sleep! Hopefully everything will be ok after this patch!...... (knock on wood)

#41 Posted by Prismatic (56 posts) -

@emergency said:

When everyone whined about always online, I didn't mind. I knew their would be some issues for the first few days, but everything would settle out and it wouldn't affect me. Two weeks later and every day several times a day they boot me off. It's a bit disgusting, absolutely no one else other than maybe valve could "get away with this". I'm really disappointed in Blizzard. I feel like I gave them the benefit of the doubt and too much credit. When people would whine, I would fervently defend them. After a few weeks of this absolute crap, I feel like readying my pitchfork as well. Shocking service, especially considering the fact it was an expensive for a PC game.

My feelings exactly.

Just got booted for the 10th time in 4 days and can't log back in. Yay.

#42 Posted by Binman88 (3689 posts) -

Booted again for "failure to create party" while playing single player inferno. This is after waiting for ages to actually play the game while it retrieved my hero list. Not to mention when I was on earlier, I was getting achievement errors and lag spikes. What an absolute broken mess.

#43 Posted by TaliciaDragonsong (8699 posts) -
@Binman88 said:

Booted again for "failure to create party" while playing single player inferno. This is after waiting for ages to actually play the game while it retrieved my hero list. Not to mention when I was on earlier, I was getting achievement errors and lag spikes. What an absolute broken mess.

A-fucking-men.
#44 Posted by eroticfishcake (7786 posts) -

@Binman88 said:

Booted again for "failure to create party" while playing single player inferno. This is after waiting for ages to actually play the game while it retrieved my hero list. Not to mention when I was on earlier, I was getting achievement errors and lag spikes. What an absolute broken mess.

Just got the exact same thing as well. I was wondering why the achievements weren't loading. I supposed it's good to know I'm not the only one? In any case the server issues seem to be getting worse which is well...incredibly stupid.

#45 Posted by Vitor (2823 posts) -

I'm glad MP3 just came out (and that I have exams next week...) because I'd be majorly pissed with D3 if not. Of Blizzard can't get this right, no other company will. Only the massive sales will likely make ubi and others rethink their DRM stance.

The thing I don't get is, if it was to do with the auction house, why not just make sure that if you create an offline character then you're never allowed access to the auction house? Problem solved.

Seems like a piracy thing although I doubt there isn't already a functioning pirated version out there.

#46 Posted by GunslingerPanda (4827 posts) -

This is ridiculous. Fora is not a valid plural for forum.

#47 Posted by Neocarbon (24 posts) -

Well, us Europeans did get the working servers during the beta, so I guess karma?

#48 Posted by Panpipe (475 posts) -

FUCK.... BLIZZARD.... FUCK.

#49 Posted by Jaqen_HGhar (930 posts) -

So, I don't mind the always on DRM thing that much. I understand why it is there, and I am lucky enough to live in a place where the internet flows well. But this is getting kinda stupid.

Let's see, got home from work on Wednesday, "Error 37". Fine, I got Thursday off. No big deal. Got to play two hours or so Thursday, get some dinner, "Error 37". Now it is getting annoying, and I see the pattern. It all breaks down when people get home from work and school, so it seems that the amount of people who want to play at once crash everything. This is somewhat unacceptable for a company that runs a major MMO.

But I figured they would have gotten it fixed today. Got home from work. "Error 37". Oh, and a few "Error 1" just to change it up.

Oh well. At least the new Cortex Command build is released today. Guess I'll play that instead.

#50 Posted by Positrark (316 posts) -

Just got an error: "Error creating your own party". Happened in the middle of a quest while playing solo. Based on the EU forums it seems to be a somewhat common problem in the last 24 hours. I understand it's hard to run a giant online system and the need to always play online, but being afraid of getting kicked out of your own single player game is kind of retarded. I mean it is the equivalent of an offline game crashing to the main menu, which would be inexcusable for a retail game.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.