Poor performance?

#1 Posted by JoeyRavn (4946 posts) -

Is someone else having "poor" performance in this game? Since it is a Source game, and seeing I've been able to max Portal 2, L4D2, etc (not to mention, other non-Source games), I feel I should be getting constant 60FPS, or something close to that, with my system, but the game takes HUGE dips in some areas for no apparent reason.

For example, in the first real mission, whenever I'm looking straight to the streets, the FPS go as low as 25. When I enter a smaller area, like the werehouse where I'm supposed to hack the terminals to activate the elevator, the game jumps back to 60 FPS. I wouldn't mind small jumps, from 60 to 45, but from 60 to 25 and back is very noticeable and annoying.

I've tried disabling/changing some of the most demanding options, but they don't seem to affect the performance at all. I get the same jumpy performance with AAx16 and no AA, Very High textures or Low, HDR Full or the other one, shadows or not. A lower resolution doesn't yield any better results either. The only option that did impact performance was Multicore Rendering. With it activated, I was getting 60 to ~40 FPS inside the Temple. With it off, constant 60 FPS inside the temple, though in the first mission, nothing changes.

Last but not least, my specs:

  • Windows Home Premium x64
  • Q8400 OC'd@3.2 GHz
  • 4GB RAM 800 MHz
  • GTX 460 786MB 800/1600/21000 (w/ 275.33 WQHL)
  • Playing at 1920x1080x60

Thanks in advance.

#2 Posted by fisk0 (3765 posts) -

I haven't had any noticeable frame drops (I haven't looked at the frame rate though), and I'm running the game on a Athlon X3 3.0ghz, 4GB RAM, integrated ATi HD4200, Windows 7 Pro x64 in 1024x768, which due to the lack of dedicated graphics card usually struggles a bit with other recent source games (like L4D2, Portal 2 and Team Fortress 2 after the last few major updates), and I've got most settings in E.Y.E. maxed out except resolution (as mentioned above) and AA which I've disabled.

#3 Posted by horseman6 (360 posts) -

I'm having similar issues with a newer ATI card. I just installed new drivers so I'll see if that helps.

#4 Posted by The_Hiro_Abides (1249 posts) -

I'm dropping frames too but I'm having a bigger problem with how dark this game is. Occasionally (even with the flash light) I'm just wandering through a dark hallway.

#5 Posted by JoeyRavn (4946 posts) -

@The_Hiro_Abides said:

I'm dropping frames too but I'm having a bigger problem with how dark this game is. Occasionally (even with the flash light) I'm just wandering through a dark hallway.

Have you tried disabling Color Correction? It makes the game a lot darker.

@HorsemanVI said:

I'm having similar issues with a newer ATI card. I just installed new drivers so I'll see if that helps.

The devs are saying they're testing a patch that will improve performance and crashes. It's bound to be released sooner or later, probably this next week. We'll see if it solves anything. I'm really trying to like the game, but the poor production values (sloppy translation, myriad of bugs and crashes) and slow response from the devs is killing it for me. So much so, I've decided not to play anymore until a patch is deployed. I really don't want to spoil my enjoyment of this game with a first impression that could easily be avoided.

PS: If you ever decide to go to the Steam forums for this game, be warned: the user jpnole is a dick and a troll.

#6 Posted by The_Hiro_Abides (1249 posts) -

@JoeyRavn: I've tried disabling color correction and didn't notice a difference. But I only turned it on and off a few times. I'll try running it with it off for a while next time.

#7 Posted by Sin4profit (2903 posts) -

@JoeyRavn said:

The devs are saying they're testing a patch that will improve performance and crashes. It's bound to be released sooner or later, probably this next week. We'll see if it solves anything. I'm really trying to like the game, but the poor production values (sloppy translation, myriad of bugs and crashes) and slow response from the devs is killing it for me. So much so, I've decided not to play anymore until a patch is deployed. I really don't want to spoil my enjoyment of this game with a first impression that could easily be avoided.

We're in the same boat, waiting for the mega patch before i go into the game any further. my issue is just with crashing to the desktop though.

#8 Posted by atejas (3057 posts) -

I'm still soldiering on ahead, but by that, I mean I'm grinding side missions in New Eden. Hopefully their patch won't invalidate save games.
I'm getting poor performance as well, but that's because I'm running this on a 4850 and a core 2 duo. Old machine is old.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.