Is anyone else having the no crosshairs in a scope problem?

#1 Posted by AiurFlux (902 posts) -

I don't have them showing up in any of the sniper rifles nor any of the scopes for the bow. I've tried pretty much EVERYTHING out there that I've managed to find by Googling the problem. I'm using two different computers with two different GPU manufacturers. I disable AA. I disable letterbox. I go into both CCC and nVidia's control center and disable AA, AF, AAA, and every other acronym you can think of. Nothing fucking works. I'm on the mission where you have to save Oliver using a sniper rifle and it is, in short, fucking impossible. It's like trying to use a magnifying glass to hit targets 200 feet away that are on the run. But the kicker is that everything is fine for the red dot, optical, and reflex sights.

If I have to start a new game I'm seriously going to be fucking infuriated. I've crafted all the pouches, liberated all the outposts on the Northern Island, and found all the radio towers on the Northern Island. I have 60+ Relics and this and that.

For once I'd like to start up a game, on the PC, and not have any bullshit problems like this. Just once.

#2 Edited by Snail (8594 posts) -

Can't be of much help with your Far Cry issue, but you seriously shouldn't be having issues with every PC game you boot up unless you choose to play buggy ports of console games exclusively or your computer/s has/have some unresolved issues.

#3 Posted by AiurFlux (902 posts) -

@Snail said:

Can't be of much help with your Far Cry issue, but you seriously shouldn't be having issues with every PC game you play unless you choose to only boot up buggy ports of console games.

Well okay, a bit of an exaggeration. DIRT 3, which I recently bought on Steam, works fine and plays like a charm. And it's insanely optimized where I'm getting 200+ FPS at times. Starcraft II is also good. Deus Ex: Human Revolution was also really well made. But my point still stands. Skyrim I had problems with, Arkham City I had problems with, Mass Effect 3 I had a couple of problems with (2 CTD's), Diablo III had that who debacle at the start, XCOM even froze up on me a few times when I was in the middle of missions, and then I ran into an invincible Sectopod on the Alien Base mission and had to restart.

Not everything is bad, but there is enough to leave a sour taste in my mouth and make me an even bitterer cunt.

#4 Posted by Snail (8594 posts) -

@AiurFlux: You probably had issues with Arkham City because Games for Windows Live fucked up your game seemingly at random if you were playing in DX11, right? I had that too. I think we all did. Skyrim's technical flaws were no secret either.

You still seem to have bad luck with game-breaking bugs, either that or something's up.

#5 Posted by warxsnake (2649 posts) -

Try playing with the alpha-to-coverage options within the game settings as the sniper crosshairs were built with alphas.

#6 Edited by Questionable (619 posts) -

Considering you have the same result on 2 seperate machines, one with a ATI card the other Nvidia,

Isn't it likely the scopes are just intended that way?

Can you post a screenshot so we know what you are referring to?

#7 Posted by FaPaThY (134 posts) -

Setting Antialiasing - Mode to Off in the NV control panel worked for me. Make sure you're actually changing the settings for the right .exe, which if you're having this problem would be the dx9 version(farcry3.exe).

Or if your card supports it use farcry3_d3d11.exe. Don't think it has that problem, but if it does then try turning AA off for that .exe.

#8 Posted by moogles1 (3 posts) -

use farcry3_d3d11.exe to run the game thats all u have to do

#9 Posted by Darkstorn (464 posts) -

Weird, I'm having the exact same problem. I actually thought the sniper rifles were intended to be that way haha...

Using Radeon 6670M 1GB

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.