So what, is v-sync broken on PC?

#1 Edited by Sooty (8082 posts) -

Enabling v-sync halves my framerate, goes from staying around 60 to less than 30 on either the 1 or 2 frames setting. What's up with that?

At first I thought my PC couldn't handle it maxed out, then I turned off v-sync and it's smooth as hell.

#2 Posted by pause422 (6153 posts) -

Do you have an nvidia card? Could work with ati too but I dunno what it would be called, I would go into the settings and turn on Adaptive Vsync and turn it off in the game. Vsync alot of the time only keeps the framerate at your refresh rate if it is going a bit higher or exactly on it. If it dips even a few frames it halves it and it sucks ass. So for averaging around 60 either do that, or not an option I guess deal with the bit of tearing unfortunately and leave it off.

#3 Edited by believer258 (11040 posts) -

This is the second thread I've seen where you complained about this game a bit. Just an observation.

On topic, try forcing VSYNC in your graphics card's control panel. If that doesn't work, get a hold of D3DOverrider and use it. Actually, just plain get D3DOverrider, disable VSYNC in every game that doesn't use OpenGL, and see a bit of a performance bump.

#4 Edited by Sooty (8082 posts) -

@believer258 said:

This is the second thread I've seen where you complained about this game a bit. Just an observation.

On topic, try forcing VSYNC in your graphics card's control panel. If that doesn't work, get a hold of D3DOverrider and use it. Actually, just plain get D3DOverrider, disable VSYNC in every game that doesn't use OpenGL, and see a bit of a performance bump.

Well it's a legit complaint, always irritating to have to dig into the profile settings to fix this stuff. Also I should probably install those new Nvidia beta drivers.

@pause422 said:

Do you have an nvidia card? Could work with ati too but I dunno what it would be called, I would go into the settings and turn on Adaptive Vsync and turn it off in the game. Vsync alot of the time only keeps the framerate at your refresh rate if it is going a bit higher or exactly on it. If it dips even a few frames it halves it and it sucks ass. So for averaging around 60 either do that, or not an option I guess deal with the bit of tearing unfortunately and leave it off.

Sure do, I know about v-sync keeping at the refresh rate but in this case I get around 60 with it off and less than 30 with it on. Weird, seen it happen in other games too but it's a very rare thing.

#5 Posted by Bourbon_Warrior (4523 posts) -

If you got a AMD card download the beta drivers, gave me a huge boost.

http://support.amd.com/us/Pages/AMDSupportHub.aspx

#6 Posted by pause422 (6153 posts) -

I'm saying that you stated you are getting "around" 60, so even a frame or two dip often caues Vsync to briefly half it to around 30 FPS until you would be at 60 or above 60 again. So as I said if you can use adaptive, that's your best bet for having vsync enabled.

#7 Posted by RollingZeppelin (1857 posts) -

V-sync has never worked properly for me in any game I've played. It either craps up the framerate or, for some reason, makes the mouse cursor incredible unresponsive. It's probably the most useless display technology ever. I've never seen or heard of an example where it's improved anyone's experience. I dunno, maybe I'm doing it wrong?

#8 Edited by Sooty (8082 posts) -

@pause422 said:

I'm saying that you stated you are getting "around" 60, so even a frame or two dip often caues Vsync to briefly half it to around 30 FPS until you would be at 60 or above 60 again. So as I said if you can use adaptive, that's your best bet for having vsync enabled.

I have only had that happen in one or two other games, v-sync usually just doesn't let the framerate exceed your refresh rate. Seems the poorer implementation of v-sync to me.

I just installed the new Nvidia beta drivers which boast of 38% improved performance so I'll try it with the game's implementation again first. Weird.

@RollingZeppelin said:

V-sync has never worked properly for me in any game I've played. It either craps up the framerate or, for some reason, makes the mouse cursor incredible unresponsive. It's probably the most useless display technology ever. I've never seen or heard of an example where it's improved anyone's experience. I dunno, maybe I'm doing it wrong?

I find it quite game dependant, some games tear worse than others I feel.

#9 Posted by CannonGoose (371 posts) -

Triple buffering is the bee's knees. I wish every developer included it in their PC games but only a handful seem to.

#10 Posted by envane (1156 posts) -

@Sooty: update drivers ? i was having that issue with my 580s , and it wasnt detecting sli for me either. Got the latest beta drivers and it jumped from 30fps with vysync and ~58 without , to 60with vysnc and ~130fps without. (ultra without msaa) now the only problem is the heat i have to deal with now (aussie , ~20 degrees added delta temp with this muggy hot weather) .. but yeh smooth fps (still decides to randomly drop to 45-50 fps when it loads a bunch of stuff in then it goes back to 60 )

havent played that much tho , yesterday fucking kept getting "farcry 3 service is offline please try again later , when i would go to the menu etc, then it would get suck and just render the distant view stuff and need to be restarted etc .

#11 Posted by Sooty (8082 posts) -

@envane said:

@Sooty: update drivers ? i was having that issue with my 580s , and it wasnt detecting sli for me either. Got the latest beta drivers and it jumped from 30fps with vysync and ~58 without , to 60with vysnc and ~130fps without. (ultra without msaa) now the only problem is the heat i have to deal with now (aussie , ~20 degrees added delta temp with this muggy hot weather) .. but yeh smooth fps (still decides to randomly drop to 45-50 fps when it loads a bunch of stuff in then it goes back to 60 )

havent played that much tho , yesterday fucking kept getting "farcry 3 service is offline please try again later , when i would go to the menu etc, then it would get suck and just render the distant view stuff and need to be restarted etc .

I think the beta drivers actually made performance worse for me! If PlanetSide 2 is also worse then I'm gonna roll back to the .61 beta.

#12 Posted by zenmastah (836 posts) -

Its definetly loose on FC3, but not broken. Atleast wasnt for me. Ubisoft has some issues with Vsync in their games it seems, AC3 had broken Vsync for me.

I just enabled tripple buffering and that seems to lock it in place.

#13 Posted by WilltheMagicAsian (1543 posts) -

NVIDIA inspector is your friend if you have an NVIDIA card. Setting a frame rate cap instead of using vsync removes that awful mouse lag too.

Online
#14 Posted by bibamatt (1086 posts) -

@RollingZeppelin said:

I've never seen or heard of an example where it's improved anyone's experience. I dunno, maybe I'm doing it wrong?

Well here's your first example! I use it on every game. I use my PC through my 1080p TV and, without v-sync, every game tears like hell. V-sync solves that for me with no obvious downside. It's a requirement for me.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.