#1 Edited by Veliremus (6 posts) -

Hey everyone,

After hearing about Matt Rorie's (@rorie?) frame rate trouble with the PC version of Black Flag, I decided to look around on the web a little to see if it could be fixed. Because I, too, had some less-than-ideal frame rates with my MSI GTX660Ti PE OC (which I figured should perform better than it did). Turning off V-Sync helped, but made the tearing unbearable. Seems like the lack of triple-buffering is hurting the V-Sync.

Using a bunch of sources, I actually found a method that significantly improved my gaming experience. I thought I'd share my findings for others to enjoy. I apologise in case this has already been addressed elsewhere -- I ran a forum search but didn't find anything. Also please note: this may only work for NVIDIA cards, no guarantees, try at your own "risk," etc.

Here's what you do:

  1. Download RivaTuner
  2. Extract it to a (temporary) folder, then use an archive tool (I used 7-Zip) to open the RivaTuner[versioninfo].exe and extract /Tools/D3DOverrider/ to a folder of your choice
  3. Run the extracted D3DOverrider.exe (it will probably start minimized in your taskbar); set Force triple-buffering to ON and Force V-synch to OFF, leave it open
  4. Run Black Flag, go into the graphics options and turn on V-Sync
  5. Optional: set the graphics settings to the optimal settings for your specific card according to the NVIDIA guide
  6. Enjoy a smoother Black Flag experience!

(Sources: PCGaming Wiki, Steam Forums, Performance Guide by NVIDIA)

Alternative by @colourful_hippie (a little more prone to tearing, in my case):

  1. Go into your NVIDIA Control Panel > 3D Settings
  2. Scroll down the list and set Vertical Synchronization to "Adaptive"
  3. Turn off V-Sync in the Black Flag graphics settings

(Reading material: Adaptive V-Sync)

#2 Edited by Chumley_Marchbanks (157 posts) -

Wouldn't it be easier to just turn Vsync off in-game and then turn on Vsync and triple buffering in the Nvidia control panel?

#4 Edited by Chumley_Marchbanks (157 posts) -

@veliremus: Yup, it's right at the bottom of the 3D settings list just above the Vsync options.

#5 Edited by GamingMichael (108 posts) -

I thought triple buffering only helps with V-Sync on?

#6 Edited by Veliremus (6 posts) -

According to this guide (not sure how good of a source it is) that only works for OpenGL games:

http://www.tweakguides.com/Graphics_10.html

However this won't work for enabling Triple Buffering in Direct3D-based games, which are the bulk of modern games.

@gamingmichael: correct. That's why you have to turn it on. But only in Black Flag itself, not in D3DOverrider.

#7 Posted by Chumley_Marchbanks (157 posts) -

According to this guide (not sure how good of a source it is) that only works for OpenGL games:

http://www.tweakguides.com/Graphics_10.html

However this won't work for enabling Triple Buffering in Direct3D-based games, which are the bulk of modern games.

Ah, I did some further research and that seems to be case. It would be nice if Nvidia would put that information in the description.

#8 Edited by Veliremus (6 posts) -

@veliremus said:

According to this guide (not sure how good of a source it is) that only works for OpenGL games:

http://www.tweakguides.com/Graphics_10.html

However this won't work for enabling Triple Buffering in Direct3D-based games, which are the bulk of modern games.

Ah, I did some further research and that seems to be case. It would be nice if Nvidia would put that information in the description.

Yes, they should have done that. A little note would have sufficed. Anyway, I guess this means the guide is still good. Glad I didn't type it for nothing :P.

#10 Posted by m16mojo2 (327 posts) -
#11 Posted by believer258 (12186 posts) -

According to this guide (not sure how good of a source it is) that only works for OpenGL games:

http://www.tweakguides.com/Graphics_10.html

However this won't work for enabling Triple Buffering in Direct3D-based games, which are the bulk of modern games.

@gamingmichael: correct. That's why you have to turn it on. But only in Black Flag itself, not in D3DOverrider.

Not only that, D3DOverrider has never worked for me in Windows 8. When I was using Windows 7, I would actually force VSync using D3DOverrider and turn it off in-game and it made things run a little better.

If a game doesn't support VSync, or doesn't support it well, I find myself using Radeonpro these days. Otherwise I use whatever came with the game. Forcing VSync in the AMD control panel has all the effectiveness of screen doors on a submarine.

Online
#12 Edited by Colourful_Hippie (4488 posts) -

@veliremus said:

According to this guide (not sure how good of a source it is) that only works for OpenGL games:

http://www.tweakguides.com/Graphics_10.html

However this won't work for enabling Triple Buffering in Direct3D-based games, which are the bulk of modern games.

@gamingmichael: correct. That's why you have to turn it on. But only in Black Flag itself, not in D3DOverrider.

Not only that, D3DOverrider has never worked for me in Windows 8. When I was using Windows 7, I would actually force VSync using D3DOverrider and turn it off in-game and it made things run a little better.

If a game doesn't support VSync, or doesn't support it well, I find myself using Radeonpro these days. Otherwise I use whatever came with the game. Forcing VSync in the AMD control panel has all the effectiveness of screen doors on a submarine.

Or just set adaptive v-sync as default for global settings in the nvidia control panel. I never had an issue with it in every game I've played.

#13 Posted by Korwin (3028 posts) -

Still not seeing all these performance problems people are having, game has run fine for me with some minor settings fiddling to find the right balance.

#14 Edited by Veliremus (6 posts) -

@m16mojo2: You're welcome!

@believer258: I'm not sure about Windows 8, since I run this game on my Windows 7 PC. With D3DOverrider basically never being updated anymore, though, I can imagine it failing on Windows 8. I heard about RadeonPro as well, so that might be a good substitute if it works.

@colourful_hippie: Interesting... I did some quick research, and it sounds like a great option. I'll try it out!

@korwin: Well, that's the thing with PC games, I suppose. Some people have problems, some people don't. Glad to hear you're not, and I hope this will help the people that do.

#15 Posted by Korwin (3028 posts) -

@veliremus: It's just extra strange to me in this instance because I've played the game on 2 different machines (I alternate between and SLI machine and a single card machine, one Haswell and one Ivy Bridge) and not a sausage. Also props for your Steve Wilson avatar.

#16 Posted by Colourful_Hippie (4488 posts) -

@korwin said:

@veliremus: Also props for your Steve Wilson avatar.

Huh, that's like 3 people (some other dude with an In Absentia avatar) now that I know who listen to Wilson on this site. Listen to the Raven album if you haven't already

#17 Edited by Korwin (3028 posts) -

@colourful_hippie said:

@korwin said:

@veliremus: Also props for your Steve Wilson avatar.

Huh, that's like 3 people (some other dude with an In Absentia avatar) now that I know who listen to Wilson on this site. Listen to the Raven album if you haven't already

I was at the Raven Tour last month, was a good performance. He busted out Radioactive Toy in the encore :P

EDIT: Two Months ago I guess, just remembered it's December now.

#18 Edited by Colourful_Hippie (4488 posts) -

@korwin: Damn, I'm jealous. I only got to see him back when he was with Porcupine Tree touring after they released The Incident.

#19 Posted by Korwin (3028 posts) -

@korwin: Damn, I'm jealous. I only got to see him back when he was with Porcupine Tree touring after they released The Incident.

FYI the more "Metally" version of Index he did live was awesome, he really should put out that flavour of the song on an EP.

#20 Posted by Veliremus (6 posts) -

@colourful_hippie: All right, so I tried the Adaptive Synch. It's a good technology, though I suppose it doesn't kick in all the time for me -- I still get some tearing. It is significantly less, though, so I will add it to the guide as a second option. Of all things I've tried now, I prefer the D3DOverrider, as it has zero tearing and a fine frame rate. I will keep Adaptive Synch in mind for other games, though!

Off-topic about Steven Wilson: Ah, I should have known the Giant Bomb community had a fine music taste ;). Yes, I'm a huge, huge fan of Steven Wilson. I've seen him live three times now -- twice for the Grace for Drowning tour, once for The Raven That Refused To Sing. Fun fact: I was on the guest list for all three of the shows, due to me winning a promoting contest (I won three times? Yes, I won three times -- very few people entered from my country). I became a Porcupine Tree fan (my first taste of SW) too late to catch them live. I still hope they will get together again.

#21 Edited by newhaap (437 posts) -

Hey guys, since this is kinda related to the topic I'll just ask it here instead of starting a new thread.

Is anyone currently using Nvidia's adaptive vsync with a 120Hz monitor? For me whenever I set adaptive vsync on and turn vsync off in games (EDIT: games that I know can get at least 120 fps average of course), it goes to 60 fps instead of 120. I'm using the DVI-D dual link cable since I'm aware that HDMI won't be able to do 120Hz, and I've switched back and forth between 120Hz and 60Hz and I'm pretty sure I see a difference when moving windows around for example so I don't think the control panel is lying to me.

Am I missing something?

#22 Posted by Korwin (3028 posts) -

@newhaap said:

Hey guys, since this is kinda related to the topic I'll just ask it here instead of starting a new thread.

Is anyone currently using Nvidia's adaptive vsync with a 120Hz monitor? For me whenever I set adaptive vsync on and turn vsync off in games (EDIT: games that I know can get at least 120 fps average of course), it goes to 60 fps instead of 120. I'm using the DVI-D dual link cable since I'm aware that HDMI won't be able to do 120Hz, and I've switched back and forth between 120Hz and 60Hz and I'm pretty sure I see a difference when moving windows around for example so I don't think the control panel is lying to me.

Am I missing something?

I'm not aware of any problem with adaptive vsync and 120hz, that being said I don't have first hand experience with 120hz monitors.

#23 Edited by Sagalla (218 posts) -

I'm guessing that driver updates will gradually improve the framerates, which are likely shitty now so the new consoles don't look so bad in comparison

#24 Edited by newhaap (437 posts) -

@sagalla: @korwin: Hmmm thanks, a driver update is one thing I haven't tried, I'll see what that does.

#25 Posted by StingingVelvet (574 posts) -

@korwin said:

Still not seeing all these performance problems people are having, game has run fine for me with some minor settings fiddling to find the right balance.

Most people refuse to lower settings if they have a relatively high-end card. Not saying everyone who is having problems is like this, but a lot of random forum chatter about bad framerates is rooted in people not wanting to turn settings down even a little.

Ubisoft do not optimize for PC very well as a rule, so even decent computers need to turn down some settings at times. Sucks but it is what it is.

#26 Edited by WesleyWyndam (163 posts) -

@newhaap: The game has a cap at around 60fps. I have a 144hz monitor and the game will not run above 63fps with vsync disabled, no matter what settings I use.

EDIT - I just noticed you said games, not game. If it's happening in other games as well, then I'm not sure what to tell you. But as far as AC4 goes, it's capped.

#27 Posted by newhaap (437 posts) -

@wesleywyndam said:

@newhaap: The game has a cap at around 60fps. I have a 144hz monitor and the game will not run above 63fps with vsync disabled, no matter what settings I use.

EDIT - I just noticed you said games, not game. If it's happening in other games as well, then I'm not sure what to tell you. But as far as AC4 goes, it's capped.

Thanks for the info! I actually just came back here to follow up also in case it's relevant for anyone else. So as you said some games have a frame rate cap, including the two games I've been trying to get to work apparently (Dirt 2 and SSFIV), which is kinda weird since Dirt 2 has a refresh rate option that goes above 60Hz. I decided to try other games and it worked for Portal 2 and DmC. Looks great!

#28 Posted by anzejk (130 posts) -

For Radeon users i would really, REALLY heavily recommend a program called Radeon Pro. It's free and its made for advanced setting of graphics option that you can't do in Catalyst. It has a whole fucking lot of options that you can set including v-sync with triple buffering, adaptive v-sync and so on. I'm using it for a looong time now and it's a biiiig must for any Radeon user. I really can't recommend it enough. Just try it and you'll see.

It's gonna save you a lot of nerves and time in a lot of games. :)

Online
#29 Posted by emjaylawthertin (24 posts) -

Okay, so preliminaries:

i7 2600 (not a 2600k, but an old stock Dell XPS 8300 - yeah, really)

EVGA GTX670FTW 4GB, factory-overclocked

16GB RAM

Seagate 1TB SSHD hybrid drive

Latest downloaded nVidia drivers and nVidia Control Panel and GeForce Experience

I was having framerate issues for the quality I wanted. My rig could blow past the GeForce Experience recommendations, but in-game vsync was killing my framerate, like sub-30 in boarding battles and in high-foliage areas like the Assassin's hideout.

I followed some recommendations to turn off vsync in-game and to run adaptive vsync and triple buffering from my nVidia Control Panel. I consider myself still a relative noob with PC gaming and am averse to diving deep into override stuff from 3rd party software I might not understand.

From what I've pulled from forums, though, I think I hit on a way to smooth out the framerate (NOTE: all I want is a solid 30+ FPS so I don't feel like a moron for skipping a PS4 or XONE this holiday). I turned OFF the vsync in-game, quit it completely, loaded nVidia Control Panel, then changed the vsync to ON as a hard override. I also set triple buffering to ON as a hard override from that app, too.

It feels like the vsync and buffering only do their job on my PC when they're working together like that. When I use in-game vsync, it's garbage; when I use adaptive vsync and triple buffering, even with the "half refresh rate" option, it tears like hell still. I also am hesitant to use D3Doverrider if I don't know what I'm doing. Still, I think I'm getting similar results as D3Doverrider without leaving the nVidia Control Panel. I don't have FRAPS and can't figure out how to get RivaTuner to surface a FPS count in-game yet, but I'll update if I hear something better.

Hope this helps somebody.

#30 Posted by FritzDude (2273 posts) -

Did Ubisoft seriously expect users to either have the machine to hit a solid 60 frames per second or did they expect players to be OK With fluctuating 60-30-15 frames per second gameplay? What's more baffling is that if you hit the Windows key and press L (win+L) and lock the desktop while in-game session, log back in and enter the game then the game doesn't fluctuate any longer. What is up with that? You would think after 6 game updates Ubisoft would have fixed this by now. I recently started playing this (aswell as other video games) and it just perplexes me that something like this exist on a fairly new game.

#31 Posted by Humanity (10067 posts) -

Did Ubisoft seriously expect users to either have the machine to hit a solid 60 frames per second or did they expect players to be OK With fluctuating 60-30-15 frames per second gameplay? What's more baffling is that if you hit the Windows key and press L (win+L) and lock the desktop while in-game session, log back in and enter the game then the game doesn't fluctuate any longer. What is up with that? You would think after 6 game updates Ubisoft would have fixed this by now. I recently started playing this (aswell as other video games) and it just perplexes me that something like this exist on a fairly new game.

Everything I've played from Ubisoft on PC has been poor in performance. AC4 ran questionably no matter what options I turned on and off. Splinter Cell Blacklist was likewise unstable despite not looking that amazing for the most part.

The real kicker is the lackluster performance of Trials Fusion of all games. The gameplay is fine but man the load times on some things are quite obviously a bug.

#32 Edited by I_Stay_Puft (3810 posts) -

@humanity said:

@fritzdude said:

Did Ubisoft seriously expect users to either have the machine to hit a solid 60 frames per second or did they expect players to be OK With fluctuating 60-30-15 frames per second gameplay? What's more baffling is that if you hit the Windows key and press L (win+L) and lock the desktop while in-game session, log back in and enter the game then the game doesn't fluctuate any longer. What is up with that? You would think after 6 game updates Ubisoft would have fixed this by now. I recently started playing this (aswell as other video games) and it just perplexes me that something like this exist on a fairly new game.

Everything I've played from Ubisoft on PC has been poor in performance. AC4 ran questionably no matter what options I turned on and off. Splinter Cell Blacklist was likewise unstable despite not looking that amazing for the most part.

The real kicker is the lackluster performance of Trials Fusion of all games. The gameplay is fine but man the load times on some things are quite obviously a bug.

I actually remember Splinter Cell Blacklist running quite well, so did for the most part Assassins Creed III. Still kinda baffled with AC4 poor optimization. Haven't touched the game since November but I'll assume the game on PC is still pretty poor and they haven't fixed it right?

#33 Posted by FritzDude (2273 posts) -

@humanity said:

@fritzdude said:

Did Ubisoft seriously expect users to either have the machine to hit a solid 60 frames per second or did they expect players to be OK With fluctuating 60-30-15 frames per second gameplay? What's more baffling is that if you hit the Windows key and press L (win+L) and lock the desktop while in-game session, log back in and enter the game then the game doesn't fluctuate any longer. What is up with that? You would think after 6 game updates Ubisoft would have fixed this by now. I recently started playing this (aswell as other video games) and it just perplexes me that something like this exist on a fairly new game.

Everything I've played from Ubisoft on PC has been poor in performance. AC4 ran questionably no matter what options I turned on and off. Splinter Cell Blacklist was likewise unstable despite not looking that amazing for the most part.

The real kicker is the lackluster performance of Trials Fusion of all games. The gameplay is fine but man the load times on some things are quite obviously a bug.

I actually remember Splinter Cell Blacklist running quite well, so did for the most part Assassins Creed III. Still kinda baffled with AC4 poor optimization. Haven't touched the game since November but I'll assume the game on PC is still pretty poor and they haven't fixed it right?

I cannot speak personally on how the performance was on the launch of AC4, but all I know is that it says Version 1.06 on my game and the game runs poorly compared to what the hardware is and is capable of. Not to mention the fluctuation because of Vsync issues. And I agree with you on the Splinter Cell Blacklist; It runs just fine even if it's poorly optimized for multi-threaded CPU's. And I can addition Far Cry 3 too as a very good optimized game for PC from Ubisoft. I haven't played AC3, nor Trials Fusion so I don't know how they perform.