#1 Posted by skipper00 (61 posts) -

Hey. So I have battlefield downloaded from the psn store on ps4. The multiplayer is fine. However I cannot get passed a mission in single player because it keeps crashing.

The mission is Tashgar and I can get passed the first 2 sections but when I try to run into the park it crashes and kicks me out of the game. I must have tried this about 15 times. All my patches are up to date. Is there anything I can do? Or do I have to re download it from the store?

Any info would be great :)

#2 Edited by spraynardtatum (3713 posts) -

I'd say wait. A lot of people, including myself, have had their save file corrupted for the single player. I haven't heard of your issue yet, redownloading might work but honestly you're probably better off waiting for the next round of patches. Best of luck.

#3 Posted by afabs515 (1328 posts) -

It's just a broken game. Sadly, it seems like you have no choice but to wait for EA/DICE to patch it.

#4 Posted by jArmAhead (341 posts) -

I'd say don't worry about it. The first level is the only decent one in campaign. Try restarting the campaign?

#5 Posted by kaos_cracker (714 posts) -

I had a save get corrupted once. After the latest patch that was supposed to fix campaign corruption, I went through and did the whole campaign in one sitting and got all trophies just in case. If the same mission for you is crashing, write about it on the crash screen then post it on the Battlefield Support forums to see if others have that problem.

#6 Edited by TheManWithNoPlan (6001 posts) -

I tried to get through the campaign twice and both times it informed me the save file was corrupted. The first time through it was a message when I went to go back and play more of the game. The second did the same as the op's and just kicked me out of the game, then informed me the save was done for. Funnily enough, the time I spent with the multiplayer was fairly okay and I didn't experience too many problems. At least, not enough to ruin the experience.

#7 Edited by flindip (534 posts) -

Yeah, it crashed for me twice in a row on Tashadar mission today. Fortunately, its not corrupting my save and just defaults back to the last known checkpoint. So, I can restart the mission at least. Although i'm not sure if I will be able to finish it.

Dice/EA REALLY drop the ball on this game. The bugs/glitches/tech problems have really hurt this a game. Thats what you get when you rush it to release without testing. Its too bad; they really could have taken advantage of the mediocre COD game. I'm sure in three months BF4 will be great, but people will already be moving on to something else. Its a shame...

I really hope they don't pull the same crap when Battlefront comes out in two years...

#8 Edited by jaybvo (1 posts) -

I also have the same issue as soon as I walk through the arches it crashes! A ps4 update was rolled today so maybe that's caused it, hopefully they will sort it ASAP.

#9 Posted by Sackmanjones (4761 posts) -

I haven't had an issue so I can't help you on that front. I can however say that you should just play multiplayer because it's a goddamn blast and sounds like it's working for most people now

#10 Posted by flindip (534 posts) -

Yeah, I went back and played it and was able to finish the campaign and got all the trophies I needed. I don't know if they fixed it per se. But it worked for me...

#11 Edited by Seppli (10250 posts) -

Luckily my save got corrupted after I've finished the campaign and unlocked all the guns associated with it. Dat REX is a keeper.

Dunno about your specific bug. I think my game crashed there too. Did you try restarting the whole level? That should fix it.