• 140 results
  • 1
  • 2
  • 3
#101 Edited by Sooty (8082 posts) -

Game looks great, but stutters like crazy at random times. It's not a very good PC version.

I'll try that ini tweak above. It runs perfect on ultra for me aside from the very random stuttering that happens.

I'm not really sure why looking at closed doors makes my PC drop to like 10 FPS, then goes back up as soon as they open. It happens sometimes...weird.

I hope this isn't a case of the game just running bad on Nvidia cards. Always seems convenient to me when there's an AMD/ATi logo on startup and then it has issues on my Nvidia card. (and vice versa when I had a 4870)

#102 Posted by Humanity (10145 posts) -

Darn, decided to buy this for PC on a whim since I have a pretty good computer overall and was running Sleeping Dogs maxed with no hitches - but it appears it's not really optimized that great. One of the main reasons I don't really like PC gaming all that much, I'd rather get a consister 24-30FPS on a 360 rather than 60 frames one second then 20 frames another. Well I got it running pretty alright but rats, was hoping this would be smooth sailing.

A bug I encountered is that, I think, after taking a screenshot through Steam the game would bog down to 2FPS at the next autosave. I'm only saying it might be because screencapping because it hasn't happened again since I stopped taking screens, and I'm a compulsive Steam-Screen-Capper. Maybe it's for the better..I.. I don't need THAT many pictures of virtual pretty teen lady..

#103 Posted by Sooty (8082 posts) -

I don't regret buying it on PC purely because I got XCOM with it!

#104 Posted by Bourbon_Warrior (4523 posts) -
@zurv said:

running fine maxed with 2560x1600 on 3 titans... as it should for the cost

Do you do animation or something on that PC, 3 Titans is severe overkill for gaming.

#105 Edited by Sooty (8082 posts) -

Just had a fight with a handyman, yeah I really wish I didn't bother with the PC version. It stuttered like crazy and I almost died on medium. christ.

I assumed this would be a pretty solid port, never expected issues like this.

#106 Edited by Karkarov (3293 posts) -

@rvone said:

@karkarov said:

Game looks great on pc, seriously. Anyone who thinks the textures weren't up to snuff was never going to be satisfied no matter what they looked like. Make sure to download the newest non beta drivers for whatever graphics card you have, both companies just released new ones for this game.

For the record I am playing it maxed out with as wide a field of view as possible at 1080. I use a 670 gtx, a 2600k i7, and 16 gig ram. I am running over 70 fps most of the time with a dip to low 60 high 50's here and there. When fraps is running I still get mid 30's.

How far along in the game are you? You say you have it maxed out, does that include ultra shadows and the highest setting for AO?

The early part of the game runs really well, but you should be seeing significant slow-down a little ways into the game with those settings.

I have encountered handymen. And I don't mean in a "hey look at the guy at the raffle/fair" way.

#107 Posted by 00 (141 posts) -
@vitor said:

@00 said:
I've just come across this, and from a brief amount of testing, it seems to have actually fixed the stuttering:

Set bUseBackgroundLevelStreaming=false in

\Users\###\Documents\My Games\BioShock Infinite\XGame\Config\XEngine.ini

I cannot recommend enough that people DO NOT do this.

I did, and while it fixed the streaming (hitches still happened but it was much less frequently), some levels now refuse to load.

If you do this, you may get stuck on an infinite (no pun intended) loading screen when trying to re-enter certain areas.

Unfortunately you are right. It was running nice and smoothly for me and then a couple of hours in, I hit a load screen that just stayed there indefinitely.

So it looks like they will need to patch the game, because streaming is totally broken right now.

@spudbug said:

I don't know if it will come back after playing for a certain amount of time, but the following fix seems to have helped a LOT. It's very, very smooth now.

- Open BaseEngine.ini (Bioshock Infinite/Engine/Config)

- Increase [MemoryPools] values to 512 or 1024. ( I used 1024)

- Set MaxSmoothFrameRate to 59 FPS.

Didn't seem to make a difference to the stuttering here, I tried all of those things before disabling background level streaming.

@sooty said:

Game looks great, but stutters like crazy at random times. It's not a very good PC version.

I'll try that ini tweak above. It runs perfect on ultra for me aside from the very random stuttering that happens.

I'm not really sure why looking at closed doors makes my PC drop to like 10 FPS, then goes back up as soon as they open. It happens sometimes...weird.

I hope this isn't a case of the game just running bad on Nvidia cards. Always seems convenient to me when there's an AMD/ATi logo on startup and then it has issues on my Nvidia card. (and vice versa when I had a 4870)

It seems to be a problem with the engine streaming in level data, rather than a GPU problem. As I mentioned earlier, my GPU usage actually drops to about 30-40% when the stuttering happens. (which could also indicate problems with CPU load, but that was far below 50%, so it seems unlikely)

It's not a disk access issue either, as people have tried running it off a RAM drive.

I'm just surprised that none of the reviewers seem to have mentioned this, especially when there are some sites splitting up reviews between the PC and console versions of the game.

@zurv said:

running fine maxed with 2560x1600 on 3 titans... as it should for the cost

It's hard to even tell in your video because you seem to take three steps forward before stopping and looking around - and your mouse settings mean it jumps around instead of moving smoothly.

But look at 23:05 in the video (I was just skipping through to see if I could find anything, rather than spend 30 minutes watching it all) that's a good example of where the game stutters badly, and it only gets worse the further you are into the game.

But if you are happy running SLI, you probably don't notice stuttering much at all anyway.

#108 Posted by mostman (252 posts) -

Just an update from me - I started the game over with the streaming param put back to True and everything is fine now. Again - do NOT touch that parameter. Things get all kinds of broken.

So now, on my 660, I'm running 60fps on High or Very High. But I still get the new section loading stutters. I'll go from 60 to 10 to 60 ALL the time when moving from one section to another. Its not as bad on High - so thats where I'll stay until they patch this. I get 60 on Ultra but the stuttering just makes it unplayable.

#109 Edited by Sooty (8082 posts) -

Hmm, I'm tempted to wait for them to patch it then. If they patch it.

The stuttering is really offputting. You'd think they would have this down by now, Unreal Engine has been used for years and years. It amazes me stuff like this even makes it past QA.

and as usual no reviews seem to be mentioning it. Gaming journalism!

#110 Posted by mostman (252 posts) -

@sooty: It's especially odd because the fair section in the beginning is the worst offender. As you come down the stairs and see all the vendors and game stalls, it just CHUGS. As an experiment, I knocked down to Low and it still dropped to 10fps as I spun my viewpoint to show the vendors. So it has nothing to do with GPU. There is some CPU bound problem going on here. Considering its within the first 20 minutes of the game, I have absolutely no idea how this made it through. Its 100 percent reproducible on all settings.

#111 Edited by Hitchenson (4682 posts) -

I'm not getting frame drops and I'm running it maxed out. Guess I'm one of the lucky few.

#112 Posted by Sooty (8082 posts) -

I'm not getting frame drops and I'm running it maxed out. Guess I'm one of the lucky few.

ATi or Nvidia?

#113 Posted by Humanity (10145 posts) -

Yah the biggest issue for me is that the performance of the game can be best described as "erratic" no matter how much you tweak the options. There are some games that need power to be run on higher settings but if you drop a few options down will run smooth as butter. Infinite seems to continuously be doing something that makes it dip in performance regardless of your settings and it's something that obviously has to do with optimization.

#114 Posted by Sooty (8082 posts) -
#115 Edited by mostman (252 posts) -

Someone needs to post a comment over there to NOT do the background streaming thing. I don't have an account.

I've heard that the pool params are just ignored anyway. I'll be interested to see if it helps you.

#116 Posted by thetenthdoctor (291 posts) -

Game plays great for me, but

EARLY SPOILER

During the fight with the Crow dude, it hitched and stalled for a second every time the guy reappeared. It's like it had to reload his character model every time he teleported, which caused my controls to freeze and get whacked in the head by him.

END SPOILER

Beautiful performance except when it streams in new assets. A patch would be nice.

#117 Posted by Sooty (8082 posts) -

Game plays great for me, but

EARLY SPOILER

During the fight with the Crow dude, it hitched and stalled for a second every time the guy reappeared. It's like it had to reload his character model every time he teleported, which caused my controls to freeze and get whacked in the head by him.

END SPOILER

Beautiful performance except when it streams in new assets. A patch would be nice.

Wait until you get to the handyman dudes, holy damn does it need patching.

#118 Edited by mostman (252 posts) -
#119 Edited by therealminime (235 posts) -
#120 Posted by Sooty (8082 posts) -

I think it benefits a lot from being quite cartoony. It's how TF2 still looks so damn good even now.

I wish more games would go for it instead of the SO REAL brown.

#121 Edited by Sooty (8082 posts) -

@mostman said:

Someone needs to post a comment over there to NOT do the background streaming thing. I don't have an account.

I've heard that the pool params are just ignored anyway. I'll be interested to see if it helps you.

Tried all of them, still a stuttering mess at random times.

So annoying, it's super smooth and then it all turns to shit for a few seconds, then back up, then back down. I'm just going to wait for a patch, I'm actually struggling on medium because of this, robot in my face and I'm there lagging around.

#122 Posted by believer258 (12216 posts) -

I'm not having a ton of issues, it just seems to do a bit of stuttering occasionally. I always thought it was just loading in new textures or quick saving.

#123 Posted by Sooty (8082 posts) -

I don't think it's loading in new stuff that is the problem, one example would be that I was walking through a room I had already been in, I turned around and looked at a desk, BAM, crazy stuttering all of a sudden.

It's the same thing with doors, when you close them the game turns to shit. It doesn't happen all the time but more often than not. Really weird.

It's most irritating during combat, when it's really hectic and you're moving the camera around a lot to aim the stuttering can make it almost unplayable, so I'm gonna wait for a patch I think and hope for the best. I'm about 6 hours in but I don't wanna continue tarnishing the experience with the "FFFFFFFFFFFFFF" moments I'm getting because of the stutter.

#124 Edited by SpudBug (633 posts) -

I dunno, i played another few hours today and no stuttering. I have adaptive Vsync on so sometimes when it's loading a new area it tears for like 5-10 seconds but it's no big deal. Otherwise solid 60fps and running around 55-60 degrees, not even using 75% GPU.

#125 Posted by amir90 (2178 posts) -

Runs great on my 6950 and i7@2.67GHZ. It isn't all maxed about, but still looks very good:) Haven't had any problems in combat so far.
Playing at 1920x1200

#126 Edited by myketuna (1765 posts) -

I'm knocking on wood because my experience has been pretty flawless. I only get stuttering when it saves and for some reason it loaded when going in and out of The Forgotten Traveler bar early in the game (the area where you have to find something). But that wasn't really so bad. Other than that, I'm trucking along pretty well. I hope it stays that way.

Ah, I almost forgot. In case it matters:

CPU - Intel i5-2500K

GFX - eVGA GTX 570 HD Superclocked

1920x1080, Ultra textures, no filtering. I don't remember what else.

#127 Edited by Boboblaw (330 posts) -

Just played about an hour of it, seems good thus far but the performance is something that has been weird. The game has been running somewhat playable thus far with occasional times the fps drops extremely low and times it's super smooth. So the weird thing is that it runs pretty much that way in all the graphics settings be it ultra or very low.

Could just be my PC as I've had some problems with games that should run on my hardware (i.e. sleeping dogs should've run fine but really struggled). Gonna persist but might just grab the 360 version eventually.

p.s. Running a 5850HD

#128 Edited by HisDudeness (254 posts) -

SPOILER QUESTION



Does anyone besides me get stuck in the Good Times club because of Cell 9 not opening because the game thinks I'm in combat?

#129 Posted by Andorski (5374 posts) -

The stuttering issue seems to be a issue concerning texture load, at least for me anyways. I would get random frame drops in the single digits with settings on high/very high. I dropped the texture settings to normal and now the stuttering is less frequent and only drop to ~40fps when they occur. Still not perfect and since I have a GTX 570 I would expect much smoother performance at higher graphical detail, but for now this is an acceptable way for me to play. Hope nVidia comes out with another driver release ASAP.

#130 Edited by Syndrom (368 posts) -

so these problems are mostly for people with nvidia cards? I have a HD 7870 and so far the game runs just fine. Granted, i'm not that far in, but still. Even on the skylines it runs fine

#131 Posted by GetEveryone (4458 posts) -
  
#132 Edited by zenmastah (999 posts) -

Try using the ingame vsync but setting maximum pre rendered frames to 3 in Inspector, if youre a nVidia user that is..

#133 Edited by Humanity (10145 posts) -

I'm on an ATI card and I've fiddled with ingame settings a lot. Dropping shadows to low and turning a few other options to normal has smoothened my gameplay but I'm certain it's a game issue because I'll still encounter crazy frame drops when walking around, indoors, with no action or particularly impressive light work. The game just seems to start doing something in the background and then the framerate dips.

#134 Posted by Sooty (8082 posts) -

http://www.giantbomb.com/bioshock-infinite/3030-32317/forums/pc-stuttering-fix-1430346/#0

#135 Posted by Syndrom (368 posts) -

@humanity said:

I'm on an ATI card and I've fiddled with ingame settings a lot. Dropping shadows to low and turning a few other options to normal has smoothened my gameplay but I'm certain it's a game issue because I'll still encounter crazy frame drops when walking around, indoors, with no action or particularly impressive light work. The game just seems to start doing something in the background and then the framerate dips.

what card do you have?

#136 Posted by StarvingGamer (8560 posts) -

Weird. I just beat the game and had 0 problems the entire way through. I didn't even know this was a thing until just now.

#137 Posted by Teoball (643 posts) -

I played through it last night and the only thing I noticed was a half a second stutter once in a while when entering new areas. Everything else was totally smooth.

i7 2600
GTX 680

#138 Posted by Wheady (101 posts) -

@teoball said:

I played through it last night and the only thing I noticed was a half a second stutter once in a while when entering new areas. Everything else was totally smooth.

i7 2600

GTX 680

yea, this is all i have been noticing as well. everything is smooth in combat, even when riding on the rails. ive got a FX4100 and 7850.

#139 Posted by Humanity (10145 posts) -

@syndrom said:

@humanity said:

I'm on an ATI card and I've fiddled with ingame settings a lot. Dropping shadows to low and turning a few other options to normal has smoothened my gameplay but I'm certain it's a game issue because I'll still encounter crazy frame drops when walking around, indoors, with no action or particularly impressive light work. The game just seems to start doing something in the background and then the framerate dips.

what card do you have?

It's an ATI Radeon HD 5800 series - I should upgrade but I play PC games kinda rarely so it's hard to justify a beefy card purchase

#140 Posted by BeachThunder (12450 posts) -

:O Finally found a way to remove the hud. I suppose I have to do a second playthrough now...

HUD hide >>

Was:

[XCore.XScreenManager]

bUseDefaultSafeRect=true

SafeRectX0=0

SafeRectY0=0

SafeRectX1=1920

SafeRectY1=1200

MaxDefaultSafeRectAspectRatio=1

Became:

[XCore.XScreenManager]

bUseDefaultSafeRect=false

SafeRectX0=0

SafeRectY0=0

SafeRectX1=3840

SafeRectY1=2400

MaxDefaultSafeRectAspectRatio=1

Crosshair hide >>

Was:

[XCore.XClikHUDCrosshair]

ShowAnimationFrameName=Shown

HideAnimationFrameName=Hide

EnterCombatAnimationFrameName=EnterCombat

LeaveCombatAnimationFrameName=LeaveCombat

HitTargetAnimationFrameName=HitTarget

NotTargetingStateFrameName=Normal

TargetingStateFrameName=Targeting

FriendlyTargetStateFrameName=TargetingFriend

InvalidCrosshairFrameName=None

InCombatStateFrameName=EnterCombat_END

OutOfCombatStateFrameName=LeaveCombat_END

MaxSpreadInScreenDistance=500;

SpreadFrames=200

Became:

[XCore.XClikHUDCrosshair]

ShowAnimationFrameName=Hide

HideAnimationFrameName=Hide

EnterCombatAnimationFrameName=Hide

LeaveCombatAnimationFrameName=Hide

HitTargetAnimationFrameName=Hide

NotTargetingStateFrameName=Hide

TargetingStateFrameName=Hide

FriendlyTargetStateFrameName=Hide

InvalidCrosshairFrameName=Hide

InCombatStateFrameName=Hide

OutOfCombatStateFrameName=Hide

MaxSpreadInScreenDistance=500;

SpreadFrames=200