#1 Edited by soup_menu (223 posts) -

(Shout out to @peteace for posting about this in the API Developers forum a little while back.)

Some images are coming back 404 with an XML payload like:

<Error>

<Code>NoSuchKey</Code>

<Message>The specified key does not exist.</Message>

<Key>

uploads/scale_large/0/26/2655079-screen shot 2014-07-08 at 10.00.34 pm.png

</Key>

<RequestId>7F8696A27F17C197</RequestId>

<HostId>

YiWBYydNjTWtHvK/P0lXXLTFGu638kYvZBfF2jFyk8qdtYv2ntIoSoFXlyF0OMk1z27p9K6vKV4=

</HostId>

</Error>

A recent example is Jeff's latest "Jars" video. The "kubrick" image is fine, so the page looks alright on the site, but all of the images provided by the API are missing:

  • http://static.giantbomb.com/uploads/screen_kubrick/0/26/2655079-screen+shot+2014-07-08+at+10.00.34+pm.jpg
  • http://static.giantbomb.com/uploads/square_avatar/0/26/2655079-screen+shot+2014-07-08+at+10.00.34+pm.png
  • http://static.giantbomb.com/uploads/scale_medium/0/26/2655079-screen+shot+2014-07-08+at+10.00.34+pm.png
  • http://static.giantbomb.com/uploads/screen_medium/0/26/2655079-screen+shot+2014-07-08+at+10.00.34+pm.png
  • http://static.giantbomb.com/uploads/scale_small/0/26/2655079-screen+shot+2014-07-08+at+10.00.34+pm.png
  • http://static.giantbomb.com/uploads/scale_large/0/26/2655079-screen+shot+2014-07-08+at+10.00.34+pm.png
  • http://static.giantbomb.com/uploads/scale_avatar/0/26/2655079-screen+shot+2014-07-08+at+10.00.34+pm.png
  • http://static.giantbomb.com/uploads/square_mini/0/26/2655079-screen+shot+2014-07-08+at+10.00.34+pm.png

Another example (one given by peteace) is for the PSP game Freedom Wars. This time it's the boxart that's missing, so the wiki page is showing with a broken image. (edit: the Freedom Wars wiki page has since been fixed)

All of the files are supposed to be coming from static.giantbomb.com which appears to resolve to an Akamai facility (a23-74-8-83.deploy.static.akamaitechnologies.com [23.74.8.83] being the one I'm seeing). It seems like maybe the images either aren't getting created (an issue with the tool used to resize/crop the various resolutions?) or aren't getting mirrored across the Akamai CDN. (edit: There aren't any problems with Akamai. See below.)

#2 Posted by soup_menu (223 posts) -

@seraphx2 noticed that the issue is actually just that the links have the wrong file extension. All of those broken pngs should be jpgs.

#3 Posted by Laika (137 posts) -

@seraphx2 noticed that the issue is actually just that the links have the wrong file extension. All of those broken pngs should be jpgs.

Good tip.

Top Men™ are rewriting the image processing backend as we speak.

Staff