#1 Posted by Ageris (11 posts) -

I've just installed chrome v25.0.1364.97 m and I cannot click on ANYTHING anywhere on any page on giantbomb.com. I have tried three different computers, all running Windows 8 Pro and the same chrome version and the same problem exists on all of them. Everything seems to work just fine in IE10 though. We are all on the same network, but I cannot see how that should affect clicking. I'm also not able to alt-tab and hit enter to trigger anything. I don't remember when I started seeing the bug, but I think it has worked even with the redesign.

Using jQuery I can see that keypress events are bubbled to the body tag, but no click events. Is this a known issue?

#2 Posted by mrpibb (478 posts) -

can you see if you are blocking cbsinteractive.com? The new site has some tracking js that needs to be fired (we're working to remove this attachment) for each link to process.

#3 Posted by Ageris (11 posts) -

Sorry for the late reply. I'll check on it on monday and report back. I don't think I'm blocking anything myself, but I'm connecting through a proxy that may be blocking some stuff. Could that be what's causing the issue? It seems to work fine on IE on the same computer however.

#4 Posted by mrpibb (478 posts) -

that's a possibility. The tracking code unfortunately is not under our control, but we're digging in to remove the hook (a pain to go through for those who've worked with other's javascript).

#5 Posted by Ageris (11 posts) -

Ok, I just tested this and it seems to be caused by the proxy blocking the tracker. It does not appear to affect IE 10, but in Chrome I can only click the Store button while directly connected to the problematic network. If I VPN into an unblocked network all the links work. So the problem was on my end, but isn't it a bit extreme for a tracking script to block all links when it can't reach a server?