#1 Edited by TyCobb (2003 posts) -

Ever since the new site went live, chat has not worked for me. I can open up the page and watch the video, but that is all. The counter of people watching is greater than 0, but number of people chatting is 0 and nothing displays in the chat log.

I figured it was just down for everyone, but there has been a couple of times where the staff has mentioned something from the chat and that's when I refresh the page or open another tab to see if it is working again; unfortunately, I get the same result.

Currently using Chrome. I have not tested with IE. FireFox is currently uninstalled.

#2 Posted by rchen (183 posts) -

Thanks for the bug,

Just out of curiosity what OS are you on?

#3 Posted by TyCobb (2003 posts) -

Windows 7 - 64bit


#4 Posted by TyCobb (2003 posts) -

@rchen: Just popped open TNT and still no luck for me. Yesterday during the PS4 conference, I went ahead and tried with IE9-64 bit and same results. TNT currently has no chat for me with either Chrome or IE9-64bit.

Let me know if you want anymore information.


#5 Posted by Blu3V3nom07 (4204 posts) -

IE 10 Chat does not work. Please fix! Its the only browser I can get to work properly on my shit computer. : (

#6 Posted by rchen (183 posts) -

Hey, the servers crashed / were all running at 100% and I didn't want to kill it so people could still watch the feed...working on this as my top priority right now.


#7 Posted by TyCobb (2003 posts) -

Not a problem. I appreciate the update.

#8 Posted by MarcusTorrent (11 posts) -

I too am on Windows 7 - 64 bit and since just before the Sony Meeting I have been unable to view chat as well. I've been using Chrome to access the stream and chat.

#9 Posted by NoobSauceG7 (1327 posts) -

I have the same problem too, on Chrome using my Mac. Wouldn't be a huge problem but I just want to make sure I can see premium live content like tonight's unprofessional Fridays.

#10 Posted by Excast (1184 posts) -

It generally seems as if chat works fine until people start making polls, then it tends to go wonky and never really comes back.

#11 Posted by TyCobb (2003 posts) -

Not sure if this helps, but I noticed an error message section this time loading up Unprofessional Fridays. No message is present, but it looks like something got caught.

#12 Edited by Morbid_Coffee (974 posts) -

I'm getting the same error message. Chat worked okay, but disconnected me about five times before I started getting the error message. Now I can't see the chat.

#13 Edited by Scrumdidlyumptious (1679 posts) -

I got an error message as well except mine printed dictionary values too

EDIT: Got another error message:

#14 Edited by Illyr (84 posts) -

I can't see chat or polls.

Windows 7 64 bit. Chrome (tried firefox as well)

#15 Edited by TooWalrus (13333 posts) -

Chat for me is kinda working, but it's slow, thinks I post don't really show up, it's useless overall. Just another bug that needs squashing.

#16 Edited by Artso (80 posts) -

The stream stopped working for me during the live streams yesterday and today. Tried rebooting, refreshing, etc. Started working again after 30 minutes. Really annoying. Also having problems with chat.

Windows 8 64-bit. Chrome. Tried IE, Firefox etc.

#17 Edited by rchen (183 posts) -

So there's a few separate issues here.

Regarding IE10:

This is kind of a new one, will look into it. Looks like the stuff is there, but the actual chat messages don't show up. May just be a IE Javascript quirk..

Regarding not being able to connect to chat at all:

The chat system itself is still a work in progress. Once it hits about 2-3k users, servers start to back up in processing messages. I'm looking into a variety of things / fixes but this will be continually worked on until it is stable. Today's Unprofessional Friday gave me some hope and insight into the issue.

Regarding the stream being slow or stutters:

This is purely a Twitch.tv thing, if it stutters see if it happens on the actual Twitch.tv site, or try lowering / changing the quality of the video.

Thanks for your patience while we get this sorted out

PS. I left the debug message above the chat input box on accident, it'll be removed.

#18 Edited by TyCobb (2003 posts) -

Any progress? Still not working for me during Random PC Game.

#19 Posted by bkbroiler (1660 posts) -

I'm having the same issues as the topic creator. Can watch videos, can't see anyone chatting, says 0 in the counter. Right now I'm on Mac OS X Version 10.7.4 using Firefox. I haven't been able to test it at my home computer running Windows 7/Chrome, because live streams usually don't happen when I'm not at work.

Polls also scroll through a bunch at once quickly and sometimes in the lower right it says "Click here to refresh and connect to chat" or something but it always disappears really quickly.

#20 Posted by bkbroiler (1660 posts) -

I was able to get on a live stream at home and the chat worked fine for me. So it must have something to do with my crappy work machine.

#21 Posted by TyCobb (2003 posts) -

@bkbroiler: It works for some, but not others. It may be machine related, but it wasn't until the new site launch that I started having issues. Chat has never worked and I work from home so I am not behind any corporate firewall or anything that would affect this. There are others that have created threads about the same issue.

I hope this gets looked at soon. @rchen any progress on debugging this? Is there anything specific or other info you need?

#22 Posted by rchen (183 posts) -

Hmm this is weirdly inconsistent across machines / browsers. Personally I've tested on OS X 10.7 Firefox and Chrome (all vanilla versions, not dev or beta) and Win 7 Chrome.

I know that IE on Win 8 currently does not work. I'll do some more browser specific testing but on OS X it should at least be working.

What you can do to help is right click on the chat page in Chrome and click Inspect Element and go to the Console tab. Once there either take a screenshot or copy/paste the output and I'll take a look.

Thanks, and this is still continually being worked on / looked at

#23 Posted by Mizine (10 posts) -

@rchen I have been getting this You are not logged in! error on all live streams/chat. I am using chrome/win7. I can see changes to Global Chat Cooldown but chat is unavailable. I can also see polls but I can't participate.

I am, in fact, logged in.

Here is the error log:

#24 Edited by TyCobb (2003 posts) -

@rchen Here's the full source


Here's the requested screenshot. Could it just be a connectivity issue where I am not connecting to the correct server? Is there a trace route I should perform?

#25 Posted by Weltal (2300 posts) -

My chat just keeps telling me I'm not logged in.

#26 Posted by icytower38 (534 posts) -

Chat has not worked for me since the new site. Originally was on Windows 7/Firefox (latest) but now I'm running W8/Firefox and still nothing.

#27 Posted by mrpibb (478 posts) -

can you guys try chrome? Want to see if it's websocket related.


#28 Edited by rchen (183 posts) -

@tycobb: Can you click on the last tab there (Console) like so:


#29 Posted by TyCobb (2003 posts) -

@mrpibb: I am using Chrome.

@rchen: Sorry, I didn't see your post until after the stream had ended. I will grab a screenshot tomorrow during TNT.

#30 Posted by rchen (183 posts) -

@mizine: Just wondering, are you logged in via Facebook or Twitter? or just normally (username / pass)

#31 Posted by Mizine (10 posts) -

@rchen Just normally. I don't use Facebook or Twitter to log in.

#32 Edited by TyCobb (2003 posts) -

@rchen Here's the requested screenshot of the console.

#33 Edited by rchen (183 posts) -

@tycobb:Hey this happens on all browsers? also try refreshing a few times?

Also are you using any firewall software or behind a school/corporate firewall?

#34 Edited by TyCobb (2003 posts) -

@rchen said:

@tycobb:Hey this happens on all browsers? also try refreshing a few times?

Also are you using any firewall software or behind a school/corporate firewall?

I am not behind a firewall and am at home. I just opened up IE to test again. Chat still doesn't work, but this time the number of people chatting counter is freaking out instead of just saying 0 like it did a couple of weeks ago in IE.

It's constantly changing several times a second. Here's an example of what it is displaying:

1281 Chatting

1260 Chatting

1283 Chatting

-1 Chatting

1300 Chatting

0 Chatting

1293 Chatting

NAN Chatting

So yea, it seems to be freaking out because I actually did see a -1 and NAN (Not a Number) show up. At least this time using IE the chat counter at least displays something other than 0. No chat messages showed up though.

Refreshing and forcing full refreshes didn't seem to change anything.

#35 Posted by rchen (183 posts) -

@TyCobb Yeah I am seeing that issue too, although not -1 or NaN...

Can you try with Firefox?

#36 Edited by TyCobb (2003 posts) -

@rchen: Weird, my reply disappeared so hopefully this one isn't a duplicate.

I just installed FireFox 19.0.2 and chat actually is working. So not sure what is up with Chrome or IE.

So quick rundown of symptoms and browsers.

  • FireFox
    • Chat works
    • Chat counter freaks out
  • Chrome
    • Chat doesn't work
    • Chat counter always displays 0
  • IE9
    • Chat doesn't work
    • Chat counter freaks out
#37 Posted by rchen (183 posts) -

The counter freaking out problem was specific to today...we had some server issues. Glad to see that at least you can get in with Firefox...I am still working on chat as my main priority right now so I'll keep working with you on this.

Chat will not work on IE on versions before IE 10..even on IE 10 it could be iffy because it lacks support for the technology we use on chat.

#38 Posted by TyCobb (2003 posts) -

Sounds like a plan. Let me know if you need anything else.

I have no problem with it not working in IE. I don't use IE except for testing. I'll play around with Firefox. Maybe it is better now that they have released 7 different versions since I swapped to Chrome.

#39 Edited by G24S (301 posts) -

#40 Edited by huser (1159 posts) -

Still having an issue with chat not working.

States zero in chat and cannot place any comment in. Using Firefox 19.0.2

EDIT - Weirdly I can get the chat in Chrome but no video.

#41 Posted by Artof_War (133 posts) -

No chat for me either.

#42 Posted by rchen (183 posts) -

@huser: In Chrome, can you try going to twitch.tv itself and watch videos?

@artof_war: Which browser and OS are you on?

And are you guys behind any sort of firewall?

#43 Edited by Aeneas (35 posts) -

chat doesn't work in IE right now. I've never seen it work in IE. Chrome works. Windows 8.

#44 Posted by rchen (183 posts) -

@aeneas:Yeah, IE doesn't support websockets fully so it won't work on IE.

#45 Posted by TyCobb (2003 posts) -

How is this still not fixed in Chrome?

#46 Edited by JohnLocke (350 posts) -

Just to add, using Windows 8 64 Bit edition, and, like Windows 7, I can not get chat to show or function but can watch the live stream. This happens in Internet Explorer.

However, I would like to say the update to the site has been really good and this is the only bug that is something I see constantly crop up so good work on the rest of the site :)

#47 Edited by Zips (44 posts) -

For what good it'll do, I'll echo the problem with the chat not being visible since the site update. The video plays fine on the live page and on Twitch, it's just that the chat on the live page will not work.

Windows 8 Pro 64-bit
Firefox 20.0 (though again, this has been the case since the site update)

#48 Edited by TyCobb (2003 posts) -

Looking for some sort of insight on this.

#49 Posted by Mirado (1126 posts) -

@tycobb: I'm using Chrome 26.0.1410.43, on 64 bit WIndows 7. No firewall to speak of. Just got done with Jurassic Lark and was able to chat just fine.

I know that doesn't fix anything for you, but I don't think Chrome is the problem (unless you are using a more out of date build than I).

#50 Posted by TyCobb (2003 posts) -

@mirado: I am on the same version although I just restarted and am now on 26.0.1410.64 m

It worked in FireFox when I was requested to try it so it definitely isn't something with the computer. I run very few extensions. Only ABP, LastPass, AutoReload, and Speed Dial 2. ABP isn't the issue because disabling it yields no effect and the other 3 would not hinder the functionality.