#1 Edited by ghoti221 (50 posts) -

Hopefully this isn't a repeat (haven't been able to find it in the forums...)

I'm having trouble using the Giant Bomb menus on my iPad using Safari. When trying to use one of the pull-down menus (e.g. the main menu header at the top of the screen), the pull-down appears, but touching the appropriate section instead activates whatever is behind the menu.

So, for example, I go to 'www.giantbomb.com', I get the main home page, I click Videos, see the video drop-down, select 'TANG', and instead of seeing all TANG videos, I go to whatever article or video is headlined on the homepage.

As a work around, is there a way to force the mobile version of Giant Bomb? The iPhone menu version works fine. 'm.giantbomb.com' is currently 404 (don't know however if it's related to the domain name / virtual host issues that GB has been having recently though...)

Thanks,

JGH

#2 Edited by djou (878 posts) -

I have the same problem using the site on an ipad and Chrome. I'll click on the Forums tab and it doesn't take me to the forums main page. The pull down menu options do work if I magnify and click in close.

#3 Posted by ghoti221 (50 posts) -

Followup to this - the menu does appear to work when there isn't a clickable element behind it. So, in the Videos menus, I have problems most often with the elements on the lower right hand side as those menu items tend to be over the video area when you pull the menu down. But the Wiki menu works consistently, because it's almost always over the text on the headliner box.

JGH

#4 Posted by JCGamer (666 posts) -

Not exactly the same issue but I can't get to the "all topics" forum easily on the iPad either. On the PC, you hit the forums button it will just take you to all topics. On the iPad, just hitting the forums just brings up a pull down menu and I have to select something like general. From there I can hit the forums button on the left side of the screen. Annoying and not sure why this isn't working so smoothly.