#1 Edited by solidad5 (4 posts) -

Title pretty much says it. I have to go to youtube to play any of the giant bomb videos. If I don't, I can maybe get through 5-10 minutes of a video on the site and then they just stop. No buffering, or error messages. They just stop. Newest chrome installation (as of this message) and I update my java usually when it asks. Had no issues until the site "upgrade".

#2 Posted by ProfessorEss (7450 posts) -

I've been having similar issues since the relaunch.

I don't know if anything was updated recently or if I'm just having better luck but they've been playing a little more consistently on the site for me the last few days.

#3 Posted by solidad5 (4 posts) -

I waited quite awhile to even post this because I figured there would be hiccups....I have been using computers since the "baud" days, so I am pretty well versed in technology, upgrading and keeping drivers updated. I wish the videos would either go full youtube integration or HTML 5 and stop the pay gate on that stuff. As it is I can't actually use the site like I should be able to. If there was a paypal option I would be a member and this would probably be a moot point, but that's another issue entirely.

#4 Posted by Rafaelfc (1382 posts) -

the new video player is TERRIBLE

Online
#5 Posted by yoshimitz707 (2453 posts) -

You should post your OS and browser info if you want them to be able to help you.

#6 Edited by rchen (170 posts) -

@solidad5:Actually there is a HTML5 player, but it's only available for subscribers. Can you describe what happens when you try to play a video?

Also can you list what OS version and browser you're on?

Thanks!

#7 Posted by bibamatt (1089 posts) -

I'm Chrome Version 26.0.1410.43 on Windows 7. Same as OP, I get about ten minutes into a video and it just ends. I have to refresh the page to get it going again. I don't bother because, additionally, the videos take FOREEEEEEVER to start. An unreasonably long time. Has been this way since the site changeover. I never watch videos on the site anymore and I cancelled my premium membership because the site is essentially broken for me (and loads of other too, if the multiple threads about this issue are to be believed). I don't mean to sound so negative but it's a huge bummer because I love using this site and I love the video content. I was a happy subscriber since the minute subscriptions were available. I'm massively bummed out that, for months now, I've been missing all of the content because I'm unable to stream anything. I really want to watch Patrick's Monster Hunter Quick Look on the site. I've tried over and over again and I just can't get it to work past about six minutes in. Eventually went to YouTube and watched it there.

#8 Posted by solidad5 (4 posts) -

Running windows 7 64-bit...Updated this morning

Browser: Chrome....Just updated as of this posting. I don't run the beta builds. Just whatever the public gets.

Every video I have tried to run on giantbomb since the site upgrade does the same thing. After about 10 minutes the video just stops. No buffering, no errors. Just stops. If I refresh, the video plays for maybe another 10 minutes from where it stopped but then just simply stops again.

#9 Posted by phantomzxro (1578 posts) -

I can watch the video fine but it does not let me jump back or easily restart the video. I have to refresh the page in order to get it working again.

Windows 7

Firefox

#10 Posted by jimmyfenix (3858 posts) -

same here

#11 Edited by rchen (170 posts) -
#12 Posted by supamon (1333 posts) -

It's been like that for me since relaunch too. I've just stuck to youtube whenever possible since it has no issues whatsoever at 720p and I can skip around anywhere if I want.

Using Windows 7 and chrome.

#13 Edited by bibamatt (1089 posts) -

@rchen said:

Have you guys tried the other options in the player, like HTML5 and progressive?

Also be sure to check out this thread.

http://www.giantbomb.com/forums/bug-reporting-33/giant-bomb-video-faq-1425594/#0

Yeah, dead videos on every player option. I've never watched HD videos on GB, always just gone with whatever the default is. Seeing as the 'high' and 'low' options aren't working for me, there's no way I'll be going near the HD option. Another reason why I left that subscription behind.

Surely you shouldn't need an FAQ and a knowledge of HTML5/video codecs and Internet speeds to make videos work? They used to work every time by just pressing play. They're definitely broken for a large amount of people. Has something changed on Giant Bomb's end? I don't get this on any other site and I never had it on Giant Bomb until recently (well, a few months ago). I initially thought I was an edge case and that my Internet had gone crazy. But there's about four threads about this and they're full of frustrated people! Things like the videos just stopping ten minutes in and requiring a refresh surely aren't problems with our bandwidth? The videos buffer fine and play ok. Then they just end in the middle. Every time. At this point, I can't remember the last time I successfully watched a video on Giant Bomb. That's crazy in 2013. Looking forward to you guys fixing this - I'm sure you will! I really want to be a premium member again because I want to watch all this content that I love. But this site is essentially broken at the moment and I just can't bring myself to pay for that. *sad face*

#14 Posted by solidad5 (4 posts) -

I just want to watch videos. I am literally half-blind. I can't actually see HD. I don't fucking care about HD. EVER. I just want to see video....And I can't. I DO NOT EVER EVER EVER CARE ABOUT HD VIDEO EVER. can I just fucking see moving pictures..Please?

#15 Posted by bibamatt (1089 posts) -

I've made a little video of what happens every time so you can all wallow in my frustration. Again, this happens on no site other than GB and it never used to happen. Something's changed and it's fucked up the site's videos for a lot of us.

#16 Posted by rchen (170 posts) -

@bibamatt: Watched your video. Would you happen to have adblock running? If so try disabling it for Giantbomb and see if it helps any.

#17 Edited by jimmyfenix (3858 posts) -

@bibamatt said:

I've made a little video of what happens every time so you can all wallow in my frustration. Again, this happens on no site other than GB and it never used to happen. Something's changed and it's fucked up the site's videos for a lot of us.

THIS IS THE EXACT SAME THINGS WHICH HAPPEN TO ME

#18 Posted by alexisg (384 posts) -

@jimmyfenix: @bibamatt: What @rchen said. Does this happen with AdBlock on (pretty sure that is what that red hand is in your toolbar)? It's almost guaranteed that AdBlock will kill all videos.

Staff