#1 Edited by kortex (441 posts) -

I am digging the look of the new site but I am not a fan of the new fonts.

Take this quote from the latest Worth Reading: The Date is really hard to read. Is it January 28 or 23? 2013 or 2018?

In general this font looks fuzzy/blurry to me. Am I alone on this one?

fyi my screen resolution: 1680x1050 on a syncmaster 226cw

#2 Posted by alternate (2655 posts) -

I suspect it is your monitor. One of mine has a fonts problem but the other one - and the tablet - look really good. Same system but different results based on monitor.

#3 Edited by Nidzumi (107 posts) -
#4 Posted by kortex (441 posts) -
#5 Posted by void (49 posts) -

I remember reading one of devs mentioning this being a bug in chrome.

#6 Posted by Parsnip (1068 posts) -

I too am getting this on both firefox and chrome. Perfectly readable on IE.

#7 Edited by Parsnip (1068 posts) -

Just browsed the latest worth reading on firefox 20b1 and the quote font is still really bad over here.
It looks like the same font is used on the upcoming and Top Releases columns on the landing page as well, and it looks like ass there as well.

Specifically it's the Jubilat font that looks like butt in any kind of bold weight and smaller sizes.

#8 Posted by Winternet (7936 posts) -

Let me just say that the font used in the Worth Reading articles for the quotes makes it so hard to read. Surely there must be a better way.

#9 Posted by Flaime (525 posts) -

Yeah, same deal for me. I'm also using chrome.

I frankly can't read this without causing headache.
For a second I thought Crysis 8 had come out.
#10 Posted by MMiranda119 (5 posts) -

If you're using Chrome, a good workaround in the meantime is to install the Stylebot extension and set the Font Weight for the fuzzy font elements to Normal. I haven't grabbed all of the elements yet, but here's a screenshot of a few of them in Style bot:

#11 Posted by Spelda (3 posts) -

Mine looks a lot like Flaime's. I just can't read those quotes at all... I'm running Firefox 19.0 on Windows 7

#12 Posted by alexisg (372 posts) -

@Nidzumi is spot on. Some of the fonts are using bold instead of font weight :500. The problem is made even worst on certain browsers. I've gone through and made most of the fixes today but still working on it (next deploy should show those changes). Chrome on windows is especially tough since it uses the older gdi clear type instead of direct write. Hopefully they update this at some point.

Staff
#13 Posted by Subjugation (4693 posts) -

Hallelujah. So happy to hear this issue is being looked at because it is one of my only gripes about the site right now.

#14 Edited by Parsnip (1068 posts) -

Awesome, thanks for the update Alexis.