#1 Edited by Mento (3278 posts) -

Hey, this might be an issue reserved for those using the newest version of Chrome (I've noticed a lot of odd issues, like this accursed new scrollbar) and isn't really a big deal in the grand scheme of things, but the site's fonts are acting up. Essentially, they switch from the serif typeface the site uses for its headers and tabs to a larger version of the sans-serif typeface used for regular text. What's odd is that - in many cases - as soon as you wave the cursor over any of these instances, it'll change back to the original.

This might just be a Chrome bug, but I figured I'd log it if only to check if anyone else is seeing the same thing. Maybe I'm just assuaging a fear that this is all in my head. (Chrome Version 32.0.1700.72 m)

Moderator
#2 Edited by Chaser324 (7262 posts) -

I've been noticing this too. Web fonts on GB seem to occasionally not load in properly (the icon and serif fonts). However, I stick to the Chrome beta releases, so I assumed it was something that would be resolved before it got into the main releases (assuming this actually is a Chrome problem).

Moderator
#3 Posted by Rorie (3432 posts) -
Staff
#4 Posted by alexisg (411 posts) -

Is this on Windows?

#5 Posted by ZombiePie (6294 posts) -

@alexisg said:

Is this on Windows?

No it's on my porch.

Moderator
#6 Edited by guanophobic (435 posts) -

I've experienced it on Windows, non beta client.

#7 Posted by mlarrabee (3271 posts) -

@alexisg: I've had it happen in OS 10.9.1 under Chrome 31.0.1650.63.

#8 Edited by Mike (14571 posts) -

@chaser324 said:

I've been noticing this too. Web fonts on GB seem to occasionally not load in properly (the icon and serif fonts)...

I don't know if this is related to the issue or not, but Chrome seems like it usually has to wait for fonts.cbsi.com to load when refreshing the GB page.

Moderator
#9 Edited by Chaser324 (7262 posts) -

@mb said:

@chaser324 said:

I've been noticing this too. Web fonts on GB seem to occasionally not load in properly (the icon and serif fonts)...

I don't know if this is related to the issue or not, but Chrome seems like it usually has to wait for fonts.cbsi.com to load when refreshing the GB page.

I haven't looked into any of that. It's possible that the way the fonts are being loaded is setup to minimize slow down in page loads rather than to avoid all potential for FOUT ("Flash Of Unstyled Text") issues. If the TypeKit JS/CSS being loaded from fonts.cbsi.com is slow, then that could definitely be an explanation.

Moderator
#10 Posted by Bollard (6604 posts) -

@mb: Apologies for missing this thread!

#11 Posted by Mento (3278 posts) -

@alexisg: Oops, sorry, yes. Windows 7. Forgot that you don't get notifications for created threads like you do with blogs, my bad for the late reply.

I should also say that while the mouseover usually fixes it, it doesn't always. As long as it isn't symptomatic of a larger problem, though, I can't see it being a high priority fix.

Moderator
#12 Edited by flasaltine (1876 posts) -

@mento said:

@alexisg: Oops, sorry, yes. Windows 7. Forgot that you don't get notifications for created threads like you do with blogs, my bad for the late reply.

I should also say that while the mouseover usually fixes it, it doesn't always. As long as it isn't symptomatic of a larger problem, though, I can't see it being a high priority fix.

Well now it is stating to happen for me in articles and Video titles and descriptions. The text is sans-serif and then when I reload it becomes serif again. It looks really odd.

#13 Posted by alexisg (411 posts) -

Hmm well we are thinking about ditching typekit to avoid these dependencies. As more of the CBS sites start using fonts.cbsi.com I have started to see a few more of these sporadic complaints. I'll be working with the guys that run the fonts.cbsi.com server soon to see if we can increase the response time. Also if any of you are using the ghostery extension that would also screw things up. But like I said, looking into it.