#1 Edited by Teclo (158 posts) -

Both Firefox and Chrome make out that this is a fake site, a phishing site or whatever. I had to add an exception to be able to log in to report this. I'm assuming it is a bug rather than an actual security breach.

#2 Edited by TruthTellah (9634 posts) -

Yeah, has been happening for me, as well. Not sure what's going on. As you did, I added an exception, but it is certainly concerning.

#3 Edited by MrMazz (1065 posts) -

This only happens to me on the mobile site on my ipod touch using the chrome and safari for ios. Oddly not on my Nexus7.

Hopefully they get it fixed because I kinda like watching Preimum videos and user features.

#4 Posted by DeF (5216 posts) -

Even Thunderbird thinks all GB emails "might" be phishing attempts since the site relaunch.

Btw, I've also had the security certificate thing happen to me on the Wii U browser.

#5 Edited by alexisg (410 posts) -

@teclo: @truthtellah: @mrmazz: @def: Does this happen on all parts of the site? The login page, etc? Can you post a screenshot? I'll have someone smarter than I take a look at it but at first glance the certificate looks legit. I wonder if for some reason an ad or other external resource is being flagged as being suspicious.

#6 Edited by MrMazz (1065 posts) -

@alexisg: This is what I get when I try to login on on my iPod Touch using the latest version of Chrome for iOS

#7 Posted by Daveyo520 (7335 posts) -

This happens when I try to go to the log in page but nowhere else.

#8 Edited by TruthTellah (9634 posts) -

@alexisg: Seems to just be the login page for me. Has been that way since the new site came into effect. It's just the standard security certificate warning that looks similar to this:


#9 Edited by DeF (5216 posts) -

@alexisg: It's only the login screen. Once I hit "allow" it goes away.

#10 Edited by FTomato (245 posts) -

@alexisg: Happens in https pages. If it helps, the site where I work has been having problems with certificates issued by GoDaddy recently too, despite not having expired. We haven't resolved it yet (low priority, we're not web focused), so I'm not sure, but it might be their side that's causing the issues.

#11 Edited by Dagbiker (7022 posts) -

<p>I only got this problem at first. Im on the East Coast, around washington dc, if you need to locate the server. also chrome</p>

#12 Posted by Monkeyman04 (1474 posts) -

Also got this trying to log in on my Iphone with the latest version of chrome.

#13 Posted by alexisg (410 posts) -

Thanks for all the info and screencaps. Looks like there might be a chaining issue with certain browser and OS combinations. Working with godaddy to have this fixed asap.

#14 Posted by Gamer_152 (14282 posts) -

Not sure if this is of any use, but a few weeks back, on a machine running XP and Chrome, I put one of my Giant Bomb blog post URLs into a link shortener, and whenever I tried to follow the link that came out of it, it declared the site could not be trusted. Seems like the same issue.

#15 Edited by Morbid_Coffee (974 posts) -

I've been getting the out of date security certificate icon in the url bar for a few weeks now, but just today started getting the red warning screen in Google Chrome telling me auth.giantbomb.com isn't a trusted website.

#16 Edited by Nettacki (1332 posts) -

I just got it right now, too. Firefox told me so.

#17 Posted by idBloc (133 posts) -

Pushing a temporary fix... It will happen on other links throughout the website but will eventually be fixed in the next couple of days.

#18 Edited by Video_Game_King (36566 posts) -

Aw shit. It's happening to me, now.

#19 Posted by EXTomar (5029 posts) -

The cert is cached where the policy to refresh is often dictated by individual installs where if nothing else it doesn't bother looking till needs too. I suspect a wave of these are going to hit a bunch of people soon....

#20 Posted by Demoskinos (16300 posts) -

I didn't see this thread before but I'm getting this too now both on my Windows 7 phone and my PC in Chrome.

#21 Posted by TruthTellah (9634 posts) -

@alexisg: Just got this warning a little while ago after clicking to go from a PM to the original forum post. This thread: Link

#22 Edited by Foggen (934 posts) -

I was going to post something very similar, but now I don't have to. This!

I didn't see this thread before but I'm getting this too now both on my Windows 7 phone and my PC in Chrome.

#23 Edited by HerbieBug (4228 posts) -

Yep, using Firefox on Windows 7. Same issue just now.

#24 Edited by MonkeyKing1969 (3680 posts) -

I just started getting it today, yesterday it worked fine...today I get this certificate error. Using Chrome Browser on a Windows 7 Pro OS machine.

#25 Edited by kmg90 (462 posts) -

I love how chrome's error/warning is the most fear-mongering, way to scare the everyday user for something that happens often (especially on local network resources that generate local certificates).

I thought everyone was getting off the godaddy crap train?

Anyway sounds like the top men need to sort out what domains are tied to what certificates or apply all the domains to a single certificate via SAN (Subject Alternative Names).

#26 Edited by TheSouthernDandy (4011 posts) -

I'm still getting this on my iphone on Chrome. Just a heads up.