#1 Edited by HodorHodorHodor (3 posts) -

I receive this message in Chrome and three other browsers on Windows 7. Hasn't changed for about a week or two now.

#2 Posted by NoRemnants (378 posts) -

Make sure you don't have javascript turned off.

#3 Posted by HodorHodorHodor (3 posts) -
#4 Edited by Palmlykta (193 posts) -

I also seem to be affected by this. I don't have Flash and is not too keen on installing it...

#5 Edited by Rorie (2682 posts) -
Staff
#6 Posted by riddles (38 posts) -

Adding to an existing thread rather than creating a new one, i'm having this issue on my xbox one. Was fine, then stopped working a couple of weeks ago with the above error. Still broken when i checked last night. Html5 videos in general are working fine in the browser, and i cant find any settings that may have changed (there dont seem to be many browser settings TO change).

Please help/fix :)

#7 Posted by ioumac (1 posts) -

@riddles: im having the same prob happened after xbox update

#8 Posted by revengecat (27 posts) -

I now have this problem in OSX Safari. I have javascript turned on in preferences. I do not have flash installed for Safari. It works just fine in Chrome since it includes flash.

Not sure if this is because my sub just recently lapsed?

#9 Edited by revengecat (27 posts) -

Btw, i'm running OSX 10.9.2 (latest public release)

#10 Posted by Rorie (2682 posts) -
Staff
#11 Posted by Rorie (2682 posts) -

Well subs would have something to do with it; the HTML5 player has always been a premium-only feature, as you'll see when you mouse over it in the quality options:

It's possible you may have been accessing the HTML5 player in the past without a membership due to faulty detection; our engineer recently changed premium membership detection from javascript to PHP, so that might have knocked you out of being able to access HTML5. But, again, that was always intended to be a premium feature from the day that we debuted it. If you don't have the HTML5 option anymore, you'll need flash for the progressive/streaming options, or you can find most of the videos we publish on our youtube channel.

Staff
#12 Edited by HodorHodorHodor (3 posts) -

@rorie: That explains it. Thanks for following up, Rorie.

#13 Posted by riddles (38 posts) -

seems ok for me now thanks - atho i had to log back in this time so maybe thats it

#14 Posted by revengecat (27 posts) -

Ta. For anybody else on OSX and hates flash, isn't a subscriber, there's a lame way around it. From Safari preferences/advanced, enable the 'develop' menu item. Then next time you land on GB page and find a video you want to watch, go to develop menu and select 'User Agent' and switch to 'Safari iOS7'.