#1 Edited by Laika (148 posts) -

We recently started caching user avatars to make the chat more scalable. Some of you may find that your avatar is, uh, wrong.

Please post here if that's the case! Also, include whether your avatar is out-of-date, missing, or something you've never seen before, as well as the last time you changed it. This will help us debug this immensely.

#2 Edited by AlisterCat (6127 posts) -

Mine was just out of date. Changed about a week ago.

Online
#3 Posted by OlRattyG (3 posts) -

Mine shows it as missing.

#4 Posted by MAJID (236 posts) -

My chat avatar is out-of-date and was changed on the 9th of April.

#5 Edited by MattyFTM (14605 posts) -

Mine is an image that I've never seen before, and I'm pretty certain that the last time I changed my avatar was for Christmas 2012, so nearly a year and a half ago. I certainly haven't changed it recently.

This is the image that's showing up. I can't even figure out what it is.

EDIT: It think I've figured out what it is. It's an image of Daft Punk. Which I may have uploaded to the site many moons ago for some reason. It's certainly never been my avatar, though.

EDIT Again: OK, I'm pretty sure it's this image. Which I uploaded to the site in 2009, and has never been my avatar.

Moderator
#6 Posted by Camelizer (145 posts) -

Yeah my chat avatar is wrong. Specifically its out-of-date by like a couple weeks I think. The one that is currently showing up I used from July of last year until sometime earlier this month when I switched to my new one. Hope this helps.

#7 Posted by RJPelonia (909 posts) -

My chat avatar is currently something that was never used to begin with; It's displaying as this image which I uploaded a long time ago, but never set as my avatar before. I don't remember when exactly I changed it to my current one, but it was probably late last year or earlier this year.

#8 Edited by Dethfish (3739 posts) -

My chat avatar is something I've never used before. I changed to my current avatar after christmas

#9 Posted by SithToast (176 posts) -

Mine is wrong! I changed mine to my current one about a month ago. (March 27, 2014) The avatar I have in chat is my previous one!

#10 Edited by Aska (490 posts) -

Mine is out-of-date, changed it a little over a week ago.

#11 Posted by Milkman (17896 posts) -

Mine is wrong. It's some picture I've never seen or used before. I last changed my avatar on February 28th.

#12 Posted by Chaser324 (7108 posts) -

Yep. Mine was showing some random image of Big Boss that I've definitely something I've never seen before. The last time I changed my avatar was some time in January when I switched from my santa hat avatar to my standard avatar.

Moderator
#13 Edited by Seroth (754 posts) -

Mine is now showing as boxart from Body Harvest. That has never been my avatar before, but my original avatar is related to the game. I don't remember ever changing it.

#14 Edited by Gnubberen (814 posts) -

My avatar in chat is Johnny Sasaki. I'm pretty sure it was one of the first thing I added to the site. Never used it as an avatar though.

Edit

Yup totally was... This is the one it's showing in chat:

#15 Posted by firehawk12 (55 posts) -

My avatar is currently shown as a broken image file. I haven't changed it since I set it up years ago.

#16 Posted by Rorie (3380 posts) -
Staff
#17 Posted by MC_Harrison (2 posts) -

My avatar is shown as a broken image file as well. Just changed it from the default today.

#18 Posted by ElixirBronze (470 posts) -

my avatar is out of date.

#19 Posted by MooseyMcMan (11969 posts) -

The chat was displaying my older avatar.

#20 Posted by Shevar (144 posts) -

My avatar is out of date.

Online
#21 Posted by Ghost_of_Perdition (751 posts) -

My chat avatar is showing a picture of doomguy I uploaded back in 2008. The last time I changed it was in July.

#22 Posted by Carteret (5 posts) -

out of date, changed yesterday? Ish?

#23 Posted by Laika (148 posts) -

Thanks everyone -- we've narrowed down two specific issues and will hopefully have fixes up soon.

#24 Edited by Vigorousjammer (2844 posts) -

Yup, my chat avatar is messed up.
It's showing a random image I've never uploaded.

I changed it within the past month, not sure if that has anything to do with it.

#25 Posted by Jamin724 (327 posts) -

So I updated my avatar over a week ago and it is still showing my very first one not even the last one I had. I tried logging out/in and resetting the image. It shows up fine everywhere else but the chat.

#26 Posted by Uppercaseccc (146 posts) -

Mine is out of date, and I think I last changed my avatar about 2 weeks ago.

#27 Posted by Laika (148 posts) -
@jamin724 said:

So I updated my avatar over a week ago and it is still showing my very first one not even the last one I had. I tried logging out/in and resetting the image. It shows up fine everywhere else but the chat.

Is this your previous avatar (Noctis)? http://static.giantbomb.com/uploads/original/21/210224/avatar.jpg

I'll try to get it sorted out for you.

Mine is out of date, and I think I last changed my avatar about 2 weeks ago.

Please confirm that this looks okay: http://static.giantbomb.com/uploads/original/11/117948/avatar.jpg

--

Avatars are being cached for performance reasons. Chat gets such high load that we can't have our application servers responding to avatar requests from everyone connecting at once, so they're sent directly from the CDN. Unfortunately, this means we have to deal with several layers of cache optimization that we don't have direct control over: Cloudfront, Akamai and your browser. We'll look into ways to improve the accuracy of the caching, but there will always be the possibility that your chat avatar is out-of-date for some indeterminate period after you change your avatar on the site.

There were also previously issues with the daemon that handled these uploads, that led to the reports above, but those are hopefully(?) ironed out.

#28 Posted by Jamin724 (327 posts) -

@laika: My very first one is Noctis but I changed it to an image with "the magic touch" this is the one that I would like to be using. It works fine on forums and everywhere besides the chat.

#29 Posted by Laika (148 posts) -
@jamin724 said:

@laika: My very first one is Noctis but I changed it to an image with "the magic touch" this is the one that I would like to be using. It works fine on forums and everywhere besides the chat.

It should be up-to-date now. You may have to visit that URL and manually refresh it to see it.

#30 Posted by Jamin724 (327 posts) -

@laika: Tried refreshing in the chat now it still showing Noctis

#31 Posted by Jamin724 (327 posts) -
#32 Posted by kahi (140 posts) -

I guess I need to change mines size

#33 Posted by Meltac (2001 posts) -

@laika: I don't know what I'm experiencing has anything to do with what happened in this thread, but I just noticed that I don't have my profile picture in the chat. I just have the default profile picture. I have no idea when I changed it. I've tried clearing my cache, using different browsers, but it did nothing.

#34 Posted by Laika (148 posts) -

@meltac said:

@laika: I don't know what I'm experiencing has anything to do with what happened in this thread, but I just noticed that I don't have my profile picture in the chat. I just have the default profile picture. I have no idea when I changed it. I've tried clearing my cache, using different browsers, but it did nothing.

Your avatar should be at this location, but it appears to be corrupted (the server responds as if it's there, and that it's an image, but it's completely empty). I would try re-uploading your avatar and checking that URL within a couple hours (the chat version is uploaded on a delay).

If that doesn't work, you'll have to ping someone else, as I don't work at CBSi anymore. ;)

#35 Posted by jSlack (658 posts) -

@meltac: Hey man,

For next chat, check it out and let me know if it's working. I flushed your image from edge cache, so we'll see if it worked!

Staff
#36 Posted by defcomm (490 posts) -

Mine is missing in chat. :(

#37 Posted by 49th (3044 posts) -

Mine is also missing. I used the same one for about 2 years and only changed it for a while at Christmas.

#38 Posted by jSlack (658 posts) -
Staff
#39 Posted by sigspec (19 posts) -

After I upgraded from silver to gold it's just showing the default image. I've tried changing it on my user page without effect.

#40 Posted by edgework (195 posts) -

Uggghhh. This is something that came up about a month ago but whenever we try to figure out what's causing it it stops happening. I know for a fact that if your profile is edited for some reason, there's a chance your avatar will get jacked up. That also means that if your avatar is jacked up there's a good chance that if you do something to edit your profile your avatar will be fixed. We are trying to fix this for real.

Sorry, we suck.

Staff
#41 Posted by defcomm (490 posts) -

@jslack: I did several times and it didn't work. I'll try again before UPF today.