#1 Posted by Bullitus (112 posts) -

I just noticed that there's no sound on any audio only content on the site if I'm using Safari. The progress bar is moving and the playing animation appears but there's no sound. There's no problem with any other content or with other browser. I'm using OS X 10.9 and Safari version 7.0

#2 Posted by Rorie (2530 posts) -

@bullitus: Is this a Safari-exclusive problem? I.e. does it work on other browsers?

Staff
#3 Posted by DoctorSage (157 posts) -

Having the exact same problem, and it's only happening in Safari for me. Chrome works fine.

#4 Posted by Rorie (2530 posts) -

OK, I'll file a bug for it. Thanks for the note.

Staff
#5 Posted by jSlack (95 posts) -

@bullitus Do you have flash installed? Chrome has a built in flash API, where as Safari would require you have flash installed in your browser. In Safari, does the flash video load on: http://www.adobe.com/software/flash/about/ at the top?

Furthermore, can you go to: http://html5test.com/ and let me know which options are "No" under "Audio".

Thanks

Staff
#6 Posted by DoctorSage (157 posts) -

Does this help?

#7 Posted by Rorie (2530 posts) -

Pinging @jslack. Make sure you @reply engineers so that they catch your followups!

Staff
#8 Posted by kadaju86 (17 posts) -

@jslack Same thing happens here as well. Also running Safari 7.0 under OS X 10.9, pretty sure this issue only happened after updating to 10.9. Can see the Flash movie in the Adobe link just fine, and the html5 test shows the exact same results as @doctorsage except for me having a green checkmark on "WebM support". Audio (podcast) works fine in Firefox, but not in Safari. Video works without issue in both.

#9 Posted by jSlack (95 posts) -

@kadaju86 @doctorsage @bullitus @rorie Thanks for doing the test. I suspected it had to do with flash / security implementation in the new version of Safari. It seems there was something in a recent update. I suspected it was flash, however it could have something to do with a security policy. It wouldn't surprise me if Apple was doing something to audio playback in tabs playing flash.

I'm going to continue to test, and replicate the issue, I'll update this thread again shortly. I currently can't re-produce the results on my Macbook w/ Safari.

Staff
#10 Edited by Nodima (1057 posts) -

I have also had this issue since installing Mavericks (Chrome has frozen my entire computer for over a year whenever I try to launch it, and I don't have Firefox installed, so I can't test other browsers). No issues on Macbook running Mountain Lion in Chrome or Safari.

Online
#11 Posted by jSlack (95 posts) -

@kadaju86 @doctorsage @bullitus @rorie @nodima It looks like it has to do with some new settings in the New version of Mac OS (Maverick), and Safari. This looks to be a universal issue affecting tons of audio content, not just GiantBomb.

Do this:

1. Go to Safari settings -> Advanced

2. Uncheck "Stop internet plug-ins to save power"

3. Reload the page you are trying to use

Let me know if that works.

Staff
#12 Posted by Nodima (1057 posts) -

@jslack Even though I had that setting custom set to allow giant bomb plug-ins to start automatically, I guess maybe it wasn't considering any of the non-homepages? Worked for me.

Online
#13 Edited by kadaju86 (17 posts) -

@jslack Yup, that fixed it! Though I also had it set to custom like @nodima, but guess there was something not working correctly on that end. Anyways, thanks for the help^^

#14 Posted by jSlack (95 posts) -

@nodima @kadaju86 Awesome! I'm glad to hear it worked for both of you guys. This was a bug I didn't notice until I went to Mavericks at home (still using old version at work, due to compatibilities).

Thank you for reporting and testing! Much appreciated.

Staff