#1 Edited by narujoe93 (2465 posts) -

Says it all in the title. Also, Ive checked to make sure I have them turned on.

Edit: also..

OS: Windows 7 64-bit

Browser: Chrome

RAM: 4GB

Adblock is turned off for this site.