#1 Posted by zxero (4 posts) -

So up till 2 or so weeks ago, I was enjoying the benefits of premium. Now it tells me I need to upgrade my account? My most recent bank statement clearly shows the most recent charge in April.

I already sent an email to support on Monday, but haven't heard back still. Now that another Unprofessional Friday is upon me, I figured I would throw up a bug report to get things moving along.

PS - Of note is the fact that I dont know WHICH account has Premium. I thought it was this account, but I know I have 2 because of when the site was updating I couldn't access one of them for over a week, so I made a new one. But I can't even access that other account anymore, still, and if I try to reset password I get a goofy error about being required to sign in at least once.

Blah. Help, please?

#2 Edited by zxero (4 posts) -

Anyone? Anyone?

#3 Edited by Chaser324 (6389 posts) -
Moderator
#4 Edited by Sogeman (867 posts) -
#5 Edited by zxero (4 posts) -

Already emailed support, but don't see anywhere to submit support tickets. Am I blind or did you just mean emailing support too?

#6 Posted by Chaser324 (6389 posts) -
Moderator
#7 Posted by idBloc (126 posts) -

Last payment in our records and our third-party records : 02/21/2013 09:48:11 AM PST

We didn't bill you in April otherwise in case both systems don't show the transaction can you send me by PM the transaction name on your statement?

Now, I just need to figure out why it didn't bill you this month. If you are still interested in the premium I'd advise to resubscribe. Sorry for the inconvenience!

#8 Posted by Chrono_Defying_Ninja (25 posts) -

Hey @zxero,

@zxero said:

PS - Of note is the fact that I dont know WHICH account has Premium. I thought it was this account, but I know I have 2 because of when the site was updating I couldn't access one of them for over a week, so I made a new one. But I can't even access that other account anymore, still, and if I try to reset password I get a goofy error about being required to sign in at least once.

If I am seeing correctly, what you should be asking to do is get your password for your other account forcibly reset and one your posting with now deleted.
I would suggest actually stating the user ID of your old account in your PM to support or @idbloc would help locating your billing.

It would be better coming from yourself, however it does seem obvious to me that you pay monthly, have a silver membership on your other account and the account has a similar name to the one you have now.

Hope that helps.

#9 Posted by idBloc (126 posts) -

Ehhhhh I missed the second part of your message for some reasons. Can you send me by PM the name of the other account and its email?

#10 Edited by zxero (4 posts) -

Sorry I'm just now getting back on here, just left work. Tons of responses, thanks guys! I'll PM you with my email and other account name now.