#1 Posted by audioBusting (1672 posts) -

giantbomb.com/reviews is only showing the Guacamelee! review. The Guacamelee! review isn't showing anything either. I tried it both on my laptop's Chrome and my iPhone's Safari and neither worked.

#2 Edited by atomic_dumpling (2482 posts) -

Same here (Google Chrome 26.0.1410.63 on Ubuntu 12.04). Yet it has 75 comments already, so it work(ed) for those people, I guess. Other reviews are loading fine.

#3 Edited by Dogma (988 posts) -

Yeah, same problem here. I wanted to check out the comments in the review and saw that the whole things was broken. But it's only Guacamelee. Hopefully @snide or anyone else sees it soon enough.


#4 Posted by RVonE (4699 posts) -

Yep. On latest Chrome, latest Opera and latest Safari.

#5 Posted by Slag (4846 posts) -

It be busted for me as well. latest Chrome

#6 Posted by MariachiMacabre (7099 posts) -

Same. Latest Chrome for me.

#7 Posted by Elwoodan (874 posts) -

same for latest version of Firefox. (also I though this was a thread about how review scores are poorly implemented/detrimental, hah)

#8 Posted by Epyk (15 posts) -

Same, latest Chrome (26.0.1410.64)

#9 Edited by Chet_Rippo (238 posts) -

I'm able to see all the other reviews, but for some reason Guacamelee! hits a 500 error. (This is on latest Firefox)

#10 Posted by audioBusting (1672 posts) -

It works for me now =D