#1 Posted by LibrorumProhibitorum (335 posts) -

Hey, not sure if this has been brought up in a different thread yet but the staff tweets have disappeared. I'm not sure if this is a bug or if you guys are just retooling the staff tweets system or something. Just a heads up either way. I'm using Google Chrome and I'm on Windows 8 if you need to know that info.

#2 Edited by probablytuna (3522 posts) -

Are they finally swapping the Twitter feature out with forum threads? WOOOOOOOOOOOOOOOOOOOOOOOOO!

I'm also having this "problem", running on Windows 7 Chrome.

#3 Posted by psylah (2161 posts) -

They didn't disappear, they just deleted all the horribly racist tweets.

Which was all of them.

#4 Posted by IrrelevantJohn (1014 posts) -

Yeah I noticed they disappeared too! Along with my friend activity feed...

#5 Posted by Nekroskop (2786 posts) -

I miss the old top post forum on the frontpage. If I want to see tweets I'll use a twitter app.

#6 Edited by mrfluke (5044 posts) -

probably making room for a redesign down there to add the forums back.

#7 Posted by alternate (2679 posts) -

Are they finally swapping the Twitter feature out with forum threads? WOOOOOOOOOOOOOOOOOOOOOOOOO!

I'm also having this "problem", running on Windows 7 Chrome.

Can't see them making any big design changes while Dave is out spawning. Might be wrong though.

#8 Edited by TigerClaw (74 posts) -

My Tweets never showed up either, Its been like this for days now.

#9 Edited by Bollard (5198 posts) -

They're there for me. I wish they were getting rid of it for forums, or user activity (people I follow). That would be awesome.