#1 Edited by Scroll (601 posts) -

I subscribed around this time last year and I just checked to my subscriber info to make sure I'm continuing to subscribe this year etc. and my subscriber info is missing, and there is currently no option to change payment.

Is this just me?

#2 Posted by Scroll (601 posts) -

And now I don't have access to subscriber content and clicking the link to upgrade brings up the error page.

#3 Edited by Chaser324 (6744 posts) -

@scroll: I know there have been some recent issues with the billing system. @idbloc and @rorie are probably the people to get in touch with about your problem.

Moderator
#4 Posted by idBloc (124 posts) -

I'll double-check your account

#5 Posted by idBloc (124 posts) -

Is this link broken? https://auth.giantbomb.com/billing/

Or this one? https://auth.giantbomb.com/billing/update/

The latter one shouldn't work.. the first one should

If you could post back as soon as you tried so I can track the error.

#6 Edited by Scroll (601 posts) -

Both links work. Very weird. Apparently no record of my credit card as well.

#7 Posted by idBloc (124 posts) -

Seems the issue is fixed

I'd really love to know which link you clicked on to get to the broken page.

#8 Posted by Scroll (601 posts) -

The very awesome @rorie gave me a week of premium so I could watch the show tonight.

I went to the subscriber videos page and clicked the link to upgrade to able to watch the content and it took me to the standard 404 error page.

I have no idea why it's decided to mess up all of a sudden today, though I know my sub was meant to renew this month.

#9 Posted by firecracker22 (561 posts) -

I can't stream the live show, tonight. Every link I try, or even going on Twitch, can't seem to find Unprofessional Friday live. Is tonight's show cancelled or something?

#10 Posted by Aviar (452 posts) -

My account seems to have reverted back to free membership. I didn't get an email that my subscription was coming due and right now I can't view any premium member videos. Is there a problem with billing?

#11 Posted by Rorie (2987 posts) -

There are a few issues with some premium accounts having their billing history deleted somehow. We're looking into it, but in the meantime, just email your details to support@giantbomb.com and I can hook you back up with premium after I look into your billing data on our credit card processor's website. Sorry for the trouble!

Staff
#12 Edited by Rorie (2987 posts) -

@firecracker22: Did you find the link to the archive? The show did indeed broadcast on Friday afternoon, so I'm not sure why you wouldn't have been able to view it.

Staff
#13 Edited by AlexW00d (6436 posts) -

Lol as soon as I check this thread I realise my sub has come to an end, what a wonderful coincidence.

E: Oh god that lack of medal is depressing.

#14 Posted by firecracker22 (561 posts) -

@rorie I checked the archive and apparently my premium membership had expired. I didn't get an email though, and the weird thing about it on Friday during the livestream was that the link would take me to the 'No Show Currently' screen, instead of the membership dragon page I remember seeing before I was a premium member. I renewed, but truthfully I have no idea if the membership was supposed to expire or not.

I'll try emailing the support email you posted in your previous post, just to be sure though.

#15 Edited by IcarusFoundYou (145 posts) -

What's with everyone subscribing in May? (Was there a premium sale last May?) Apparently my billing history was deleted and I had issues with billing when renewing.

But thanks to @rorie for the quick response, I can finally watch Unprofessional Fridays now!

#16 Edited by Scroll (601 posts) -

Yeah I believe there was a sale around that time. Anyway I'm happy to resubscribe manually because this place is my favourite source for video game stuff and cake flushing.

#17 Posted by Rorie (2987 posts) -

We've been having some issues with billing histories being removed for some reason. Looking into it! Just email me at support at giantbomb.com if this happens to you.

Staff
#18 Posted by xwillx (14 posts) -

Hey Guys

My Membership relapsed this week as well, I've resubscribed and all premium content is working but I'm still getting banner ads any idea why that might be happening? Pre roll for video content is not being shown.

Thanks

#19 Posted by Peanut (955 posts) -

My premium account seems fucked right now, as well. I checked billing and it says my yearly renewed on the 7th, but I see ads everywhere and I can no longer access premium content. It was working properly last night, but suddenly it isn't.

#20 Edited by Rorie (2987 posts) -

@peanut: I hooked your account back up. No idea why that happened, so please PM me if it happens again. Sorry for the trouble.

Staff
#21 Posted by Brazzle (213 posts) -

@rorie: I got charged twice for my current annual subscription, anyway we can fix this?