#1 Posted by Almak (90 posts) -

In October I bought a month of premium, my account since lapsed into a free account again (which was as intended, since I only wanted a month) but the premium content is still available to me, even though it is clearly stated that I am a free user. I just wanted to make you aware of this, I am a big fan of the site and the work you guys do here thus it doesn't feel right to me to keep consuming the content when I clearly shouldn't have access to it but if this is not an isolated issue, someone might just feel otherwise, thus I feel this is definitely worth a look into.

I am using the latest version of Chrome and on top of that I have adblock and ghostery (both of which are whitelisting this domain, so I'm not sure if this is a factor at all). Otherwise I'm using Windows 8.1. Not sure if this info is of any help, let me know if you need any more information about my setup in case you deem it to be important to solving this.

#2 Posted by Chaser324 (6536 posts) -

Do you know when exactly your sub expired? There is a short grace period after the official expiration date that allows you a little time to renew without losing access. I imagine you're probably still in that grace period, but you can have @rorie check your account details if you're concerned.

Moderator
#3 Posted by Almak (90 posts) -

Hmm, well it started on October 25th, so I imagine it ended on November 25th, right? Unless I'm confused about how this works, than that would mean I had it free for 3 weeks now.

#4 Edited by Dauragon (554 posts) -

I had the same bug happen to me. I was able to see all the premium content for weeks after my membership lapsed. I only lost access after I cleared my cache for an unrelated issue.

#5 Posted by RazielCuts (2954 posts) -

@almak Your avatar still has the monthly sub emblem though. Go to 'Billing' on the dropdown when you highlight your profile name at the top and it will tell you what status your account is in and when your sub will expire.

#6 Edited by Almak (90 posts) -

I know, that's the weird thing though, under billing it already states that I am a free member. Oh and I just tried clearing the cache, no effect, still see the premium content. I guess it makes sense seeing as this might be the grace period that Chaser324 is referring to and it is all according to plan after all.

#7 Posted by Yesiamaduck (1069 posts) -

I changed my card and forgot to update my Giantbomb account and had a free access to the premium content for at least a month before I noticed this (realized I no longer had a silver ribbon) and amended the card details. I know the site by default usually allows your membership to lapse for almost a week but I thought o.O a whole month and counting? Bit extreme there

#8 Posted by MB (12389 posts) -

@almak: There is at least a 7 day grace period after your subscription expires before premium status is revoked, that could be what you're experiencing.

Moderator
#9 Posted by __pb__ (16 posts) -

My yearly subscription expired without notification. I just started seeing ads on my account today, though I haven't been to the site for a few days so I can't confirm the exact date when ads started appearing.

From what I can piece together from my email:

  • I originally subscribed on November 27th, 2011
  • I redeemed a yearly subscription code code on July 5th, 2012
  • My subscription should have renewed, or I should have received a notification, on November 27th, 2013

I don't know if I had automatic renewal turned on, but I do want to re-subscribe! I'll hold off on buying a subscription so that support can look at my account in case there's some clues there.

#10 Posted by Rorie (2896 posts) -

@__pb__: Can you email me at support@giantbomb.com so that I can look into this and follow up with you?

Staff
#11 Posted by Rorie (2896 posts) -

@almak: Are you still seeing the premium access? Can you click play on, e.g., last week's UPF?

Staff
#12 Posted by Nightriff (5080 posts) -

You are a good person to admit to this