#1 Posted by rivalscho0ls (5 posts) -

Ran into a little bug here with billing for premium memberships. Short version: Giant Bomb tried to auto-renew my premium membership using a card that had recently been stolen online (to buy $8,000 plane tickets - what a nightmare) and canceled. I received an email alerting me to this, so I logged in and changed the card. That was 9/26/13 - now on 10/24/13 I just logged in and was not premium, and could not look at my billing history. After looking through my own card history, I determined I was never charged for the Premium renewal even though I updated my card information, so I just "upgraded" today. Just thought it was weird that I updated my billing info and it still didn't go through.

#2 Posted by ikilledthedj (279 posts) -
#3 Posted by GnsDemon (115 posts) -

I had a similar thing happen. I logged into my account today and I'm not premium anymore. I've been a member sense about the time they started the premium up. I also go to my billing info and its completely empty too. I'm confused.

#4 Posted by Meepasaurus (213 posts) -

I had a similar issue and ended up just having to resubscribe using the "Change Plan" option. There's a known bug with updating your payment information.

#5 Posted by GnsDemon (115 posts) -

oh ok well damnit! I don't have a damn bit of money right now. AHHH I want to watch the newest Last souls part!

#6 Posted by Rorie (2857 posts) -

@meepasaurus: @gnsdemon: @rivalscho0ls: The bug with updating payment information should've been fixed earlier this month. Feel free to get in touch at support@giantbomb.com for specific billing issues, though; I'm loathe to discuss anything here about people's billing issues.

Staff
#7 Posted by guilherme (331 posts) -

This just happened to me right now... I've travelled for a month and did not login. Today I came back and when I logged back in I'm not Premium anymore. I updated the billing information, confirmed my subscription payment but I still see ads. This is a very strange bug. My billing history was empty too.

#8 Edited by Rorie (2857 posts) -

@guilherme: It looks like you still have the premium icon on your profile. Are you still seeing ads?

Staff