#1 Posted by Moth_Pope (450 posts) -

Hey. I've had a look around the forum to see if this had been answered but didn't have much luck, so here goes. I do most of my Giant Bombing on my Surface RT tablet which has always been awesome, but since the site's relaunch I've not been able to use the video player controls at all. Once I hit play, that's all I can do. I can't use the scrub bar, play/pause button, volume or fullscreen controls. It's like when I try and tap on the controls the tablet doesn't see them there.

On the previous layout the video player was identical on the Surface to if I was running the website on, say, Chrome on my PC. I also had the Embiggen and playback options (Youtube, Streaming, Progressive) too, which are no longer there when on the tablet (though I realise this may be down to coding on tablets vs. computers).

At the moment I find myself having to go to the Youtube channel to view videos fullscreen and use the controls, which I don't really want to do as I like browsing through the site and using the Premium HD options.

Everything else runs perfectly, but this has been a pretty big issue for me. Any help or suggestions would be great. Cheers!

#2 Edited by vogon (95 posts) -

OK, I spent like three hours debugging this just now.

technical details @snide and the other Top Men: it looks like GB serves the mobile video player (videoJSON.isDevice = true, videoJSON.device = "phone") to IE 10 on the Surface RT, in both desktop and Metro IE. if you break into the init function for the video player, set d.videoJSON.isDevice = false, d.videoJSON.device = "other", and screenfull = false, then resume, you get the desktop video player and everything proceeds as you'd expect.

otherwise you get the phone player (with all of the GB-skin controls hidden, but with IE's native <video> controls), and I think #uvpHi5's onclick handler swallows all click events on the native controls.

#3 Posted by Bollard (5203 posts) -

MothPope, I'm on my Surface now and haven't used the video player yet so can't comment on that issue, but I can't even @reply to you. Do you have the issue that the forum text box is just plain with none of the features like bold, quote, spoiler etc?

Also, in the forums for me no-one's profile pictures load on the left, and the main homepage is lacking the upcoming and new releases stuff that goes down the right. It's weird.

#4 Posted by Moth_Pope (450 posts) -

@vogon: Wow, that's great to hear. Thank you for looking into it. Hopefully top men will get on it soon! Cheers.

@chavtheworld: Sorry for the late response, I've been at work without the Surface so thought I'd wait to get home and try it out. After looking around, I've got the exact same issues as you. I can't @ reply to messages and the forum text field is completely plain without features... the home page is also lacking the same content you mentioned. I wonder why this is... I've noticed there's a lot more buttons that you need to hover over to see (ie. when I use my mouse to hover over your message on here, it get the Reply, Quote and Flag options), so maybe that's a reason?

#5 Edited by DaMisterChief (628 posts) -

Its like i just found a unicorn, how is that thing i was going to get one but got a unsubsided Nokia 920 instead

#6 Posted by ignignort (41 posts) -

Just posting in here to confirm the Surface RT video player issue

#7 Posted by Bollard (5203 posts) -

@MothPope, hmm, I'm replying from my iPod Touch now and just noticed the reply buttons and advanced editor stuff is missing here too. It must be treating the surface as a mobile device?

Also, the having to use a mouse to hover over stuff was also an issue in the previous version of GiantBomb, so I don't think it's that related - however, on this iTouch there are buttons for edit and flagging which are touch friendly (no hovering needed). If the surface is being handled as a mobile device it's weird it lacks these. Can't speak as to why you can't reply people on either however.

#8 Posted by fleabeard (164 posts) -

This video player problem makes my Surface sad.

#9 Posted by LucidDreams117 (375 posts) -

Problem with me too. Have a Surface RT. Video player makes me sad. I can also confirm that issue with the limited forums options. Even with attaching the keyboard and using the mouse, no options appear but the flag one and the box is plain. I'm guessing it's because the site recognizes my Surface as a mobile device such as a cell. I've been told there's a guy working on the video player often so here's hoping the issue gets fixed soon :)

#10 Posted by SPCTRE (180 posts) -

1. Issue confirmed on my Win 8 RT machine, i.e. Surface RT.

2. Thanks and props to @vogon for going the extra mile to give Dave and Alexis some technical details to go on.

#11 Edited by Snail (8574 posts) -
@chavtheworld said:

@MothPope, hmm, I'm replying from my iPod Touch now and just noticed the reply buttons and advanced editor stuff is missing here too. It must be treating the surface as a mobile device?

So according to what you're saying there, and according to @vogon's post, the problem you guys are having is that the site is treating your device like what it claims to be (a mobile device, i.e. a tablet)? But you want it to act as though you were on a laptop?

So the main issue here is that the website doesn't know whether to treat the Surface RT as a laptop or a tablet? So it's having the same problem as everyone else? ;)

#12 Posted by LucidDreams117 (375 posts) -

@Snail yeah that definitely seems like it. Though I don't think a tablet should be considered a mobile device really especially something like a Surface as opposed to say an iPad. Either way I don't care to be honest. I only want the ability to use videos controls like fullscreen and change the time. I'm only sad because Giant Bomb worked great before on my Surface, non mobile site.

#13 Posted by Moth_Pope (450 posts) -

@snail: A tablet is about as mobile as a laptop... I'd certainly group laptops and tablets together over phones and tablets (although the iPad is basically just a big iPhone, but still... other tablets can be a lot more "computer-y"). Like @luciddreams117 said, Giant Bomb's website ran perfectly on the Surface before, with all features, so it's just a shame and really stands out now that it doesn't.

The video fix is my main hope. Just hoping @snide and co can find a way around this soon. Site is awesome otherwise!

#14 Edited by fleabeard (164 posts) -

Well I found a workaround for now, if you change the User Agent for the 'Desktop IE' you can get it working. Go into the Developer Tools menu and in the window that pops up, go to Tools - Change User Agent String and select Apple Safari (iPad). Controls will work and it will also render all the things that were missing.

#15 Edited by LucidDreams117 (375 posts) -

@fleabeard Fantastic! Thanks so much for the tip. That really works. Bit of a pain to set it every time but I'm still happy. :)

#16 Posted by alexisg (379 posts) -

I think I posted this somewhere else but we are aware of surface troubles. It's a little odd since we are using the surface bultin video tag player. Looking into it though.

Staff
#17 Posted by fleabeard (164 posts) -

Wonderful to hear @alexisg thanks for letting us know. And thanks for all the hard work you guys are doing.

#19 Posted by LucidDreams117 (375 posts) -

@alexisg thanks for the update. Appreciate all the work you guys are putting into the site. Know it hasn't been the easiest.

#20 Edited by Moth_Pope (450 posts) -

@fleabeard: That's great, thanks! A nice easy work around until the official fix.

@alexisg: Thanks for letting us know. Like others have said, really appreciate the hard work you guys are doing to get this running smoothly.

#21 Posted by Bollard (5203 posts) -
#22 Posted by Moth_Pope (450 posts) -

Don't know about anyone else, but most of these issues generally seem fixed now. I can use all the video controls and avatar images are showing up in posts. Thanks, guys! Good work. Only issue still left is the ability to @ reply people and use other forum codes, but for me that's not too big a deal.

#23 Edited by Bollard (5203 posts) -

@moth_pope: :O That's cool! Haven't seen the site on my Surface in a while, will check it out soon. And that's weird about the replying thing, considering it works on mobile. You sure it still doesn't work?

#24 Edited by Moth_Pope (450 posts) -

@chavtheworld: Yeah it's really cool! So nice just to be able to go full-screen and use the time line to skip back and forth. :D After playing around, the forum tools in the reply box definitely do not work, however I have managed to get the Reply, Quote, Flag and Best Answer buttons to (sort of) work. It's not great though, as basically the buttons still remain hidden as they did before. If you hold your finger down on a post they'll pop up but they disappear very shortly after you take your finger off. If you're quick you can press one of the buttons before it goes but even then it doesn't always work. I managed to quote you for this post but it took some doing.

#25 Posted by Bollard (5203 posts) -

@moth_pope: Does it work if you're using the touch keyboard? I would assume you just need to hover over them to make them appear, kinda like they do on the full site.

#26 Posted by Moth_Pope (450 posts) -

@chavtheworld: Ah yes, I can confirm it works perfectly with the touch keyboard.