#1 Posted by Obinice (275 posts) -

First off, I know this issue is almost certainly being worked on. Dave posted:

Getting the API up and running, this will also fix any problems you're having with your Roku / Boxee device.

today, and I know that Roku and Boxees are media center setups and probably access the API in the same manner as XBMC. I didn't see XBMC mentioned however, and XBMC is the only way I take Giant Bomb videos in (nothing better than coming home from work, sitting down with my dinner, and firing up today's Quick Looks). I even bought a subscription so I could watch all the awesome subscriber stuff, and get everything in glorious HD!

Anyway, the app still works almost fully, except that the account linking is currently broken, so no HD or premium content. I linked my account up, it threw a couple of errors, and now it seems linked, but no premium content. I'm sure it will be fixed along with the rest of the API stuff, but I just wanted to make a thread you know....in case anybody forgot about XBMC :)

P.S Since the last big update of the app when GB was bought out, there's no "All Videos" tab any more, so I can't browse back through the archives, I have to do a manual search for anything more than a couple of months old. Kinda sucks, sometimes I want to go back and watch an old show or Quick Look, but I don't have anything particular in mind, or can't remember what I'm looking for!

P.P.S The new site is freakin' awesome :D My congratulations to the team. You deserve a year's paid holiday :P

#2 Edited by Dunkelheit (46 posts) -

+1!!!!!! I just started using XBMC and loving it. I really hope to watch giantbomb through it.

Obinice, which addon are you using? I was using one from the official repo which didn't work. Are you using a different one?

#3 Posted by Obinice (275 posts) -

+1!!!!!! I just started using XBMC and loving it. I really hope to watch giantbomb through it.

Obinice, which addon are you using? I was using one from the official repo which didn't work. Are you using a different one?

I'm also using the official repo addon, which (as of yesterday when I last checked) is completely broken at the moment. I can't wait for it to be working again, having everything in XBMC at the touch of a remote is great! (Giant Bomb, Tested iPlayer, Movies, TV Shows, Live TV, Music, Photo Albums), it's the future.

WE LIVE IN THE FUTURE.

#4 Edited by GnolTac (123 posts) -

The XBMC GiantBomb plugin is actually really easy to fix yourself on your machine. Just open default.py in the plugin directory in a text editor and change the

API_PATH = 'http://api.giantbomb.com'

to

API_PATH = 'http://www.giantbomb.com/api'

Save, open XBMC, open the plugin and tadaaah. The plugin directory will most likely be in your userdata folder and then something like %userdata%/XBMC/addons/plugin.video.giantbomb. The location of the userdata folder on your OS can be found at this link. Let me know if you run into any issues!

#5 Edited by Dimmuxx (14 posts) -

It works now again and it seems the speed is great again so that I can use it instead of the youtube plugin.

Edit: Still seems to be some buffering problems, but at least it's better than before.

#6 Posted by Dunkelheit (46 posts) -

Thanks GnolTac!! I'll try that when I get a chance.

#7 Posted by Obinice (275 posts) -
@dimmuxx said:

Edit: Still seems to be some buffering problems, but at least it's better than before.

Whoop! Working great! Time to catch up :D

P.S I've never had buffering problems in HD (ISP: Virgin Media 60 meg, Location: Manchester, UK), hope yours improve :]

#8 Edited by Dunkelheit (46 posts) -

It's working great now. Looks great too. Just started but haven't noticed any buffer issues.

By the way, the site update looks FANTASTIC!!!!!

#9 Posted by Dimmuxx (14 posts) -

Was working fine for a couple of hours tonight but now it's buffering all the time again. 100mbit/s in Sweden connection.

#10 Posted by mrpibb (467 posts) -

@dimmuxx: can you take a look at this thread and then pm your details? I'm actively working w/ akamai to see if there are things we can do.

#11 Posted by Dimmuxx (14 posts) -

I watched some videos today and the buffering problem still happens a lot.

#13 Edited by arbayer2 (15 posts) -

Glad to hear there's some sort of fix at the moment, thanks, GnolTac! Now, Obinice, what did you have to do to link your account to the addon? I never quite got access to giantbomb.com/boxee or /xbmc to find my link code like others suggested because all I'd receive was a 500 error. Did you ever encounter that?

EDIT: Oh jeez, just noticed the sheer deadness of this thread, my apologies. Feel free to delete if necessary, mods.