#1 Posted by TimesHero (664 posts) -

I can't even launch it. I've tried redownloading it. I tried removing GFWL, and noting is working. Any ideas?

Online
#2 Edited by JJBSterling (167 posts) -

DSFix?

#3 Posted by Sterling (2078 posts) -

Do you have a 360 controller plugged in while trying to boot the game? If so try unplugging it. Also try manually running these two files:

  • ...\Steam\steamapps\common\Dark Souls Prepare to Die Edition\REDIST\DirectX\DXSETUP.exe
  • ...\Steam\steamapps\common\Dark Souls Prepare to Die Edition\REDIST\GFWL\gfwlivesetup.exe

After doing so, reboot the computer.

#4 Edited by Huey2k2 (486 posts) -

Works just fine for me with DSFix.

When you say you tried removing GFWL what exactly do you mean?

#5 Edited by Zidd (1838 posts) -

If you're using DSfix did you disable the in game anti-aliasing before you applied DSfix?

#6 Edited by ModernAlkemie (358 posts) -

Have you tried deleting the "appcache" folder in the Steam directory and then restarting Steam? That usually works for me when a game fails to launch.

Also, did this issue only start after messing with GFWL? That sounds like it could cause some serious initialization errors.

#7 Posted by Budwyzer (544 posts) -

@zidd said:

Did you disable the in game anti-aliasing before you applied DSfix?

How is one supposed to disable this in-game if it never launches to begin with?

I have the same issue. Installed the game via Steam, launched it, it immediately crashes. Tried DSFix, made sure AA is off, it immediately crashes.

Mine looks like it may be linked to GFWL as when I launch the marketplace it tells me that I need to have the Sign-in Assistant for Win7. Yet when I attempt to install the assistant it tells me that it cannot finish and closes...

MS is making the right move by closing those doors, because GFWL is nothing but fail.

#8 Edited by Driadon (2995 posts) -

If you have any GFWL issues, attempt to remove everything related to GFWL, including both the marketplace, the redistributable, and everything Silverlight. Once that is done, restart the PC and reinstall it all.

#9 Edited by Pie (7055 posts) -
#10 Posted by theodacourt (520 posts) -

Make sure you have the newest version of dsfix. I got the one from the steam forums and it was out of date, but getting the latest one fixed it. I got the same messages and it really annoyed me for a few days!

#11 Posted by Korwin (2829 posts) -
#12 Edited by ElixirBronze (417 posts) -

I had this problem when I had accidentally enabled Anti Aliasing while using DSfix. I had to delete DSfix, go into the game and disable AA, reinstall DSfix and then it worked.

#13 Posted by Brad (2875 posts) -
Staff
#14 Posted by AlexW00d (6186 posts) -
#15 Posted by ajamafalous (11852 posts) -

@budwyzer said:

@zidd said:

Did you disable the in game anti-aliasing before you applied DSfix?

How is one supposed to disable this in-game if it never launches to begin with?

There's an .ini you can edit. About to leave for work so I can't look up where it is, but I'm sure google can find it for you.

#16 Posted by Scampbell (491 posts) -

I think the real answer is: Yes, yes it is.