#1 Edited by Funzzo (835 posts) -

So I just picked this up off steam for 5 bucks because I own the reg version and the DLC. The second it started I knew there was something wrong. The splash screens were stuttering and going very slow and you cant skip them. Once I made it to the menu the mouse was also stuttering and moving weird. Once I got into the game the voices in the cut scenes did not match up to the mouths of the characters. Everything just looks kinda shitty now. That's the only way I can explain it. Has anyone else out there been having problems like this.

#2 Edited by Poppduder (460 posts) -

I also had this problem. I dont have any solution, I just got pissed and uninstalled it. :( good luck. I was using a 6 core AMD processor and AMD 6890 video card if it helps any

#3 Posted by ThunderSlash (1652 posts) -

Wow, that sucks. I was about to pull the trigger on buying it too, since I have the discount bonus too. Thanks for the heads up.

#4 Edited by Claude (16255 posts) -

Played the original on the Xbox 360. Played fine. So sorry for the Master Race.

#5 Posted by Hailinel (24295 posts) -

Sounds like it hasn't been optimized for PCs yet. It wqs originally meant as a Wii U exclusive, so I wonder how the other console versions play.

#6 Edited by soulcake (263 posts) -

sounds like a driver issue try a new or a old driver.

#7 Posted by ArbitraryWater (11595 posts) -

Installing it now, let's see how this goes...

#8 Posted by Encephalon (1240 posts) -

I picked it up for 5 bucks too, but I haven't fired it up yet. Kind of dreading it now. We'll see.

#9 Posted by probablytuna (3604 posts) -

Does anyone know how big is the download for those who already own the base game and the DLC?

#10 Edited by Encephalon (1240 posts) -

@probablytuna said:

Does anyone know how big is the download for those who already own the base game and the DLC?

Sadly, it doesn't just plug into your old game. It's a whole 'nother thing. Like, 15 gigs.

I assume it's just for simplicity's sake. Having a DLC upgrade for the base game while also selling a full enhanced game, I imagine, might lead to marketplace confusion. They also seem to have taken down the vanilla game, presumably meaning the Director's Cut to replace it.

#11 Posted by probablytuna (3604 posts) -

@probablytuna said:

Does anyone know how big is the download for those who already own the base game and the DLC?

Sadly, it doesn't just plug into your old game. It's a whole 'nother thing. Like, 15 gigs.

I guess that makes sense... But god damn on my internet connection it'll take more than a week to download. Screw it, I'll just skip it for now.

#12 Posted by Funzzo (835 posts) -

Open regedit

Click on HKEY_CURRENT_USER

Click on software

Click on Eidos

Click on Deus Ex:HRDC

The third line down should be D3D11_CREATE_DEVICE_PREVENT_INTERNAL_THREADING_OPTIMIZATIONS

Double click on this and change the value from 0 to 1. This made things better but not as good as the original version of the game.

#13 Edited by Colourful_Hippie (4337 posts) -

Sounds like a shit port

#14 Edited by mak_wikus (514 posts) -

Weird, considering what a bang up job Nixxes did on the PC port of the original game. Did they made the Director's Cut thing? Or is it someone else?

#15 Posted by Kidavenger (3528 posts) -

Try verifying the install in Steam; I downloaded and played Remember Me this week it wasn't running very well and it was pissing me off, I verified the install and one of the files was damaged, after it fixed that, the game ran flawlessly.

It's really hard to believe that they took an existing PC game that had no issues and broke it so badly making changes to the boss fights and incorporating the existing DLC.

#16 Posted by SongWriter1987 (123 posts) -

@thunderslash: I'm getting between 100 and 150 FPS on max at all times.

#17 Posted by JasonR86 (9653 posts) -
#18 Posted by Veektarius (4750 posts) -
#19 Posted by bhlaab (143 posts) -

It seems fine to me. Might be an issue with AMD, I have an nvidia. Those sorts of things tend to be fixed relatively quickly.

Also just try rebooting, maybe you have a background process eating up your cpu.

#20 Posted by Humanity (9028 posts) -

Sounds like a shit port

Yah but the original ran fine on PC. Did they completely overhaul the graphics or something? I was under the impression it's just the main game and DLC rolled into one with some minor tweaks?

#21 Edited by JoeyRavn (4963 posts) -

@claude said:

Played the original on the Xbox 360. Played fine. So sorry for the Master Race.

Yeah, it's so cinematic.

I'll take my chances with the PC version, thank you.

#22 Posted by SongWriter1987 (123 posts) -
#23 Posted by SASnake (324 posts) -

@claude said:

Played the original on the Xbox 360. Played fine. So sorry for the Master Race.

The original plays fine on the PC too...so...whats ya point?

#24 Posted by Pie (7073 posts) -

@humanity said:

@colourful_hippie said:

Sounds like a shit port

Yah but the original ran fine on PC. Did they completely overhaul the graphics or something? I was under the impression it's just the main game and DLC rolled into one with some minor tweaks?

I think I read that they made the graphical improvements from the DLC game wide

#25 Posted by JasonR86 (9653 posts) -
#26 Posted by Colourful_Hippie (4337 posts) -

@joeyravn said:

@claude said:

Played the original on the Xbox 360. Played fine. So sorry for the Master Race.

Yeah, it's so cinematic.

I'll take my chances with the PC version, thank you.

I'm going to start calling all sub-30 frame games as cinematic from now on

#27 Edited by HatKing (5876 posts) -

I wonder if the console versions are fucked? Sounds like the WiiU one is fine, but I think this is also being rereleased on 360/PS3.

#28 Edited by CrusNR (19 posts) -

The game runs the same as the original for me. I get anywhere from 70-90 fps, but it mostly sticks to 82-83 and that's with max settings at 1440p.

My gpu is a 680 for anyone curious.

#29 Posted by Snail (8593 posts) -

CAN'T WE ALL JUST GET ALONG

#30 Posted by Korwin (2839 posts) -

I remember there being a driver bug on my 5870's at the time with the original release that made the game run like crap, probably something similar here.

#31 Posted by falserelic (5399 posts) -

That sucks...

Since I've already played the original version of Human Revolution. I got no need to go out and buy the directors cut.

#32 Edited by Slaegar (698 posts) -

I think they did a very good job with the port. It was optimized well too. I ran the game on higher settings with just a single 9800 GT after I melted my 460.

The interface was also done nicely compared to the awkward gamepad controls. My only beef was you would use consumables if you scrolled through them on your hotbar. I just filled half the keys with booze and RP'd Jensen was an alcoholic.

Do you have your computer specs available? Sometimes people have like a GTS 540M and can't figure out why things are struggling.

Drivers aren't a bad thing to check for either. I remember people saying Dead Island was broken on the PC and it was on mine too. Until I updated the drivers and it ran awesome. It went from less than 10 fps on low settings to 70+ on max on an aging computer.

edit: This was on the old version to be clear. So they new one might look like Crysis 3 or something and hate all computers (especially if you're (didn't catch this until an hour later bah) like Brad and turn down all the effects and textures, then turn the most demanding AA all the way up and wonder why it runs poorly since AA is "basically free now")

#33 Posted by super2j (1666 posts) -

@poppduder: I already couldn't play the game because it would crash at that conversation with the hooker everytime i picked the left (or x button) dialog. I could not find a solution. I wondered if this would solve the problem but I really rather not pay more money for a game that already didnt work... and is now worse.

#34 Posted by SonicBoyster (348 posts) -

I have a better framerate than in the original with only an occasional stutter as it loads in new textures. Looks better too.

#35 Posted by insanekoz (1 posts) -

Do what Funnzo suggests in regedit!!

(hit Windows key + R and type regedit in the prompt to get to regedit).

This boosted my framerate from a stuttering 32-38 frames per second to a solid, locked 60 frames per second. It takes 30 seconds and fixes everything.

#36 Posted by The_Nubster (2090 posts) -

I'm running it on a Radeon 7870 with everything cranked up and I'm having no issues. What are your specs? The AI from the DLC is being used and the entire lighting engine has been overhauled and there are a lot of small improvements, so it's definitely more taxing than the original game.

#37 Posted by ArbitraryWater (11595 posts) -

It runs totally fine on my computer, no worse than the original version in any case.

#38 Posted by boogyhouser (1 posts) -

I'm having the same issue. The game runs like crap. Changing the resolution / graphics settings has no effect good or bad. I've also told steam and the game itself to use my Gpu...

Btw the original ran at 100fps or better with everything turn up to max

Running a 780 gtxm 4g

Haswell quad score

24 gigs of ram

It definitely ain't the system.

Hope they fix this soon

#39 Edited by Winterstrike (61 posts) -

@claude said:

Played the original on the Xbox 360. Played fine. So sorry for the Master Race.

This isn't System Wars, so stop any attempt to start a flame war. Thanks.

@sasnake said:

@claude said:

Played the original on the Xbox 360. Played fine. So sorry for the Master Race.

The original plays fine on the PC too...so...whats ya point?

He's just trying to troll but he has just failed.

#40 Posted by zenmastah (888 posts) -

Had to do the registry fix to fix the stuttering, other than that its running great.
As to how they changed the overall looks of the game im not sure which i prefer yet..

#41 Posted by Creamypies (4059 posts) -

Runs like garbage on the PS3 too.

#42 Posted by buft (3315 posts) -

@funzzo: @poppduder: hey guys, this was actually an issue with the original deus ex on steam as well , eventually it got fixed but i was able to fix my issue with a program called Orochi CEG which optimises the bulldozer processors for CEG games, i have an fx 6100 and a hd 6870. perhaps this will help you too considering your issue is similar to mine in the original.

this fix also works for saints row 3, the total war series and space marine.

#43 Posted by crazyleaves (644 posts) -

Runs awesome here, better than the OG. AM Phenom Black II, HD 6870. 8g DDR2.

#44 Edited by UlquiorraSchiffer (61 posts) -

@winterstrike: Trolls need to do their research for maximum effectiveness. It's sad to see when someone does shoddy work because they're too lazy to do their homework. That's the kind of thing that will get you blacklisted with the alliance to boot.

#45 Posted by Nictel (2402 posts) -

I'm having the same issue. The game runs like crap. Changing the resolution / graphics settings has no effect good or bad. I've also told steam and the game itself to use my Gpu...

Btw the original ran at 100fps or better with everything turn up to max

Running a 780 gtxm 4g

Haswell quad score

24 gigs of ram

It definitely ain't the system.

Hope they fix this soon

Runs awesome here, better than the OG. AM Phenom Black II, HD 6870. 8g DDR2.

So it's not the hardware? Maybe it is an 32/64 bit issue? Or a I have X files on an other disk than C:?

Online
#46 Posted by Shaanyboi (1282 posts) -

@hatking said:

I wonder if the console versions are fucked? Sounds like the WiiU one is fine, but I think this is also being rereleased on 360/PS3.

WiiU was the main SKU being done by Straight Right, but then when the console wasn't selling, the port jobs for the 360/PS3/PC were done by ANOTHER developer. The WiiU version largely runs alright and is generally pretty great. The other versions are kinda fucked.