#1 Posted by jclane (326 posts) -

I've been on reddit, steam forums, other random tech support forums and have sent an e-mail to Rockstar personally, yet I still find myself £10 out of pocket with a version of Grand Theft Auto San Andreas that just flat out refuses to launch. To keep it short, a window keeps popping up that claims "Cannot find 800x600x32 video mode". Here are my system specs:

  • Graphics card: Nvidia GT 640
  • Intel i7-3770 CPU quad-processor @ 3.40GHz
  • RAM: 12GB
  • OS: Windows 7 Premium 64-bit
  • Running via HD tv through HDMI port

The consensus from scouting the internet was that this would pop up if the person's system was incapable of running the game, which is just not true in my case. I also have Vice City through Steam and that generally runs smoothly (mouse detection issues here and there), but San Andreas just will not start.

Solutions I've tried include downgrading the 3.0v that comes with Steam to the 1.0/1.01v that supposedly supports 1080/720p, but that yielded no success. I also tried running the game with compatibility mode on older operating systems, which generally leads to the error of the game thinking it is already running (I have yet to get the game to boot successfully and upon inspecting the task manager, I can clearly see that the game is not running). The latest thing I tried was downloading somebody else's user file settings for the game, but that ended up the same as step one.

Quite frankly, I am stumped. I may have just wasted money on a product that simply will not work. I'd appreciate any suggestions on where to go next, duders.

#2 Posted by captain_clayman (3300 posts) -

Not exactly sure what you should do, but perhaps your computer is trying to run the game using integrated graphics instead of your GPU? I know that i7 has built in graphics, so just make sure the game is running on the GT 640 instead.

#3 Posted by jclane (326 posts) -

@captain_clayman: How can I check to see it's running off the right graphics. Could I check to see if the i7's graphics are turned off somewhere?

#4 Edited by Phyrlord (171 posts) -

Hey man, It doesn't sound like a graphics card issue. I would put money down on a 64bit W7 issue. Try finding the EXE that San Andreas runs with and go into the compatibility tab and check the boxes That say "Disable Visual themes /Disable Desktop Comp/Disable Display scaling".

I have to do the same thing for Fallout 3 or it crashes every 15-20mins.

#5 Posted by AlexW00d (6058 posts) -

@jclane: I really doubt it's anything to do with that, but it'll be running on intel hd4000 (I think that's the new version) if you plugged your hdmi into the motherboard back panel instead of the GPU. Also out of curiosity, that's a pre-built machine right?

#6 Posted by jclane (326 posts) -

@AlexW00d: Yeah, it's pre-built, which much to my chagrin, hasn't been serving me too well in hindsight.

#7 Posted by jclane (326 posts) -

@Phyrlord: I think I've already tried that a couple of times and it started causing a different error in which the game thought it was already open. A friend suggested I go to the in-steam settings and set the boot-up to be -window, which seemed to have done something, and by something I mean, no more error messages, but the game is indefinitely not starting up.

#8 Edited by WilltheMagicAsian (1543 posts) -

Since it's running through HDMI, it probably doesn't have all the standard PC resolutions set up. Right click your desktop, click NVIDIA control panel, click Change resolution, click customize at the bottom, then click create custom resolution and try creating 800x600.

Edit: Ah, didn't know that it didn't work in windowed mode either.

#9 Posted by Chaser324 (5954 posts) -

@WilltheMagicAsian: I actually think that might be worth trying though. A quick Google makes it look like there are actually quite a few complaints about GTA:SA only supporting a very limited set of resolutions and not working on nontraditional PC resolutions (things like 1024x576).

Moderator
#10 Posted by jclane (326 posts) -

@Chaser324: Wow, it actually worked! I made a custom resolution at 800x600 at 32-bit which is basically what the game was asking for and it runs! Thanks guys!