#1 Posted by MilkyJoe (2 posts) -

i just went on my email today after seeing the Giant bomb site for the first time and was greeted by this :D
Everysingle one is from Giant Bomb thats 299 messages, for some reason it felt the need to notifiy me every time someone posted a comment on the update?

caption
#2 Posted by LouChou (458 posts) -

Yeah, notification settings are a bitch. Fortunately I disabled them upon registration.

#3 Posted by MB (12915 posts) -

Same here....I'm sure stuff like this isn't helping the server run well.

Moderator
#4 Posted by AtomicEdge (310 posts) -

Yeah I have community off and wiki alerts on. Seems to be pretty good.

#5 Posted by Termite (2398 posts) -

Darn, I didn't turn them off.

*Sigh*

#6 Posted by phatkav (304 posts) -

Crap. I thought these things are off in default. Damn it.

#7 Posted by mgsninja (26 posts) -

That sure was a spam surpise.

#8 Posted by Flexiable (98 posts) -

I think mine were off by default anyway. I did notice that they've had to post all their content again...Reader told me so. The servers seem nice and fast now anyway (relatively).

#9 Posted by LouChou (458 posts) -
Flexiable said:
"I think mine were off by default anyway. I did notice that they've had to post all their content again...Reader told me so. The servers seem nice and fast now anyway (relatively).
"
Indeed. Obviously people are starting to latch onto the fact that their inboxes are being physically abused by GB.
#10 Posted by banksrob (1126 posts) -

just sitch them off

#11 Posted by Nobility (295 posts) -

Hope that setting reverts to unchecked for new users once the site launches, first time I ever got 200 emails in one day.

#12 Posted by Major (506 posts) -

I had that happen to me too... commented on the "Welcome Back" post as soon as I registered then went to bed.

#13 Posted by banksrob (1126 posts) -

luckily for me they went into my spam inbox