#1 Edited by SaFt (383 posts) -

So i ran into this problem with my copy of Illusion of time. I played it a year or two ago without problem and haven't touched it since.

The graphics are all messed up, parts of sprites and the backgrounds are all jumbled together all over the screen. Also when in the inventory all the items are also messed up, but exiting and re-entering the menu a couple of times fixes this for some reason.

Of all the games i tried this is the only game that has this problem. And it's just in certain parts. All the interior areas of the incan temple is fine, but the cliffside with the big faces are all messed up, so are all the towns and interiors of the houses.

I tried cleaning the cartridge with some rubbing alcohol but it didn't help. Any idea of what could be the problem and if it's fixable?

#2 Edited by Video_Game_King (36272 posts) -

Don't you get it, man? These are Gaia's illusions! FIGHT AGAINST THEM, MY BROTHER!

#3 Posted by joey (984 posts) -

blow on it

#4 Posted by SaFt (383 posts) -
#5 Edited by Arabes (338 posts) -
@joey said:

blow on it

What he said

#6 Edited by SaFt (383 posts) -

@arabes: Doesn't work, tried blowing it, tried cleaning it with rubbing alcohol twice and i also tried rubbing it with an eraser gum as i had heard it would remove whatever grime was on the connectors.

But it still doesn't work, it's not a battery problem because all my saves are still there when i boot it up. It's probably just busted and i can't do anything about it.

#7 Edited by Nightriff (5079 posts) -

@saft: Try a mix of 50/50 rubbing alcohol and water and clean it well. I'm no expert but a few months ago I did this on NES, SNES and N64 games that I was worried I would have to rebuy (Mario Kart 64 was my biggest fear, rebuying would be like $30!). Anyways they all worked instantly after I did that, could be only temporary for all I know but it worked

#8 Posted by Ravenlight (8040 posts) -

The connectors on your SNES might be the problem if the cart is clean. I found this advice on the Nintendo Age forums: http://www.nintendoage.com/forum/messageview.cfm?catid=8&threadid=26299

My fast cheap solution for dirty connectors on a SNES is to take a piece of cardboard and cut it to fit the cart slot, then insert the cardboard like a game several times. Sometimes with thin cardboard you will need to double it up. I try to make the cardboard only slighty thicker then a SNES cart. It also works for dirty toploaders.. I know it sounds crazy, but it really works.

Maybe give that a shot.

#9 Edited by bobafettjm (1487 posts) -

It very well could be the connectors on the SNES. Do you have this problem with any other games? I remember having an SNES that I would have to push the carts back slightly while they were seated in until I took it apart and fixed the connections.

#10 Edited by theuselessgod (318 posts) -

Two things I'd try:

I prefer Windex over alcohol to clean it with q-tips. If the connectors have been rubbed off too far, though, you might be boned.

It could very well be the SNES. While the cardboard trick is handy, I prefer to use a combination of canned air and a credit card wrapped in a cloth. You can slightly dampen the cloth if you want with windex, but it works dry. The CC and cloth (if it's a thin enough cloth) should fit perfectly in the SNES. Just stick it in a few times and it should clean stuff off a bit.

I have this same problem with my Gradius III cart and doing those two things fixed it. If not, it could be that the pins are too far gone on the game and you're just SOL. :(

#11 Edited by SaFt (383 posts) -

@nightriff: @ravenlight: @bobafettjm: @theuselessgod: I played some Secret of mana and Legend of the mystical Ninja yesterday and both worked just fine. It can't hurt to try these things though, thanks for the tip.

EDIT: Yeah no luck with that either. It's probably just straight up broken. Thanks for the help.