#1 Posted by ShadowDoGG (134 posts) -

I know its in beta but for me atleast it is exceptionally slow and its not like there loads of flahs either its just javascript/php/html

#2 Posted by theNoss (14 posts) -

Yeah it is a little slow.

I'm sure they're working on it though. Give em' timeeee

#3 Posted by Mordok44 (173 posts) -

Its the first day of launch. It will get a lot quicker in time :)

#4 Posted by Lairdo (543 posts) -

Its running pretty quick for me actually : /

#5 Posted by Oriental_Jams (3063 posts) -

It is slow, but that was to be expected.

#6 Posted by Pikachu (449 posts) -

its slow but nothing to complain about, i mean they did just start this forum thing today.

#7 Posted by Xero (159 posts) -

not too slow, still usable

#8 Posted by Toseph (370 posts) -

It fairly slow but what do you expect for the first day of a beta

#9 Posted by Termite (2398 posts) -

It was slow earlier, but now it's sped up

All of those people trying to sign up really put on the server load madness

#10 Posted by Creciente (82 posts) -

I had a very little slowdown while logging in once, but other than that, the site is very quick.

#11 Posted by Atlas (2436 posts) -

It's been very slow at times, and has just stopped like 4 times, but recently it's been one extremely smoothly.

#12 Posted by IndieBoy (109 posts) -

Soooo slow =(

#13 Posted by Randolph (374 posts) -

Giant Bomb, right now, is getting mugged by the internet, literally.  It could be a rough few days, and it's going to get worse as the day goes on and more people realize it's up and open.  Don't be shocked to see forum downtime, maybe even site downtime.  This is an open beta, it's sort of a "fix on fail" kind of thing.

#14 Posted by RowdyRob (206 posts) -

Yup. But that's to be expected. Give it time.

#15 Posted by suneku (2997 posts) -

It fluctuates for me... sometimes it's going nicely and sometimes it lags like crazy... same as their other site comicvine.

#16 Posted by tsduv21 (23 posts) -

It isn't very slow for me. Average I guess.

#17 Posted by sizu (391 posts) -

Its a good sign that the server is busy day one:)  Means the community will grow.

#18 Posted by Hulk (428 posts) -

Hulk lag puny site out with strong posting.

#19 Posted by banksrob (1126 posts) -

yea lol slow page loading but it will get better, we just need to give it time

#20 Posted by BoG (5187 posts) -

I'd imagine we're bombing the servers with so many people on at once, with a site that is fresh and can't handle it.
Hey, at least it is holding up better then the Metal Gear online servers.

#21 Posted by trebert (45 posts) -

Yeah its to be expected from day 1 every new server of absolutely anything has lag or other issues on day 1 though the sites still usable.

#22 Posted by selfconfessedcynic (2506 posts) -

Oh - metal gear online rears it's ugly head once more.

Yeah, couldn't get a single page load a couple of hours ago - but now it's fine, oddly enough.

#23 Posted by Raspberry (63 posts) -

I'm just happy they decided to make a site together and please the fans :P

#24 Posted by HomoPocket (47 posts) -

It's a bit sluggish, but I'm also on a sluggish computer. Besides, it's the forum's maiden voyage, so that's to be expected. They'll work out the kinks in no time.

#25 Posted by General (54 posts) -

Yea, hopefully it is because the server is packed and not because my computer sucks.

#26 Posted by Vecta (167 posts) -

Large influx of people = slowdown.

#27 Posted by Lairdo (543 posts) -

Now its slow and the site keeps crashing.

#28 Posted by blizzvalve (128 posts) -

It's running slow to me. It's either the site or my internet connection is going bad

#29 Posted by Rianor (94 posts) -

Yeah, periodically, since it launched last night, i've had sporadic loading, sometimes it takes quite awhile, and then it just loads fine. I'm sure it has to do with all of the heavy traffic of everyone signing up and using the site right now.

#30 Posted by SSbabel (1141 posts) -

It is a bit slow, but seeing that it has recently just launched and there have been a lot of people flocking to signup and explore the site u gotta expect the website to have a lil trouble.

#31 Posted by claysol13 (65 posts) -

Well ya gotta figure a ton of people are uploading images/info/visiting the site.  Its putting a strain on the server load for sure.

#32 Posted by xplodedd (1316 posts) -

it was bad before, doing better now.

#33 Posted by predator (350 posts) -

Running very slow to me as well, it's expected though.

#34 Posted by doublefafa (8 posts) -

It is moving rediculasly(i don't think i spelled that right) slow for me. It is going so slow where as i can't even edit my profile because it'll just take to damn long.

#35 Posted by GhettoMechanic (2 posts) -

All The people want too go on the greatest site in the world @ one time, thus the reason for the slowness, it will pick up later

#36 Posted by DanCarmichael (220 posts) -

A bit slow yeah, especially  trying to get to the homepage. Some areas like the forum work fine for me though.

#37 Posted by Azel (4 posts) -
Randolph said:
"Giant Bomb, right now, is getting mugged by the internet, literally.  It could be a rough few days, and it's going to get worse as the day goes on and more people realize it's up and open.  Don't be shocked to see forum downtime, maybe even site downtime.  This is an open beta, it's sort of a "fix on fail" kind of thing.
"

This is what I figured, but my slow connection and on its last legs PC don't help I bet! :P
#38 Posted by Joru (311 posts) -

Sometimes it speeds up and sometimes pages don't even load up properly for me, I guess it's just launch problems and the fact that I live in Europe but it never really became unusable.

#39 Posted by iGaboru (215 posts) -

If only it ran as smoothly as in Jeff's site tour! 

#40 Posted by pwilletts (19 posts) -

Running slow for me but maybe thats cause I'm using all my bandwith to download Opposing Fronts from Steam.

#41 Posted by Guffman (21 posts) -

im finding some of the pages and videos are alittle slow but nothing a page refresh doesn't fix

#42 Posted by Roybot (34 posts) -
ShadowDoGG said:
"I know its in beta but for me atleast it is exceptionally slow and its not like there loads of flahs either its just javascript/php/html
"
Just try to imagine the complexity of the database they are using. Every process there database server have to do will take time. And right now EVERYBODY wants to edit there profile, upload images and try the site. I am sure the servers are under heavy pressure but that will eventually not be the case.



But anyway, the site is hosted on Godaddy.com (US) and I wonder if Giant Bomb will consider putting up a mirror server in another region. That would come in handy.
#43 Posted by hyperslug (181 posts) -

It feels kinda slow yeah... especially when there is so much too see :D

#44 Posted by Disgaeamad (1342 posts) -

You have to remember the amount of trafic as well. There's probably a crapload of pages being loaded each second, so that'll affect the speed of the site as a whole.

#45 Posted by ShadowDoGG (134 posts) -

I just think its on a poor network.

It wasn't on the best of bandwidth before but now since there is a lot more content it is a bit beyond a joke

#46 Posted by Manks (836 posts) -

It's running a bit faster compared to 3 hours ago. 

#47 Posted by RozzleDozzle (23 posts) -

Yeah, it's slow for everyone. Their servers are getting SLAMMED, hardcore style. Think about it, almost everyone who comes here today is doing more than just looking at the site. Almost every visitor is signing up, editing wiki, posting their firsts blogs/reviews, etc. It would be hard for any server to keep up with all this traffic.