#1 Edited by AlisterCat (5480 posts) -

Update: Solved. Thanks!

My Dragon Age Origins character is broken. I do zero melee damage. I have researched the problem and the issue seems to be a value being rounded to a negative due to a glitch in how the damage is calculated. It is known as NaN (not a number) where the value is rounded as such that it is not a valid number. The fix should be simple, just resetting the value in the save game using the dragon age toolset. I cannot edit the file, however, as the toolset is memory hungry and my 8GB will not suffice.

I am looking for a helper, willing to open my save using the toolset. You need a 64bit OS and at least 16GB of RAM. No guarantees that will be enough but at this point I'm stuck. I will provide instructions so you don't have to know the toolset.

It sucks because I got all the way to the expansion and have ended up with a main character that cannot do any damage, making it very difficult to progress. Researching the cause of the glitch has been very interesting though.

Resources I have used:

http://dragonage.wikia.com/wiki/Save_game_editing

http://social.bioware.com/wiki/datoolset/index.php/Character_Save_Values

http://forum.bioware.com/topic/11727-nan/

Here is the directory, in a rar file: https://onedrive.live.com/redir?resid=A233E541646F74BC!549&authkey=!AMURJ68H5QOoVEI&ithint=file%2c.rar

Instructions:

  • Open the toolset.
    Click File > Open File and navigate to Saves > Slot_5 > VigilsKeep.das
  • Click the plus icons as follows:
    SAVEGAME_PLAYERCHAR -> SAVEGAME_PLAYERCHAR_CHAR -> SAVEGAME_CREATURE_STATS -> SAVEGAME_STATLIST
  • Click the plus symbols from 0 to 9 to expand the view.
  • Look in the value column for any negative numbers, or any containing letters. Set them to 0 if so.
    For example:

    SAVEGAME_STATPROPERTY_BASE = 40
    SAVEGAME_STATPROPERTY_MODIFIER = -1.09E-06
    SAVEGAME_STATPROPERTY_INDEX = 10

  • File > Save As then just save as it is and upload for me

Here is a screenshot of the values from a sample save. Replace with similar values found in the image if you can, but only for negative values.

#2 Posted by Edmundus (255 posts) -

I remember using the DA toolset last year to edit values, and I have 8gb ram. Since when did the toolset suck up that much memory?

#3 Posted by AlisterCat (5480 posts) -

@edmundus: The memory required seems to increase dramatically the bigger the save gets, from what I have read. I cannot open my 22MB save, or another of similar size, but I can open a 1MB save.

#4 Posted by crusader8463 (14413 posts) -

Just so happens I have a 64 bit OS and 16 GB of ram. I would be illing to help, but I have a super slow 1MB internet connection so I think it will take forever for me to download the DA editor. I will look into it and see what I can find. Maybe upload your save file in the OP so people can d/l it.

#5 Posted by crusader8463 (14413 posts) -

@alistercat: I'm downloading the editor but it will take an hour or so to complete. Let me know what value you need edited, what it needs to be edited to, and upload the save file and I will see what I can do.

#6 Posted by AlisterCat (5480 posts) -

@crusader8463: That would be amazing, thank you. I'm currently writing up some simple steps. I'll post soon.

#7 Edited by AlisterCat (5480 posts) -

@crusader8463: I have updated with the files, plus instructions. If you could take a look that would be great. Even better, if you do find what I am expecting if you could let me know what it is you see, maybe a screenshot.

#8 Posted by crusader8463 (14413 posts) -

@alistercat: Crap cakes. I just got the d/l finished but it requires the game to be installed too. That would take the better part of a day for me to download and I need my PC so I can't devote that kind of time. I could download it over night, but I gotta work tomorrow so it won't be done till tomorrow and I wouldn't be able to mess around with it till tomorrow night after work at the earliest.

So if someone else can jump on have at it, but otherwise that's the quickest I can get it to ya.

#9 Posted by AlisterCat (5480 posts) -

@crusader8463: I really appreciate the thought, and I don't want to inconvenience you further. If somebody else is able to come along and help that is great but no worries, thank you anyway.

#10 Posted by crusader8463 (14413 posts) -

@alistercat: No worries. I was looking over my steam list last night and was tempted to install DA:O again but I went with neverwinter nights 2 instead since I have never played it. DA:O is one of my favourite games of all time so any excuse to fire it up again is ok in my books. I just figured if there was someone around with a better internet connection they could get this done for ya lickty split and you didn't have to wait a couple days for my slow ass internet.

Plus I always wanted to mess around with the editor and learn how it works.

#11 Posted by AlisterCat (5480 posts) -

@crusader8463: Well, you can check some of the resources I posted if you want to use the editor. It's only save game editing, but it's a start. Plus the toolset Wiki has a lot of tutorials.

#12 Posted by AlisterCat (5480 posts) -

Anyone else interested in helping out? I'm sorry to ask like this but I don't have another solution. It may not even open with 16GB of RAM.

#13 Edited by Veektarius (4584 posts) -

If you haven't got a helper by tomorrow evening, PM me and I'll do my best to help. I won't be of any assistance before then however.

#14 Edited by AlisterCat (5480 posts) -

@veektarius: @alistercat: Thank you for the offers of help, no longer needed. Matt Pascual on the forums tried for me and 16GB wasn't enough. I posted on the bioware forums for help and have come up with a script solution I compiled in the toolset. It doesn't completely solve the issue but it is close.

Here is the script, incase someone stumbles upon this one day and needs help.

#include "2da_constants_h"

void main (){ SetCreatureProperty(GetHero(), PROPERTY_ATTRIBUTE_DAMAGE_BONUS, 0.0f, PROPERTY_VALUE_MODIFIER); SetCreatureProperty(GetHero(), PROPERTY_ATTRIBUTE_ATTACK_SPEED_MODIFIER, 0.0f); SetCreatureProperty(GetHero(), PROPERTY_ATTRIBUTE_ATTACK, 0.0f, PROPERTY_VALUE_MODIFIER); SetCreatureProperty(GetHero(), PROPERTY_ATTRIBUTE_ATTACK, 40.0f, PROPERTY_VALUE_BASE); SetCreatureProperty(GetHero(), PROPERTY_ATTRIBUTE_DAMAGE_SCALE, 1.0f);}

#15 Posted by crusader8463 (14413 posts) -

@alistercat: I tried searching around, and a few things I found in random old forum threads, but nothing seemed to work despite having 16 GB of ram. Wish ya luck finding help. I tried for an hour but nothing would load.