#1 Edited by Dexter_Morgan_ (314 posts) -

I have an iphone 4s that is jail broken (I purchased it that way) and after trying to update it, it got stuck in recovery mode. After hours of searching for a way to fix it to no avail, I decided to just restore it via Itunes. However after the iphone is about to be wiped an error message pops up that says "Error 21" and i'm back at square one with an iphone that is stuck in recovery mode and can't be restored "turned back to it's factory settings and erased completely).

I have searched countless google pages and have watched at least 20 youtube videos, but I cannot for the life of my iphone fix this problem.

I have downloaded tinyumbrella and clicked "exit recovery mode" which restarts my phone, but doesn't fix the problem. It just stays in recovery mode.

I am desperate... if anyone can help me fix my phone I swear to Mother Gaia herself that I will be forever in your debt. Please save the Titanic (my iphone). We have been through a lot together and I always imagined that her death would be because I dropped her and she shattered epically while I watched in horror. This is how iphones are suppose to die. NOT LIKE THIS! PLEASSEEEEEEEEE....

#2 Posted by Dexter_Morgan_ (314 posts) -

PS I like the new look GB. You be lookin fiiiiiiiiiiiiiiiiiiiiiiinnne.

#3 Posted by EXTomar (4453 posts) -

Hmm, I thought stuff like Error 21 were things like "can't validate image install" which it does by talking with Apple's servers and fetching keys. I would try going to another machine, installing iTunes and try plugging it and see what you get.

#4 Posted by Dexter_Morgan_ (314 posts) -

@extomar said:

Hmm, I thought stuff like Error 21 were things like "can't validate image install" which it does by talking with Apple's servers and fetching keys. I would try going to another machine, installing iTunes and try plugging it and see what you get.

Error 21 is usually a battery error, but it is also a jailbreak error that happens frequently (apparently).

I have tried on 3 different PCs already, but still end up with the same result. Thanks for the advice though!

#5 Posted by DriveupLife (909 posts) -
#6 Edited by Dexter_Morgan_ (314 posts) -

Ok I fixed it.

I'm going to list what I did in case this happens to someone someday and they need help and stumble upon this page because of Google or something because through the tens of forums I searched that were years old, not one person bothered to update their OP with how they fixed their problem and that is terrible and they should be punished.

Basically, my phone was bricked. Usually it is impossible to unbrick an iphone, but if it's stuck in the recovery mode cycle and you can't restore it because it's jail broken and no third party programs work for you such as tinyumbrella or redsn0w, there is some hope if you follow these steps.

1.) Download an IOS IPSW from Google. You will need to visit ipswdownload.com and enter what type of update you want as well what type of phone you have. I entered Iphone, 4s, and the firmware I chose was update 5.1.1 because the 6.0 updates were what got me into this mess in the first place.

2.) After you download the firmware into your computer open up iTunes and try to restore your iphone again, but this time hold shift before clicking restore. When doing so a pop up box of your downloaded files should pop up. Choose the IPSW you just downloaded and the restore process will begin. Since this is not a restore issue, but a bricking issue this won't work for you like it didn't for me the first time. Before the restore process is finished another error box will pop up only this time it will be error '3194'.

(CLOSE ITUNES AFTER THIS. VERY IMPORTANT)

3.) From this point open up your start menu and select 'computer' and then select your (C) drive. After this locate your 'windows' folder and open it, then locate your 'Systems32' folder and open that, then locate your 'drivers' folder and open that and then finally locate your 'etc' folder (which is usually at the top) and open that.

4.) Inside your 'etc' folder you find a file that says 'hosts'. Right click on it and copy it. Then right click at the bottom of the page and select paste. (This is a precautionary measure in case you screw something up.

5.) Now that you have a copy of 'hosts' in your 'etc' folder, drag the original 'hosts' file to your desktop.

6.) Minimize the 'etc' page and open up the 'hosts' folder that is now located on your desktop. It will ask you what program to open up the file in. Select 'Notepad'. After doing this Notepad will open with the text. Scroll all the way to the bottom and delete the line of text that says 74.208.10.249 gs.apple.com and NOTHING else. Click on the save tab and then close 'Notepad' after you have saved it.

7.) After you close the notepad program, reopen your 'etc' folder that you minimized earlier. Drag the 'hosts' folder that is on your desktop back to your 'etc' folder. Basically you're just redoing what you did at the beginning of step 6 by dragging the 'hosts' file back from your desktop to it's original place in 'etc'.

8.) Reopen up itunes and click restore.

Boom. You have just fixed your bricked iphone.

(I am also not responsible if something bad happens. This will only work if your phone was bricked but was still able to turn on to recovery mode. DO NOT do this if it's simply stuck in recovery mode, but can be restored. You will royally fuck up your iphone if you do this. This is for people who have no other options because restoring won't work and third party programs can't help (such as tinyumbrella and redsn0w).