#1 Posted by Fallen189 (5006 posts) -

Hey guys.

Had this problem for a while. I use a PC with a Samsung television as my main monitor. Simple enough right? Here's what I want to do:

-My TV headphone slot is bust, and I can't plug anything in anymore, however, I still want to use headphones for it because speakers are stupid. However, when I plug headphones into my PC audio jack, audio still comes from the TV, presumably because HDMI overwrites it.

What I'd like to know is if there is any way to make audio default to coming out of the PC audio, as opposed to the TV. Thanks

#2 Posted by TruthTellah (9033 posts) -

@fallen189: So, does audio come to both your headphones and the speakers of your TV or just the TV, avoiding the headphones altogether?

#3 Posted by I_Stay_Puft (3364 posts) -

Not sure if this is what you were asking for but If you're using windows if you right click the volume control icon in the notification area you should be able to see your playback devices. Right click the headphones icon and you should be able to set them up as your default listening device.

#4 Edited by Fallen189 (5006 posts) -

@i_stay_puft: @truthtellah: .

It just hits the TV, avoiding the PC jack alltogether.

I tried that, but it doesn't show the headpone icon. This is all I get

#5 Posted by Yesiamaduck (1069 posts) -

Go into start>control panel>hardware and sound>Device Manager

And make sure your computers audio device is enabled, if it's not there it may be damaged or the drivers have funked up.

#6 Edited by m4r71n2012 (49 posts) -

Are you using the headphone jack in the motherboard or one on the case? Might sound stupid but are the front panel ones plugged in to the motherboard ok, does the mic port work?

#7 Posted by TruthTellah (9033 posts) -

@fallen189: I've never had a PC refuse to output headphone audio just because a HDMI cord is connected. Are you able to use headphones to listen to things on the computer when the HDMI is not connected to a TV? This sounds like a potential driver/setup problem. Make sure everything is properly connected and it isn't just a computer problem completely separate from anything to do with HDMI.

#8 Posted by Fallen189 (5006 posts) -

@truthtellah: @m4r71n2012: @yesiamaduck:

All seems fine in device manager.

The front port works in that I plug headphones in and hear the "pop" sound that you typically get when it's being powered. I just don't know how to force audio out of it.

I also have no idea how to check how to use audio when there's no HDMI input. Is this something that i'm missing which is very simple?

#9 Edited by TruthTellah (9033 posts) -

@fallen189: Well, if you don't have a second, non-TV monitor to plug into for a test, I guess you could start a long song, disconnect the HDMI, and then plug in headphones to see if your PC outputs the audio to them.

Your monitor should have nothing to do with whether or not you can get sound from your headphones. If you have a normal monitor, connect it and then see if headphones work fine. If neither of these tests work, then it sounds more like an issue with the audio drivers or setup of your hardware than your TV.

(On that Sound menu you took a picture of, did you scroll down? Could a headphone icon be there? Were the headphones plugged in when you looked? Because even if audio isn't being output to headphones, there should be a headphone icon there which you can set as Default.)

#10 Edited by Fallen189 (5006 posts) -

@truthtellah:

Scrolling down just showed another of the same thing. I've plugged them into both front and back jacks and neither detect anything at all. It's extremely frustrating, as there's seemingly no way to make this work at all. I disconnected the HDMI while audio was on and nothing carried on

#11 Posted by TruthTellah (9033 posts) -

@fallen189: Do you have another monitor you could try using to test getting headphones to work?

(also, have you just tried reinstalling your audio driver? I figured that might be the first thing you did, but I don't know.)

#12 Posted by Fallen189 (5006 posts) -

@truthtellah:

Unfortunately not. Redoing all my audio drivers as we speak. At this rate I'll go out and buy a VGA cable and see if that works

#13 Posted by Mijati (921 posts) -

Seems likely to be an issue with your drivers (or maybe even a hardware fault with the ports). HDMI audio goes through AMD's own drivers so it makes sense as to why that works while any other audio connection does not.

#14 Posted by TruthTellah (9033 posts) -

@fallen189: Oh, and if this is a AMD issue, maybe right click the Sound icon and check the Volume Mixer. You should be able to disable AMD hdmi from there. (just in case that's what you are using)

#15 Edited by Fallen189 (5006 posts) -

Tried anything and everything that people have suggested, and nothing works. Maybe my Pc is just fucked, who knows.

I've tried enabling and disabling everything, but fuck all works. No idea what to do anymore, I'll probably just give up. I havent got a fucking clue as to why my PC can't detect there's headphones plugged in when I'm looking right at it.

Kind of frustrating. When my audio jack in my TV worked, I'd just plug into that, but now that's fucked somehow. It'd be annoying to have to buy a new TV for this, as nothing else works

#16 Edited by HoboZero (187 posts) -

Hate to see someone give up :( I am running an identical setup to what you describe, maybe I can help

I think Mijati is on the right track - in the screen you posted, you should see an entry for "Speakers" that does not say "AMD High Definition Audio Device" under it. Either the system's onboard audio is disabled or its drivers are not installed. Some things to try:

  • start some audio playing with your headphones plugged in, then disconnect the HDMI. The system should send the audio to whatever outputs remain. If you get sound out of your headset, then the onboard sound card is working and we just need to find the setting to change. If not, then its probably disabled/busted
  • Open up the Device Manager, and have a look for any "Other Devices". These are devices with no drivers loaded. If you see any generic devices under that heading like "Multimedia Device", that would be your onboard sound card, and it will need some drivers to function
  • Finally, if you don't see any unknown devices, and can't locate your onboard sound card in Device Manager, have a look in your system BIOS. There will usually be a section for Integrated Devices, under which the onboard sound can be enabled and disabled.

Hope that helps :(

#17 Posted by Yesiamaduck (1069 posts) -

Tried anything and everything that people have suggested, and nothing works. Maybe my Pc is just fucked, who knows.

I've tried enabling and disabling everything, but fuck all works. No idea what to do anymore, I'll probably just give up. I havent got a fucking clue as to why my PC can't detect there's headphones plugged in when I'm looking right at it.

Kind of frustrating. When my audio jack in my TV worked, I'd just plug into that, but now that's fucked somehow. It'd be annoying to have to buy a new TV for this, as nothing else works

The Audio Jack isn't the problem, considering the sound device isn't showing at all something tells me it's either a driver issue or the soundchip/card is damaged.

#18 Edited by EXTomar (4724 posts) -

I agree. What appears to be happening is "the mixer" only knows of one and only one audio output device which is on the graphics card. You need to figure out if the "on board audio" is disabled or broken before you can change the setting.

Depending on how "old" the "on board audio" is it may support PNP behavior which will automatically solve this issue because it "knows" if there are speakers or headphones plugged in and reconfigures the mixer automatically.

#19 Posted by VierasTalo (776 posts) -

There's one way of going over this; Your PC probably has other outgoing ports for visuals other than that HDMI. VGA or DVI maybe? Those don't transmit sound, so get a DVI/VGA->HDMI-block to go there, and you'll only get image to your TV and sound from your PC.

#20 Posted by diz (918 posts) -

Your internal sound card (if you have one) may be disabled in the computer BIOS. It might be a good idea to reboot and go into the BIOS settings (often done by pressing F3 or DEL keys when your computer boots) to look for a disabled on-board sound device.

Good luck anyways!

#21 Edited by fatalbanana (188 posts) -

I had a similar problem to this and I found a cool trick that fixed it. Get a headphone splitter and an auxiliary audio cable. Plug the headphone splitter into your speaker input on your pc, plug your speakers into one end and the aux cable in the other, plug the other end of the aux cable into your tv's dvi audio port (if you have one if not try the other audio ports). This makes audio play out of both your speakers and the tv at the same time so just lower the volume on your tv and plug your headphones right into your speakers or pc.

If this doesn't work or isn't what your looking for look in your tv's settings and see if there is an option to choose speaker output and switch it to external speakers and see if that works.

If all else fails try this; Samsung tv's are weird about sources so go to your source menu, highlight your pc source, hit tools or options than rename the source to dvi pc and that should make sound not come through your hdmi cable.

#22 Edited by I_Stay_Puft (3364 posts) -
@fallen189 said:

@i_stay_puft: @truthtellah: .

It just hits the TV, avoiding the PC jack alltogether.

I tried that, but it doesn't show the headpone icon. This is all I get

From your image I see your disconnected devices so I wonder if you can also see your disabled devices? To do this right click on this screen any of the devices and make sure "show disabled devices" is check marked. See if maybe your headphones are under disabled.

If the headphones still don't show I'd recommend what others have been saying and check to see if your audio drivers might be disabled or uninstalled by accident. Another thing you could possibly check is the AMD control panel and see if their might be sound options under there that might be effecting your sound setup. I don't use AMD but I know with the Nvidia control panel there are some settings to play around with. Also I'm kinda confused about where you were initially plugging in your headphones, were you plugging it into a audio out on your actual television? Like for my computer monitor which takes hdmi, vga, dvi if I wanted to I could plug a set of headphones to a normal stereo jack in the back of my monitor and it would allow me to listen to audio if I had my monitor connected by hdmi. If not this and it's connected directly to your pc how many jack do you have? If more than one which one is it plugged into?

If all else fails you could buy some sort of usb sound card adapter or just go the full route and buy a new card all together. I'd definitely recommend what others have tried before even thinking of purchasing something new. Could be simple as AMD disabling something when you connected it by hdmi.

#23 Posted by Fallen189 (5006 posts) -

Lots of wicked suggestions here, cheers lads. I'll get on them tonight and let you know once I exhaust them/find a solution

#24 Posted by MrKlorox (11209 posts) -

There is probably an option in your motherboard BIOS that allows you to disable the onboard sound chip. You may have disabled it at some point because you knew you would be using an external solution and forgot about it. It happened to me last year when I got a receiver and uninstalled my X-Fi card and I needed a second set of speakers to let me hear my PC while the receiver was switched to one of my consoles.

#25 Posted by Fallen189 (5006 posts) -

So I've exhausted everything in here and still got nothing unfortunately.

Went into the bizarre bios and had a fiddle. Changed hd audio from auto to on, but still nothing. Tried everything in the thread and still found nothing unfortunately. It's just weird, I guess. Pretty disappointed that there is no easy fix to this solution, but I guess that's the problem with using a PC, right? I've no ideA what's left to try, but if anyone has bright ideas, I'm all ears at this stage.

I'm still not sure why the hdmi audio appears to override my on board things, but I've only ever used a TV through hdmi as a monitor. I'm out of ideas here lads. I might just buy a new TV at this rate and use a new audio port.

#26 Posted by Fallen189 (5006 posts) -

Ok I fixed it. Turns out my motherboard wasn't detected in regard to audio, so windows installed some gypo drivers for audio. I went to my motherboard website, completely reinstalled all my motherboard drivers and I'm set. Thanks so much everyone!

#27 Posted by TruthTellah (9033 posts) -

@fallen189: Great! Knew it must be some kind of driver issue. Glad you eventually found the right drivers to get it working properly for you. :)

#28 Posted by I_Stay_Puft (3364 posts) -

Ok I fixed it. Turns out my motherboard wasn't detected in regard to audio, so windows installed some gypo drivers for audio. I went to my motherboard website, completely reinstalled all my motherboard drivers and I'm set. Thanks so much everyone!

Glad to hear dude. Happy gaming.