Avatar image for aragorn546
#1 Edited by aragorn546 (186 posts) -

Alright, i know giantbomb is not technically a tech site, BUT I have found that the GB community has a great many talents. I wanted to seek the GB community for help with this problem:

So I built a HTPC (home theater PC). It has been working fine for months. I was using a gigaware USB wireless keyboard with a touchpad built in for navigation. It was working PERFECTLY until about a month ago. The connection between the touchpad and the HTPC became a bit problematic (would cut out occasionally.) This afternoon it just simply stopped working. After replacing batteries, switiching usb ports and all that good stuff I figured the USB ports were fried...except this happened while i was watching a movie stored on my USB hard drive. It seems that, for whatever reason, my PC simply will not recognize input devices like mice and keyboards through usb. I tried using wired USB devices and still no dice. The devices are getting power.

worst part: it is a micro atx board so there are no PS/e ports on it to plug in an old keyboard or mouse.

I cannot interface with the computer AT ALL to try and fix this. Any suggestions?

Avatar image for korwin
#2 Posted by korwin (3824 posts) -

Can you interact with it outside of the OS? If you can still use the keyboard and mouse during post and the BIOS/UEFI menu's then there might be a funky conflict going on at the OS level. It wouldn't be the first time I've seen USB devices misbehave for no apparent reason. If things aren't working at the BIOS level try giving your CMOS a kick in the pants with a hard reset.

Avatar image for aragorn546
#3 Posted by aragorn546 (186 posts) -

Alright, so no dice on any of the suggestions already. Removed cmos battery and still nothing. I am KICKING myself for not installing splashtop on this thing when i first set it up. Any suggestions guys? I would hate to have to eat it on this motherboard