#1 Posted by GERALTITUDE (5315 posts) -

Does anyone else get slightly annoyed when dealing with the PS4 eject button? I want to know if maybe mine is a little broken or if they are all like this. I find that pushing the eject button doesn't really work consistently, and that I have to push with my nail, pretty hard. And sometimes a few times over to get it to register.

At first I thought it was just me getting used to the design, but now I'm not sure. I guess there's probably an Eject Disc option through the controller? Not a big deal but I might consider swapping it if it's busted.

For the record I love my PS4 not here to be starting something just genuinely want to know if it's just me. Peace and love

#2 Posted by Marcsman (3463 posts) -

I can barely find mine. Never used it. And yes you can eject discs with your controller. use the Option button.

#3 Posted by BD_Mr_Bubbles (1834 posts) -

If your having to try that hard then yes something is probably wrong with the button, I have had no such issue and find both power and eject responsive to a simple touch. Yes there is and eject option from the home screen select options then eject disc.

#4 Posted by Demoskinos (17239 posts) -

@geraltitude: You just have to simply touch it. The actual part that registers the button press is the part closer to the disc tray itself. You shouldn't have to really jam on the button at all.

#5 Edited by MariachiMacabre (7097 posts) -

Huh. Odd. Mine hasn't given me any issues. Like @demoskinos said, I notice that the "button" is only really under the portion closer to the slot itself.

#6 Posted by jsnyder82 (827 posts) -

Both of those front buttons are fucking terrible.

#7 Posted by MonkeyKing1969 (5153 posts) -

I've gotten in the habit, even with my PS3, of just using the PS button or using the circle button to eject discs.

#8 Posted by Spoonman671 (5486 posts) -

I've never used it.

#9 Posted by Tearhead (2423 posts) -

@geraltitude: You know both buttons are capacitive, right? Why are you using your nail?

Anyway, I wouldn't know if they're difficult to use, because I hardly use them. I just use the controller to turn it on/off and I don't have any disc based games so I never use the eject button.

#10 Posted by Strife777 (2006 posts) -

You can't "press" it, no matter how hard you push. You just need to touch the right place. I've had a few occasions where I had to try a few times, but I just figured out you need to touch a little closer to the disc tray.

If that still bothers you, you can just press the Options button on your controller on the game's icon, it'll give you the option to eject the disc.

#11 Edited by GERALTITUDE (5315 posts) -

Thanks for the replies, I tested it a bunch of times and I just think mine PS4 is a little wonky. Sometimes I tap it and it works, sometimes I have to leave my finger for a longer time, and sometimes it just doesn't do anything.

I'll just use the controller I guess.

#12 Posted by Unlogik (171 posts) -

I have the exact opposite problem. My power and eject buttons are too sensitive and I turn on the PS4 every time I dust.

#13 Posted by LiquidPrince (16757 posts) -

Maybe it's because you're using your nails... It's a capacitive button, meaning it requires a touch from flesh for it to work, similar to touch screens. But yeah it is pretty well hidden.

#14 Posted by ch3burashka (6088 posts) -

Just mouse over the game icon and drop it into the recycling bin.

#15 Posted by Marcsman (3463 posts) -

"UPDATE" I found it last night. Still not gonna use it.

#16 Posted by spraynardtatum (4342 posts) -

Use the pad of your finger. I barely even have to touch it for it to work.

#17 Posted by Kidavenger (4058 posts) -

For mine, I can't just touch it and have it work reliably, I have to swipe my finger from the top down, doing that it works every time.

#18 Posted by hurricanehaines (47 posts) -

I'm with @kidavenger, I always roll / wipe my finger down the button face, until it beeps at me. I'm not a big fan of those types of buttons, the new 360's were always getting accidentally turned on (oo-er, madam) or spitting out the CD tray as your child or pet brushes past it.

#19 Edited by GERALTITUDE (5315 posts) -

So, according to the internet some folks just don't transmit heat as well as others. That might explain why sometimes my iPad/iPhone seem to ignore me completely. Maybe I'm just not capacitive enough... :(

Maybe it's because you're using your nails... It's a capacitive button, meaning it requires a touch from flesh for it to work, similar to touch screens. But yeah it is pretty well hidden.

lol I should never have mentioned the nail.

I only use my nail because using my thumb doesn't work, but if I press hard with my nail I can get it into the crevice where the eject button is, nahmean?

For mine, I can't just touch it and have it work reliably, I have to swipe my finger from the top down, doing that it works every time.

This actually works really well! Maybe I just need a longer press.

PS. Sorry your resume thread turned so critical, I was just laughing at some details I thought were funny. Lol didn't expect it to turn into KIDAVENGER YOU ARE EMBLEMATIC OF EVERYTHING WRONG WITH HIIRING!

@hurricanehaines: yeah capacitive buttons are intensely inferior to real buttons. Played some GameCube last night and that is a satisfying power button.

#20 Edited by Flappy (2414 posts) -

The only issue that I had with mine was coming to the realization that there was no disc tray or anything. Since I never bought an OG PS3 or whatever, I never realized that you just have to present the disc to the drive and let it accept it.

I'm not ashamed to admit that I spent a solid 45 seconds rubbing the eject button while my PS4 scolded me with its Beep Beep Beeps.

#21 Edited by Mittt (72 posts) -

Now that you mention it....was the Gamecube the last great console power button? I can't think of one console power button since that one that I have liked.

#22 Posted by Gruebacca (791 posts) -

I find that my buttons have a bit of lag before they register. They're surely not as good as the original ps3 buttons.

Two tips: 1. Don't use your nail, and 2. Swiping helps a lot.

#23 Posted by GERALTITUDE (5315 posts) -

@mittt: Hmmm. Definitely the last great one. After that the consoles (360, PS3 Slim, Wii) all have buttons that just barely depress when you push them down. Not only does the GC have that awesome power button but the light on the front is so giant and orange and the boot up music is so fast it hits just after the power comes on. All in all a pretty amazing start up sequence.

#24 Posted by ILLUMINOTIKMOTIONFILMS (2 posts) -

Funny I googled this issue and I'm not alone. My question is if I press the eject button hard or with pressure will that damage the button or ps4 itself?

#25 Edited by psylah (2285 posts) -

Is this where we're at now? Pressing a button is troublesome and confusing?

#26 Posted by Maximus_VI (63 posts) -

Took me a few presses to eject a disc last time I tried. I'm definitely gonna give the swipe technique a go next time.

#27 Edited by nbsmola (13 posts) -

I had a problem with my first PS4 where, while turned off, it would randomly turn on and eject the disc. I'd wake up and find the PS4 on with the disc sticking out of the system. Tried everything. Turned it vertical, took the rubber pieces off the bottom etc. Finally got sick of it and sent it in to Sony. They sent me a new one and have had no troubles. But, yea, that eject button is a pain.

#28 Edited by Fattony12000 (8153 posts) -


#29 Edited by TheHBK (5664 posts) -

My PS4 burned my dog. Now I need a new dog.