• 56 results
  • 1
  • 2
Edited 1 year, 3 months ago

Poll: So... how many times has it crashed for you on the PC yet? (200 votes)

Not at all 52%
A couple of times but I should really be doing something else so it's probably a sign 33%
OH GOD MAKE IT STOP 15%

Are they patching this game at all any time soon? I lost two hours of progress :(

I'm running it on a high end PC by the by on Windows 7.

#1 Posted by dudeglove (8276 posts) -

And by two hours I mean I flat out lost two saves since the last session that don't exist any more.

#2 Posted by Chaser324 (6744 posts) -

I had one crash during the last mission, which was actually initially a bit confusing because of when exactly it happened.

Moderator
#3 Edited by cloudnineboya (845 posts) -

No crashes but it stutters a lot which is annoying sometimes. Edit: now i am going to save more regularly to try avoid this,TY for the heads up!.

#4 Posted by Capum15 (4995 posts) -

Only had it crash twice in about 22 hours. One infinite loading screen too, but overall, not bad.

#5 Posted by CaLe (4052 posts) -

Every time I try to alt-tab. No crashes besides that.

#6 Posted by RawknRo11a (568 posts) -

None so far (fingers crossed), although the xbox 360 version has been a bit buggy, mostly in co-op

#7 Posted by Happenstance (468 posts) -

Ive played 6 hours so far, no crashes yet.

#8 Posted by rebgav (1429 posts) -

I've had a single soft-lock in the 20-something hours that I've played. I've seen it crash a lot on livestreams but haven't seen anyone actually lose a save. It seems very odd that it would roll back two manual saves.

#9 Edited by MildMolasses (3229 posts) -

It crashed on me once. I did have a few freeze-ups that I'm pretty sure were related to my internet connection going down. I think the same thing happened during the QL for the Bureau.

That sucks that you lost progress. When I restarted after my crash, I was right where I left off

#10 Posted by Iodine (550 posts) -

Luckily I have had it crash zero times, there was one 15 seconds lock up, but nothing other than that

#11 Posted by Krullban (1062 posts) -

0. But I've encountered a glitch where I went bald and I'm unable to change my hair.

#12 Edited by Iodine (550 posts) -

@krullban said:

0. But I've encountered a glitch where I went bald and I'm unable to change my hair.

Like Vinny?

#13 Posted by Stonyman65 (2871 posts) -

Only once so far and I'm about 55% or 13 hours in. It froze up completely and I had to alt/tab out and start it again. I think it might have had something to do with AVG running a scan or something, or the fact that my computer just couldn't take it. That being said, I had been playing the game for like 6 hours straight at that point so I wouldn't be surprised if my PC just said "fuck it, it's too much" lol. But after that one incident it's been fine. Haven't had a single issue. Everything's been a smooth 60 fps on ultra settings.

#14 Posted by dudeglove (8276 posts) -

Also, are people launching this through Big Picture mode?

#15 Posted by Amikron (344 posts) -

The only issue I've had is that when I downloaded my character off the Saints Row website he had no pants, so the opening bits of the game have my character running around pantsless. Personally I didn't really see it as an issue though:

#16 Edited by SuperWristBands (2266 posts) -

It crashed about four times through my playthrough of ~14 hours. It sucked every time it happened but was the worst during the last mission. I'm not sure exactly how missions work for saving other than the game telling me that I'd have to start over if I were to load the game during one but it crashed before the first point in which the game says "Saving" on the final mission and I had to re-do it all.

#17 Posted by Colourful_Hippie (4488 posts) -

0

#18 Posted by TheHT (11781 posts) -

1 crash out of 23 hours played.

#19 Posted by jsnyder82 (763 posts) -

Never so far. And I've spent a lot of time in the game collecting clusters. Already up to 900.

#20 Edited by Irishmarkerhead (40 posts) -

One crash when I tried to start an activity and one post activity results screen I couldn't click through so had to restart the game (and redo the activity.) Otherwise its been pretty smooth so far!

#21 Edited by Humanity (10066 posts) -

One crash so far and that was during a co-op session.

Sometimes the game will freeze up for a few seconds but the audio still plays fine but I attribute that to my really old harddrive.

#22 Posted by Teoball (639 posts) -

I just finished an 8 hour session. No crashes or bugs so far.

#23 Posted by ZeForgotten (10397 posts) -

A few times, especially during one mission.
Changed it to Borderless Fullscreen-stuff in Display options and it never happened again.

#24 Posted by thebunnyhunter (1482 posts) -

only had one crash in 19 hours of playing, i only lost maybe 10 minutes on a combat heavy mission. Saints Row IV seems to be pretty good at auto saving after everything

#25 Posted by Sammo21 (3543 posts) -

I have had the game freeze twice in the menu and it seems to be when I accidentally try to access that upload feature for my character. When I cancel out of it there is a 50/50 chance that it will lock up. All the music still goes, the animations keep on trucking, but I can't do anything but ctrl-alt-dlt the game and then restart. I have started running into an issue with a loyalty mission (created a thread for it) but nothing really hard locks.

#26 Posted by MikkaQ (10344 posts) -

No crashes in about 9 hours of playtime.

#27 Posted by Ares42 (2796 posts) -

I had it crash in the middle of the final mission. So anti-climactic. Now I have to start it all over again =/

#28 Edited by PsychoPenguin (187 posts) -

I've had tons of crashes/bugs :( One time when I was supposed to be following another car the car seemed to go into a normal AI car loop, just driving around in random circles with no direction. After following it for about 15 minutes the game froze and crashed. When I reloaded the actual trip was about 1 minute. Still a very fun game so I'm pushing through despite it being unstable as heck on my system and I've never lost more than ~20 minutes once when I was deep into a mission.

#29 Posted by BD_Mr_Bubbles (1702 posts) -

Luckily not at all (fingers crossed)

#30 Posted by Metric_Outlaw (1172 posts) -

It crashed about two hours in for me and again just minutes before I beat the game.

#31 Posted by Sammo21 (3543 posts) -

Holy shit, I am getting a bunch of scripting problems in the game ever since I started the Asha loyalty mission.

#32 Posted by crusader8463 (14429 posts) -

I had one random crash to desktop while just running around the city dicking around trying to collect everything and lost a few min of gameplay. Then just to really test my patience once I had finished all the collecting/side stuff and just had the main storyline missions to power through, that's when the constant crash to desktops kicked in. In the last handful of missions the game seems to crash to desktop about 3-4 times and they were always at the last point of those long boring kill all missions that went on for like 15-20 min because you had to wait for stuff to spawn. And of course I would then have to replay each one all over again and hear all the talking bits again and again thus making them lose all freshness or humour.

It wasn't that big of a deal since the game does a good job of auto saving every few min, but replaying some of those missions was a real kick in the balls. I still got 24 hours of gameplay out of it though, and I might be getting another couple when a friend comes back and I help him with the co-op stuff.

I had two bugs that plagued me throughout the game that annoyed me more than any crash to desktop though. Tattoo's I put on my character on a whim would not go away. I thought they looked bad so I took them off, but every time I would go to the Image as Designed and modify my characters body they would always come back on and I would have to go hunt down a tattoo place to remove them again. As well, whenever I would leave the simulation to go into the real world, none of my characters makeup would stay on and it made her look really weird and fugly without it.

#33 Posted by ToxicFruit (1719 posts) -

I have had 2 crashes, one in the first mission and then one later when i was just gliding about

#34 Posted by Twinsun (495 posts) -

Too many to count. I've spent a bunch of time trying to fix the problem but to no avail. It really sucks..

#35 Posted by Korwin (3028 posts) -

Never crashed, did have the occasional scripting problem that forced me to restart a checkpoint but those kinds of things aren't really limited to a single platform.

#36 Posted by Vermisean (154 posts) -

No crash in eight hours so far... So I'm going to cross my fingers for now.

#37 Edited by Sammo21 (3543 posts) -

Game literally just hard locked for the first time.

#38 Edited by Nictel (2435 posts) -

Once in-game, right after it auto-saved so no lost time there. Most of the times it actually crashes after I try to quit. As in it just hangs in the main menu doing nothing and then says it crashed after a minute or so.

Besides the servers always being down and I am unable to download any characters the ride has been smooth and very enjoyable.

#39 Posted by CaLe (4052 posts) -

Just had my first non-alt-tab crash. It was during one of the final missions. I just wanna get the game over with at this point.

#40 Posted by Karkarov (3274 posts) -

It crashes a lot when I have played it for an extended period. I would say in total I have seen about ... 8-9 crashes. That is in roughly 31 hours of playtime though so not crazy bad. The only two that actually annoyed me and caused me to lose more than a hand full of minutes (auto saves!) was when I gold tanked a Genki's Mom and it crashed at the end.... and when it crashed halfway through the final mission which takes like 30-40 minutes start to finish.

#41 Posted by Chaser324 (6744 posts) -

@sammo21 said:

Holy shit, I am getting a bunch of scripting problems in the game ever since I started the Asha loyalty mission.

That's the only place in the game where I had any scripting issues, but they were pretty annoying. Asha kept getting stuck or just outright disappearing in those air ducts.

Moderator
#42 Posted by Sammo21 (3543 posts) -

@chaser324: That's the mission where you get her out of stasis or whatever. Her loyalty mission is an escort thing.

#43 Posted by Sammo21 (3543 posts) -

Just had my second hard lock. I am on the final mission. Total hard lock. This game seems to have more technical issues the farther in you go.

#44 Posted by Chaser324 (6744 posts) -
Moderator
#45 Edited by PhatSeeJay (3322 posts) -

Had hard locks every third hour or so. Had to replay a large portion of the last mission since it started me out back at the ship when I hit continue.

Bit annoying to say the least.

#46 Posted by Entus (254 posts) -

Hasn't crashed once for me yet.

I had a glitch where a helicopter I needed to get in spawned upside down and refused to land right side up. It was pretty hilarious.

#47 Posted by Jay_Ray (1127 posts) -

It was crashing every 20 minutes the first couple of times I played it but then updated my graphic drivers and no crashes since.

#48 Posted by HarlechQuinn (451 posts) -

No crashes for me so far, ca. 8 hours in (2 hours Coop play)...

#49 Posted by Sooty (8082 posts) -

Zero. No problems of any kind.

#50 Edited by desoda (120 posts) -

Twice. One hard lock during a save, but luckily it loaded fine.